[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

Everything works perfect:)

1 Like

To be able to answer your question we need both modded BIOSes.
Why did you try to replace the NVMe module of a fully NVMe supporting BIOS?
You cannot expect any noticeable functional benefit.

Thank you for your time and efforts,

I tried the same procedure on UEFITool but just after removing the Ip6Dxe tool and saving, it inserted a Pad-file. So I guess I can only do these manipulations that you did on MMTool?

Thank you for your time

Each BIOS modding tool works and behaves differently.
Since I tested the procedure of my last post only with the MMTool v4.50.0.23 and succeeded at first try, I recommend to use the same tool.

1 Like

Thank you, I 100% managed to make the modded ROM. Sadly there is no way to flash it because the HP tool is within an .exe file and it won’t do it. Thanks for the help nonetheless. Sad to see that computer not being used

It is fine, that you finally got the BIOS successfully modified without the creation of a natively not present Pad-file.
The specific procedure how to flash a modded BIOS into a specific mainboard (here: your HP one) is not the topic of this thread. Please look into the start post of >this< thread and use the “Search” option of the Forum by entering some keywords (e.g. “HP BIOS flash”).
Good luck!

So… all of this for nothing. The IP6 driver is gone because I cannot see the options to boot from it in the boot order menu. But the BIOS still cannot see the PCI-e NVMe Apple SSD. The NVMe driver might not be enough in the end… my 2019 9th gen Intel PC can see it and boot from it, but no luck with that HP AMI BIOS even with the NVMexpressDxe!!

So sad :frowning:

EDIT: thank you for your help @Fernando and for your guide, at least you can add in the first post that it doesn’t work if someone intends to reuse the PCIe NVMe SSDs from Apple Laptop (I replaced 3 of these, cause 120GB is often tight on the go, but I wanted to reuse them to boost old desktop PCs that can have a new purpose… like for that HP Pavillon 6 that supports Win11 from an SATA SSD with no hiccups… but I wanted to keep my SATA SSDs for PCs that don’t even have PCI-x…). In the case someone comes with the similar situation at least they won’t lose their time trying to mod and flash a BIOS for a SSD that cannot be booted even with NVME.ffs driver. I think the APPLE SSDs contain a driver within them, maybe… ? But then why my 9th Intel PC can see and boot from it? So sad, but thanks, again.


Please re-read the start post of this thread carefully.
No user of a mainboard without native NVMe support can see the name of an NVMe SSD listed within the BIOS BOOT menu. Nevertheless they are able to boot off it, if they follow my guide.
Tip: Enter the BIOS, enable CSM and look into the “BOOT” section. If you should see a device named “PATA”, your BIOS modding and flashing procedure was successful and you will be able to boot off the NVMe SSD by following the chapter 4 of my guide (“Installation of the OS onto the NVMe SSD”).

I can’t see any PATA device, I’m 100% sure that the BIOS file I flashed had the nvme driver, because I found the tool to flash a non-signed BIOS. Still with CSM enabled and looking at the BOOT order, I don’t see the PATA device.

I appreciated all your efforts but I’m rather sure it is because the SSD is Apple.

A BIOS modification and its flash should never been done in a hurry - the risks of a failure and the consequences are too severe.
It may be possible, that an Apple SSD is not shown within a non-Apple BIOS as “PATA”, but it may be possible, that it is not usable at all.
Maybe you have conceded too many extraordinary factors (combination of a very old HP system with an Apple SSD). The real life is sometimes hard for users, who want to get everything (if possible for free).

I did nothing in a hurry, I spent hours yesterday reading guides, I tried the less risky ones with CLOVER and DUET but both ways couldn’t never see the Apple SSD, no mater which versions of which drivers I injected, so I came to the BIOS mod in the last resort.

As what I can affirm, that same Apple SSD onto a PCIe adapter is totally seen on a 9th gen Core Intel platform with MSI BIOS and I can boot from it with no other strings attached.
I wish I could try another “normal” PCIe NVME SSD but I don’t have an adapter for these. I’m sure that the BIOS I flashed has the nvmexpress_dxe.ffs driver and I did how you mentionned to mod my BIOS (doing it with MMTool and checking with UEFI Tool). No harms were done and the computer still works.

But no PATA device or nothing appear, even with the right BIOS settings.
Well believe me I did nothing for “free”, I bought that Apple PCI adapter for 16 euros, which is rougly the price of a SATA 120GB SSD that I could have bought instead. But I wanted to REUSE and not buy more EWASTE.

I totally get that your guide and the tools are “free to use” and I do appreciate all your time and help, but I don’t think I did any mistake and doing it in a rush. It just simply doesn’t work for me. The system isn’t that old. It’s 3rd gen Core Intel, some people did get NVMe support on late Core 2 Duo platform from 2009. I’m 99.9% sure the reason is because it’s a Apple SSD on an adapter. Heck, even Clover can’t see it and it’s made for Apple hackintosh at first!


EDIT: Even on a motherboard with NATIVE NVMe support, this guy cannot get the same Apple SSD on adapter to be seen as a bootable device, not from the BIOS or from Clover. RIP


The fact, that the NVMe SSD is not listed within the BIOS, does not mean, that it has not been detected by the BIOS and is not usable with your HP system.
If I were you, I would try to install Win10 onto the NVMe SSD according to point 4 of my guide. Maybe it will be successful.
Another option is to look for the NVMe SSD from within a Windows OS, which has been installed onto another disk drive. You have to run the Disk Management, because the NVMe SSD is neither initialized nor formatted and cannot be shown by the Windows Explorer.

Thank you Fernando, believe me I tried multiple times. Windows 10/11 boot environment sees the Apple SSD, I did shift + F10 and typed diskpart then wiped the disk from the setup. I tried both GPT and MBR ways of installing Windows 10/11. The setup copies the files then the computer reboots but it only sees the USB drive with Windows setup. If I unplug the said USB drive, it doesn’t boot on the Apple SSD. I have a Windows To Go SATA to USB Adapter that contains Windows 11 and it boots from USB and I can see the Apple SSD within the Device Manger and Disk Manager. If I remove the Apple SSD from the 3rd gen Intel HP desktop AFTER Windows setup copied the files and that I put into my self-built 9th gen Intel desktop, and then proceed to boot onto the Apple SSD the setup continues with account creation and basic settings. Then I arrive onto the desktop. If I tried to put the Apple SSD back into the HP, it won’t boot from it. GUID/GPT or MBR. Windows 11 or Windows 10.

Only internal SATA or Windows To Go SATA to USB will boot.

Hello Dear!
I thought there would be some changes with this upgrade. well i uploaded the files as requested. Grateful for the attention! :slight_smile:
X79SUP5.F5F_MOD.zip (7.7 MB)

Windows can only see and manage an SSD, which has been detected by the BIOS.

These are the requirements to be able to boot off an NVMe SSD:

  1. The mainboard BIOS must contain an NVMe EFI module (only exception: Samsung’s 950 Pro has an NVMe Option ROM) and the BIOS settings must allow booting in UEFI mode.
  2. The OS partition must use the GuiMode Partition Table (GPT). Only the Samsung 950 Pro can natively use the LEGACY MBR partition scheme.

As soon as I have the required free time I will do a deeper look into the BIOS files.

The v5 NVMe module is not an upgrade, but just an optimization of the formerly offered v4 module. There is no difference regarding its function.

Thank you for your time! :clap:

Before I modded my BIOS, I could see the NVMe Apple SSD inside the Device and Disk Managers, that, within another install of Windows on a SATA SSD.

So do you mean that BEFORE I modded my BIOS, this later was already seeing and reporting my Apple SSD?

I honestly think you can made an exception for the Samsung 950 Pro, AND you can now make another exception for the case of NVMe Apple SSDs coming from 2013-2017 MacBooks (Pro and Air). These were mainly made by Samsung, maybe that’s the reason why they are another exception? I tried everything to boot from it on the HP desktop. Again, I could install Windows on it, but even if I have literally zero SATA devices, BIOS set to boot UEFI, Legacy disabled, I just can’t seem to get the HP to boot off the Apple SSD. After Windows files are copied, it won’t boot. If I put the Apple SSD in the modern desktop: it continues the setup. I’d like to try again, really, but I read your guide thoroughly and unless I’m really blind, I did everything right. It just won’t happen. Best thing I can do is buying a M.2 NVME to PCI-e adapter and try my Samsung 980 SSD that I currently use on my main rig from 2019, by installing it on the HP with the modded BIOS.

By a comparison of both modded BIOSes I cannot find any reason why one worked and the other not.
Please attach the original BIOS F5F.
Question: Where did you get it? I couldn’t find this BIOS version on Gigabyte’s Support page for your mainboard.

You must select revision 1.1 to find the correct BIOS on support page. But I attached the original here. :slight_smile: https://www.gigabyte.com/Motherboard/GA-X79S-UP5-WIFI-rev-11/support#support-dl-bios
mb_bios_ga-x79s-up5_f5f.zip (3.9 MB)