[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

Welcome to the Win-RAID Forum!
The suffix of the BIOS file doesn’t matter. Only important is, that it is an AMI UEFI one.
Good luck!
Dieter (alias Fernando)

hello sir good evening from philippines any tutorial for asus p7h55m 1st gen lga1156?

non uefi board could read these:


today I flashed my uvme bios mod as posted earlier from within an efi usb boot stick with
fpt.efi -F -bios biosfilename
and then installed a pcie 1x nvme adapter with a new nvme ssd.
Then I did a
sc.exe config stornvme start= boot
in the old windows installation and then proceeded to
restart from a linux usb stick and copied the sata attached ssd’s data over to the nvme ssd.
Then I shut down the computer, disconnected the sata ssd and booted from the nvme ssd.
I also used the windows 10 tools to extend the windows partition on the nvme ssd.

And I am very pleased that the nvme bios mod for the Dell Inspiron 3847 works.

Thanks for all the information provided here!


I’ve modded an ASUS B85M-E (3602) BIOS and added the v5 NVME DXE (NvmExpressDxe_5.ffs) to it.
Can someone verify if this modded file by me is safe to flash and will work to enable NVME booting?
I checked the report and generated an UEFITool diff of the original 3602 BIOS and the modded BIOS, the only difference seems to be a removed bit of free space, and the new module.
Thanks in advance, and happy holidays.

Welcome to the Win-RAID Forum!
I have compared the content of your modded BIOS with the content of the original one and didn’t find any mistake.
So the modded BIOS is ready to be flashed. Please read the chapter about ASUS mainboards within the startpost of >this< thread.
Good luck!
Dieter (alias Fernando)

Thank you for acceptance to the forum. Sorry, does the BIOS update v2203 for the P8Z77-M motherboard include NVMe support? A few days ago I bought Kingston K3000. I put it in the computer on adaptor to PCIe slot. However, only Windows sees it, because I cloned my system drive to it (Macrium Reflect).

my comp P8Z77-M, i3-3240, AMI 1708v. 2012-11-09, 8DDR3, Win11 22621.900.

Welcome to the Win-RAID Forum!
The latest BIOS 2203, which is offered by ASUS for the P8Z77-M mainboard, doesn’t contain any NVMe EFI module (I just have checked it). That is why you are not able to boot off it.
My advice: Look into the start post of this thread and simply follow my Guide. It is much easier than you may think.
If you should not be able or willing to do the required BIOS modification yourself, please start a new “Request” thread within >this< Forum section.
Good luck!
Dieter (alias Fernando)

Hi there , i was trying to make a MSI B85M-G43 NVME Mod (I know that there is a supposed mod for it but its actually for the B85-G43 version), and the padding thing is missing. Im attaching a screenshot here for reference (top NOT modded, bottom MODDED)

also the bios file uses some weird format called “390”. i saved the file and it showed up as “(biosversionblahblah).390**.rom**”. should i be worried about the .rom thing ?

Yes read the guide again related to the pad file verification and methods used. File name can be simply renamed as this is no relevant issue, the pad IS.

EDIT: Try open your eyes a bit more…

Step 2 - BIOS modification (2 alternative Methods):
c) Verification of the successful insertion

Could you provide me the guide related to the pad files? this guide only says to report the issue here.

i might be blind (probably i am) but i dont see any solutions than just the cause (wrong bios configuration). If my bios config is wrong or something what am i supposed to do ???

Thats why theres 2 methods to do the mod… AMI MMtool and UEFI tool (This is one also to compare)

3 tools to use AMI MMtool 4.x, UEFI tool 0.25 or 0.28, one of then will work and preserve the original pad-file in the mod file.

11 posts were split to a new topic: [Offer] MSI B85M-G43 NVME Mod BIOS

3 posts were merged into an existing topic: [Guide] How to flash a modded AMI UEFI BIOS

Hello, another blind guy here! :slight_smile:
I was trying to mod my Gigabyte H81M-S2H. And I stumbled upon something odd, so I just want to confirm it’s alright.
I modded latest bios from Gigabyte website.
When I used the MMTool, it said the “big” version exceeds the volume size (for both “as is” and “compressed” FFS options). The small version went through though. But when I verified it using UEFItool, I found one pad-file missing.

Then I tried modding the file using UEFItool, followed the instruction, inserted the small version, verified again - the pad-file was missing again. Tried both UEFItool 0.28 and 0.25.1, same results.

The odd thing is… I also tried to insert the “big” version using both UEFItool versions and it didn’t say any warnings about size (like the MMtool did). And when I verified the final files, the pad-files seems to be in correct places.

Could this last “variant” be actually ok?

You’re excused from this “blind” group…for now, still…

Ok do it again with MMTool 4.x and the small variant, but first remove some DXE


I have an MSI x79a GD65 8D main, latest BIOS version 4.8, I am trying to add NVMe support.

At the Step 2: BIOS modification, after inserting “NvmExpressDxe_5.ffs” file into the original BIOS, it shows the “NvmExpressDxe_5.ffs” is the last module in the list. (CORRECT)

But after saving the moded BIOS, I reopen it to check, and it shows that the “NvmExpressDxe_5.ffs” module is not the last one, in fact, it swaps position with the empty named module just above it (the one with “00010018” bytes size and GUID “05CA01…”).

As the guide, 2c step (verification) says the inserted module “NvmExpressDxe_5.ffs” MUST be the LAST ONE (ULTERMOST), so I don’t know how to move on?

Repeating the modification steps still results in the same issue.

I try to use UEFITool, open the original bios:

One pad file exists before the module with GUID “05CA01…”.

After inserting NVMe module (insert after), I have this:

Note that the pad file before the module with GUID “05CA01…” does not exist anymore.

But opening the output from UEFITool by using MMTool, it looks okay: (the NVMe module is the last one in “01” volume)

I have check that the file size if OK.

I believe that I fall into this red warning:

Pls help.

Please attach or post links to your modded and the original BIOS file.
Then we can try to solve the problem.

1 Like

Hi Fernando,

The original bios is downloaded from MSI site.

Both output files have issues described in my previous post.

Pls help. Thank you!