[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

I dont boot in Legacy mode.

Anyway it isnt an issue for me any more. I just want to report possible bug/issue:

  • When isserting usb drive, the POST is very slow. for example F11 to select boot drive, everything very slow.

My PC:

  • MSI x79a gd65 8d, bios 4.8 modded NVMe.
  • NVMe to PCIe card with WD SD530 NVMe.

does NvmExpressDxe5 fixed motherborad no boot with intel sata controller set to raid mode?

Usually they aren’t related, you boot from an RAID volume or an NVMe disk, with NVMe OS support.
If you have a specific issue you should try to explain it better, the NVMe mod is only the insertion of a DXE driver.

EDIT: That usually wont happen if the system is newly OS fresh installed, what you describe happens to a lot of users with their systems as the OS controller from AHCI to RAID has different HW ID’s, so it breaks the previous OS on the system.
Fernando explains this on one of his guides i think…or a the least i know that he warns users about it very often on several posts.

i remember i asked same question years ago, it’s not i am boot from a raid volume, it’s i moded my sabertooth z87 and my asrock f"something" z77, it work normaly, but after i set the intel sata controller to raid mode(normaly is ahci mode), then the mother board won’t boot, it just black screen when power up, no self check, everything is not working, like “a mother board with a damanged bios chip”

5 posts were merged into an existing topic: Recommended AHCI/RAID and NVMe Drivers

I added Samsung 980 with PCIe x16 adapter.
Unfortunately cannot boot with it ,even if BIOS show “Unknow HDD”.
Boot with W10 install (USB thumb) and can choose it for install but message is “Windows cannot be installed on this disk , your computer cannot boot with it”.
It’s recognized by W10 and i can clone W10 SATA => NVMe ,but still cannot boot with it .
HDTune return only 800Mb/s ,no more.

You people like to get in trouble and mess it all.
Perform a clean OS install in GPT (NO MBR), delete all partitions from the NVMe disk during OS setup destination drive, select now the RAW disk, install, done.
The NVMe being recognized in Windows is not a surprise at all, when not a system boot drive its just a regular storage NVMe disk.

1 Like

I took a lot of attempts and a lot of time, but I finally got it to work on my Asus m5a99x evo r2.0 motherboard!

Huge thanks for the guide! I didn’t think I could ever run a NVMe drive as boot on this computer, but this made it possible :slight_smile:

1 Like

Welcome to the Win-Raid Forum and congatulations, that you succeeded!
Dieter (alias Fernando)

Thank you so much for the post.
My question:
where and how to download the official Nvme ffs file?

What is different between

Read the guide again before posting unnecessary questions.

This is what you will need:
►Details: (open/hide by a click)

sorry, finally found them. thanks

This link seems lost? ’ Oops! That page doesn’t exist or is private.’

After having done the related test with my old Intel Z68 system I found in June 2015 the first time answers to the questions. My success report can be found here: https://winraid.level1techs.com/t/howto-get-full-nvme-support-for-all-systems-with-an-ami-uefi-bios/30901/117.

Hi, I am trying to add NVMe boot support for my Intel J3160 board. However, when I open MMTool, the window size is not correct as I cannot see some of the options.

I tried to use tab to insert the module. However, both “Save Image” and “Save Image as” complains about “Error in Saving”, and the saved image file is empty (0 byte).
I have tried to run the program in Windows 7 compatibility mode, the result is the same.

Share the bios dump file to analyse.

The BIOS file is here ThinMiniN3160Quad17.rar, which is located at “EFI/BOOT/BS00A282.BIN”.
I have tried UEFITool to insert the module, it does not complain. However, the BIOS file contains some pad-file and I do not know the modified BIOS is correct.

MMtool 5.x method, insertion DXE5 on VOL2, no pad-file created, as the original also doesnt have.

EDIT: The app windows size is not an issue on your side, happens to all.

Thanks, I tried newer version of MMtool, the window size problem still exists, but I can insert the module.

Many thanks for guide. I successfully inject NVMe boot support to my Asus H81M motherboard, i5-4460, even without OS Windows 8.1 reinstall ( OS was clonned from old drive to nvme). But after this change computer cannot enter to sleep, nor power of. PC restart itself instead of shut down. Will OS reinstall help ?

[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

Step 4 - Installation of the OS onto the NVMe SSD:

Hello again. I upgrade the processor on my FM2+ system, but it seems the bios lose the NVMe support, is not even show the device. If i put back the old processor, everything is ok. Do i have to re-update the bios with the modded one? Thank you in advance.