[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

I try flash bios by USB CH341A and downgraded bios 1904 (latest 1905) it really work.
I have a problem.
Can you help me check the bios of Mainboard Huananzhi X99 AD3 ver 2.0 ?
I can’t find ‘’ CSMCORE’’ in DXE volume of X99 Huananzhi but only 1 volume contains DXE driver.

Thank you.

I have checked your modded BIOS and couldn’t find a mistake, but to be sure I need the original BIOS for comparison purposes.

Although nearly all BIOSes have a module named CSMCORE within the (main) DXE Volume, there are some without that module. If a BIOS has just 1 DXE driver Volume, the NVMe module has to be inserted there.

After using this forum to successfully flash my BIOS in November 2020 to give my system bootable NVME support, I recently transferred that M.2 SSD boot drive to a new motherboard. I was going to stop using my old Asrock z77 Pro4 MB as I had a No-Display issue and had it packed away, when I realised I should clone the drive first. I found out the No-Display was a power supply issue and bought a new PSU. When reinstalling my old MB, the BIOS did not detect the NVME drive and I was unable to boot. :rage:

Having used the modded 2013 version, 1.80, of the BIOS uploaded by @Paulos7 that time in 2020, I decided to Mod the latest (2018/5/30) Beta BIOS from Asrock this time, using the file Z77 Pro4(2.00) ROM. When editing the BIOS, I had to insert the small NVME module, after I got an error message when trying the bigger one as first option. My modded BIOS is attached. z77pro4 MOD 2.00.zip (4.2 MB). I changed the MOD from the filename back to the original “z77Pro42.00” before flashing it, to avoid issues.

I flashed it and the system immediately booted into Windows, once again recognising my NVME boot drive. So I can confirm the modding of the Beta BIOS was successful.

One thing that UEFI Tool flagged was a checksum error in the original Beta BIOS downloaded from Asrock. I downloaded both the European and Chinese hosted versions of the file to check, and they were the same. So I ignored the error and modded the BIOS without any issues.

I’ve a chinese motherboard jingsha h81m.

The only part I found difficult is getting the original BIOS ROM for my board. Is there any way to extract it? Because there is no manufacturer’s website to download the BIOS.

How do i download my bios ROM?

And how/method do you pretend to flash the mod bios?
What ME FW version the board have, 9 or 9.1?

EDIT: “…use the flash utility directly in the BIOS”, certain bios security wont allow to flash modified bioses.
HWinfo can tell you the ME FW version if the bios has no info on it.

EDIT: Or run this tool and provide the resulting files, on a shared service of your preference.

1 Like

2 posts were merged into an existing topic: Hello to all the friends of the group

I plan to use MMTool and use the flash utility directly in the BIOS.
Where do I check the ME FW version?

Although this question has nothing to do with the topic of this thread, MeatWar gave you the answer >here<.

Hello friend, how can I insert the nvme model in a B85M D3V A please help me


The procedure how to insert the NVMe module is layed down very detailed within the Guide (= first post of this thread).

If you want help, you should describe your problem. Where is the original and your modded BIOS attached? A screenshot (showing your problem) may be helpful.

Ok. Done:

Intel ME Version: v9.0, Build 1482, Hotfix 30

Full Report of HWInfo file:

Now grab the resulted “x64_bios-region” file, extracted from the RAR, apply the mod according the guide, use method 1 or 2 and share it again for verification before flashing, if you want it.
Recommended method, AMI MMtool and small DXE variant.
The “verification” is also described in the guide using UEFItool for missing/added PAD file on selected bios volume.

For flashing, get the ME9.1 tools package from C2. (CS)ME System Tools and use the Intel FPT tool as CMD line ADMIN, preferably on the root of a disk:
Ex.: fptw64 -bios -f x64_bios-region_mod

The forum and provided information is NOT responsible for any user actions based on the gathered information.
Its a user choice ONLY regarding the risks of flashing mod files.
Good luck.

EDIT: Use the MMTool_x86_5.00.0007

1 Like

Thank you for your reply,

I’m getting this error while inserting module:

What’s happening?

I don’t know. Maybe the path to the NVMe module was too long. It is never a good idea to use a personal user folder for such actions.
Advice: Put the folder named NvmExpressDxe_Small into the root of drive C: or drive D: and redo the insertion.
If this doesn’t help, use another BIOS Modding tool.
Good luck!

1 Like

Changing path does’t worked but I used UEFITools for inserting module and worked.

Now, opening new file in MMTool:

As you said, I would appreciate it if you could verify the file for me before I flash it:

As I write this post I saw your EDIT about the MMTool version 5.00.0007. I will try too.

EDIT: With MMTool 5.00.0007 that worked, this is result file:

About the version of ME 9.1Tools, it’s 9.1 and not 9.0, ok?

File verified, original PAD file still present in the end of the worked bios volume.
The ME FW image on the system is 9.0 but the tools available work for both.
Report back, good luck.

1 Like

Done. I’ll restart and test for verify the result and back for post if worked.

Impressive!!! Worked!!! Perfect.

Thank you very much! @Fernando @MeatWar

You are amazing.

1 Like

hello there, I’m successfully doing a bios mod and installing windows on dell T5610, i was wondering can i doing a raid 10 for the boot drive? i found a plx 4x nvme card on Aliexpress and intrigue to try it.

and also. while i’m doing the bios mod, i’m using the nvme small version in compressed mode and i just saw on this forum there’s a resizeable bar mod. can i use both or better with nvme boot using clover and resizeable bar mod? (if clover can do raid 10 please let me know)

thank you

As long as RAID arrays and RAID boot are supported form that card, it could be possible.
Careful with the seller/product description… regarding the card full features/supported, do not link the card for my opinion… i cant vouch for anything on AliExpress.
The DXE’s NVMe branchs are equal in their function, small or std.
Both mods, NVMe along with ReBar should also be possible, but better submit all the system info on the correct thread, related to ReBar