[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

6 posts were split to a new topic: [Request] NVme Support for Phoenix UEFI BIOS

I’m trying to modify the BIOS of an old Intel board DP55WB. The file cannot be decompressed by either MMtool or UEFITool.
Any idea why?

This is AMI bios based but specific for Intel, not a regular AMI Aptio IV Core bios file so several tools can’t handle it. Can be also an Insyde core based, as seen here.
What you may be looking for, is a more well-known structured bios image with all regions available, using a dump from the system should be what you’re looking for…

Anyway…most Intel mod files are impossible to flash with known methods, a SPI programmer is needed… you can confirm this on the forum, performing a deep search for several Intel mods attempts…

Thank You.

Hi Thank you for this helpful guide , I modded my ASUS P9X79LE BIOS successfully, but I have a problem .
The bios mod result is .ROM file and when I’m trying to update through UEFI ez flash I need a .CAP file … Does anyone know how to convert the file? I tried ASUS utility but same result .

Welcome to the Win-Raid Forum!
This is the thread about how to get full NVMe support, but not about how to get a modded ASUS BIOS properly flashed. The related thread can be found >here<.
Please read and follow the advices given within the ASUS related chapter of the first post.
Good luck!
Dieter (alias Fernando)

Thank you Fernando

I’ve been attempting to add NVMe support for a X10SLL-F board I’m using for a home server. I ran into the issue with padding described in this guide while trying to patch the DXE module in. The discrepancy I found looks like this, with the modded bios on the left. The pad entries under the highlighted entry seem to be missing.

I’m a new user, so it looks like I can’t upload attachments, otherwise I’d provide the bios files too.

Also, its worth noting that I tried just using the modded file form this post:

but the AFUDOS command seems to be hanging. I’ve left the system running for now, but I will probably go interrupt it and flash the unmodded bios for now so I can reboot.

Welcome to the Win-Raid Forum!
You are right - due to the big amount of pad-files it is not easy to get any NVMe module properly inserted into the BIOS file named X10SLL1.308.
Nevertheless I finally succeeded by using
a) the AMI Aptio MMTool for the BIOS modding and
b) the uncompressed “NvmExpressDxe_Small.ffs” module for the insertion.
As far as I could see all natively present Pad-files stayed untouched after the insertion of the NVMe module.
Tip: You will find the working MMTool v5.0.0.7 by doing a Google search for “MMTool Aptio 5.00.0007”.
Good luck!
Dieter (alias Fernando)

Thanks Fernando!
It actually looks like the BIOS from the other post I referenced did end up flashing correctly even though the flashing tool hung at the end of the process. But this is kind of an unsatisfying answer I think, so I’ll take a look at the MMTool you mentioned and see if I can get that to work.

7 posts were split to a new topic: [Request] NVMe mod GA-Z87 D3HP BIOS


Sorry I am having issues with my Supermicro board (X10DRU-i+). I got to the part of the instructions to show the volumes of DXE. But my BIOS doesn’t have a CSMCORE listed. And the note placed in the instructions doesn’t make sense to me.

Note: In the very rare case, that no module named CSMCORE is listed, you have to search for the upmost Volume, which contains modules with the letters “DXE” within their name.

I’ve also tried to insert the EFI NVMe module. And all my “Insert after…” options are greyed out and I can’t actually put it into the BIOS. I’m quite stuck, and any help would be greatly appreciated.

EDIT: Well I didn’t get it figured out. But I did find this post SuperMicro X10DRU-I+ BIOS 427 mod for NVMe boot. Where someone already modded the BIOS for my mobo so I just used this and it worked great. So for anyone looking for it go to that post.

Welcome to the Win-Raid Forum! It is fine, that you finally succeeded and now can boot off your NVMe SSD.

The sense of this additional note was to help users, whose mainboard BIOS doesn’t contain a module named CSMCORE, to find within the voluminous BIOS the target “DXE Driver Volume”, where the NVMe EFI module has to be inserted. Note: There are a lot of BIOSes, which contain more than 1 DXE Driver Volume and it is very important to find the matching one, because otherwise the BIOS modification would have no effect.
Please explain why this part of my guide doesn’t make sense to you. I would be grateful for a better understandable wording.

Thank you very much for this guide. Unfortunately, I am unable to patch my Gigabyte GA-H87-HD3 bios without either getting pad files added or removed. I’ve tried with both MMTool version and 5.0007. I have tried all 3 bios versions that are available (F10, F9, F8). Compressed NvmExpressDxe_Small is the only option that isn’t too big.

Any help would be greatly appreciated!

@c0d3m0nk3y Welcome to the Win-Raid Forum!
Contrary to you I was able to get the NVMe EFI module inserted without getting any pad-files added or removed.
Solution: Let the UEFITool do the work.
Here is the result I got:

Good luck!
Dieter (alias Fernando)

1 Like

Awesome, the UEFITool seems to have worked indeed. I shied away from it because of your warning that you really need to know what you are doing when you use it but it wasn’t so bad after all. It even managed to insert the full-size module.

The one problem that I still have is that I can’t tell whether it worked. The flash tool seems to be flashing the modded BIOS (it says erasing, copying, verifying or something along those lines) but it was suspiciously quick. Unfortunately, I’ve had already flashed the unmodded F10 version before and now I can’t tell whether I have the modded one or whether the flash tool just skipped it because it thinks, there is no change. It still says no boot device found, but obviously that can have all kind of causes. It also won’t let me flash back to an older version.

I’ll have to play around with it a bit more. Either way, thank you very much for your help! Much appreciated.

This is ALL explained in the guide, the guide IS for reading not to “hang on a wall” like a paint…
The method for flashing the mod on this mb generation is using Q-Flash ONLY.

EDIT: Windows 8 WHQL features disable (CSM) if not mistaken, cant remember if it present in these bioses from Gigabyte

Thank you for pointing out that there are instructions that I had missed. Unfortunately, Q-Flash is what I have already used. There is no CSM option in the BIOS.

PS: I did manage to flash back to F9 with Q-Flash (previously I had tried my original backed-up F2 version) and then back to the modded F10 version. So I know that I am running the modded BIOS now. Unfortunately, I still don’t see any PATA drive. I’ve set everything to legacy but there is no CSM option

Ah ok, yes. I’ve had it set to “OS (other)”. There is also “Windows 8” and “Windows 8 WHQL”.

I did manage to get it to boot into Windows now! There is one catch though. I had to move the M.2->PCIe adapter card to the first x16 slot. For some reason, it doesn’t work in the x4 slot (the only other slot that fits), which is a bit annoying because now I either have to use onboard graphics or move the GPU to the slow slot.

If anybody know why that is, let me know. Otherwise, thanks alot for your help!

PS: Setting the PCIe speed of the port to 4x instead of leaving it on auto fixed the issue. Now I can also boot from the other slot!!

Congratulations, glad you figured it out, enjoy it.

1 Like