[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

Thanks Fernando, I thought I had found a link to the modded BIOS in this thread :grinning: If not, it was elsewhere on the forum.

I was hoping to use my existing OS rather than installing a fresh OS - do you think this would be possible?

It may be possible, but very difficult, because the formerly used OS knows nothing about the new system drive and the required new boot sector. Doing a fresh OS install is not only much easier and safer, but also much better for the system’s performance due to the loss of the old garbage.

1 Like

Thanks @Fernando I will go for that option!

I want to insert the full version not the compressed, but MMTool says “file size exceeds the volume size”.
I tried to delelte some items but caused some trouble in using.
How can I solve this problem?
The bios for my motherboard can be downloaded here:
https://download.gigabyte.cn/FileList/BIOS/mb_bios_ga-b85-hd3_v2.1_f4.zip?v=8c53ad16c9c539ce9fb6ee92e6346b8e

There’s no difference in using one or another in NVMe mod for the motherboard.
Some specific modules can be deleted if no intention of using it like PXE boot etc…it may not be suitable in some motherboards.
Also some bios language strings can be removed with AMIBCP tool when it matches the same insertion volume

Hi Everone,
I need help with a bios i modded following your very detailed instructions very carefully using the mmtool.
I can see PATA SM in the bios now but cannot boot my nvme m.2 patriot p310 which has my cloned win 10 on it.I am new to modding the bios and do not know very much about it. So please bear this in mind.
Gigabyte ga - f2a88xm - hd3 m.board
bios ver.f8f
Thanks

Read the guide on point#4 related to OS install, the guide is not intended for cloning OS or MBR partitions.
NVMe is for GPT and x64 UEFI systems, not legacy OS or partitions.

Sorry but I thought the mmtool was to add nvme support for legacy motherboards.
As already stated I am new to modding the bios.
If I am going about this wrong why not point me in the right direction ?

My friend…if you read the guide all your answers will be clarified and then you will see what you failed and im not to blame… the tools are for the mod operation, the OS part is a bonus, so THATS YOUR DIRECTION, READ IT.

Unbelievable… a free guide with all the steps and still its our fault of user ignorance and lack of support…as this was a TI 24h tech support forum and obligation.

@gadgett
Welcome to the Win-RAID Forum!
The fact, that you can see a device name “PATA” within the BIOS, verifies, that your BIOS modding procedure was successful and you are able to get Win10 or Win11 installed onto the NVMe SSD by simply following the related part of the guide.
Where did you read, that you can boot off a cloned formerly used system drive instead?
Good luck!
Dieter (alias Fernando)

Thank you for your reply and great advice.
I did’nt read that you could boot from a cloned system disk I just assumed that you could.
I have already cloned my system disk to a m.2 attached to a pcie1X adaptor card on my other PC which has a GA-A320-S2H MOBO and Athlon 950 cpu but this is more up to date.All worked well.So I thought you could do the same.

Hi
I wanted to run this bios mod.
Unfortunately, I get stuck when creating it. I have the problem “File size exceeds volume size”

I hope you can help me here is the link to the current bios

https://dlcdnets.asus.com/pub/ASUS/nb/G751JY/G751JYAS213.zip

Asus Rog G751JY-T7336

Thanks in advance

Even with the small DXE_4?

EDIT: Yes, the name is NvmExpressDxe_Small (6Kb) and ALL versions, standard, small, compressed…its all an NVMe DXE module so there is no wrong choice “blindly” using any one, the issue is the size taken on the insertion volume.

There’s also a small compressed of 4kb

he tells me the same thing about the dxe4

and I can’t find dxe4 small in the onedrive cloud. Only which ones are called small. But not known if 4 or 5

and now just blindly using one wouldn’t be the wisest thing to do
:smiley:

Alrighty, I am have modified my BIOS and I’m ready to risk flashing. I tried already, but the build date is “too old” x.X

Oh… you think that the Asus utility and securities will let you flash a mod bios… please, use your brain and safe measures.

You really can make your system death… Fernando warns in point#3…users dont like to read good guides… too much words, they just want it done.

https://winraid.level1techs.com/t/guide-how-to-flash-a-modded-ami-uefi-bios

Hello my friends. :slight_smile:

Yesterday evening I went to give my old notebook a bios mod… with a few hurdles but ok.

My problem is now. the bios is already modded and it is already on the notebook. I also find the entry nvme… in the rom etc.
“But I still have no support. maybe someone could take a look?

If anyone wants to help me. Just call. then the files come within 10 minutes :P.

Greets from Germany
Happy weekend :stuck_out_tongue:

NVMe mod flashed and confirmed so… windows install as next step?
Support… i dont “compute” the term… read the respective guide.
Its all there…too much reading? So sorry, the guide also took the author is time.

Greetings, I wanted to know if someone can help me, I have a dell optiplex 3040 with bios OptiPlex_3040_1.19.1.exe… I extracted the bin file has several, I want to modify it to embed the drive for nvme, the problem I have is that the “CSMCORE”, does not appear in my bios, and I do not want to touch anything until I am sure where to enter the information in the correct site I don’t want to damage the computer… Can someone guide me?

P.D.: I followed the guide but my bios is different and the work is more serious

@franciszek77
Welcome to the Win-Raid Forum!
To be able to help you I have to do a look into the pure BIOS *.bin file.
Please attach it as compressed .zip /.rar file or post a link to it.
Regards
Dieter (alias Fernando)