[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

Thanks, I tried newer version of MMtool, the window size problem still exists, but I can insert the module.

Many thanks for guide. I successfully inject NVMe boot support to my Asus H81M motherboard, i5-4460, even without OS Windows 8.1 reinstall ( OS was clonned from old drive to nvme). But after this change computer cannot enter to sleep, nor power of. PC restart itself instead of shut down. Will OS reinstall help ?

[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

Step 4 - Installation of the OS onto the NVMe SSD:

Hello again. I upgrade the processor on my FM2+ system, but it seems the bios lose the NVMe support, is not even show the device. If i put back the old processor, everything is ok. Do i have to re-update the bios with the modded one? Thank you in advance.

Your request is completely off-topic! If you want help, please start a new thread and give it a short, but meaningful title.

    Off-topic: (open/hide by a click)
    Have you recently flashed any original BIOS? This would have erased your previous BIOS modification.
    As long as the NVMe EFI module is within the in-use BIOS Region of the mainboard’s SPI chip, your system should support booting off an NVMe SSD.
    You can check it by creating an SPI dump and looking into the content of its BIOS Region.

A post was merged into an existing topic: [Guide] How to flash a modded AMI UEFI BIOS

Which module is the best? NvmExpressDxe_5 module or Nvme module from Z97/Z170. I tried using the NvmExpressDxe_5 module on MSI Z77ma-g45, but there is a problem that shutdown takes longer than the official bios if using Windows 10 non UEFI (HDD format MBR) even though bios fastboot feature already enabled

You better stay on the other thread you made before…and ask the user who did the mod if there were more “Inventions” done, besides what we can see or requested, in your screen captures.

Your current system bios is NOT using or loading the inserted NVMe DXE driver, as its on Legacy mode, not in UEFI… so the “catch” is what else was done…

I’m just asking which is better, the NvmExpressDxe_5 driver or the driver taken from Z97/Z170

You may not realize a difference, but I recommend to insert one of the NVMe modules, whose download links can be found within my Guide (= the first post of this thread).
They are newer, perfectly optimized and 100% matching all AMI UEFI BIOSes without native NVMe support.

I have modded the bios of MSI Z77MA-G45, the result is like the sc image. I downloaded the latest official bios, opened it, inserted mod NvmExpressDxe_5 in CMSCORE and then saved (using MMTool I have checked all the original files, there are no changes, only the addition of the nvme driver, no red notif. Have I done it right?

According to the pictures: Yes, everything seems to be fine!
Good luck for the flashing of the modded BIOS!

Hello, can I get some help on modding a BIOS file. This is the second BIOS that I am trying to MOD - with the previous one I didn’t have any problems, but with this one I do. The problem is that after doing everything right, verifying the inserted module is present in the modded BIOS file, I cannot flash it. BIOS gives me an error “Secure flash check fail”. Can anyone give an advice what could of I done wrong, or what I need to do to get it right. Could it be some kind of a checksum error or something like that?
The motherboard is Asrock FM2A75M-DGS R2.0, the latest BIOS is v. 1.60. I flashed this file and the operation completed successfully, since the one I was cooking didn’t work…

[Guide] How to flash a modded AMI UEFI BIOS - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

I found it and did it using the UBU tool, thank you. It worked

Hi, can anyone check my NVMe module? At left side the BIOS backup and right the modBIOS NVMe.

Edit by Fernando: Since the originally attached big sized picture was not appropriate for a check, I have removed it.
As MeatWar already has mentioned, the complete BIOS files (original + modded) should be attached as *.ZIP file(s).

Not even a motherboard model identification…nice indeed.
This not the proper way to check it and not according the guide.
And this capture screen is also not correct way, share the original and mod files here or in a sharing service of your preference.

Would someone please give me a hand with this Acer B75H2-AM (M4620GH) BIOS? I tried several NVMe modules, but MMTool complains about all of them exceeding the size.

I don’t mind if the filesize increases to be honest, even if that means soldering in a larger capacity BIOS chip.

BIOS Download:
m4620gh.zip (2.0 MB)


You can safe remove all network-related drivers from DpcDxe to Udp6Dxe if you don’t use UEFI network boot, in order to get some space on the bios volume.

Thanks, that worked.