HP 830 G6 ME firmware stuck in recovery mode

The Intel Management Engine on my Elitebook 830 G6 is stuck in recovery mode and is not functioning. As a result, the Intel audio device is not working.

I’ve tried flashing the bios to the latest version, which supposedly contains an updated ME firmware. The Management Engine Firmware update stage fails constantly with this message: “Update of the Intel Management Engine Firmware failed, because the target Intel Management Engine firmware update was found to be invalid”

Tried everything i could think of, incl. various CSME utilities which all refuse to interact with the ME component except for dumping a backup image of it.

Is there some way to force-flash this thing or some other way to shake it off recovery mode?

Many thanks.

Sound like corrupt ME firmware. Follow this guide:

Seems this is still ME 12 so this should be quite straightforward, dump will possibly work with fpt, problewm will be flashing if no service / FDO / … jumper can be found.

I did manage to dump the firmware.
I tried to simply flash it back & it failed. I don’t think there’s any jumper on that board.
This thing is a bit daunting to be honest, yet it pains me to dump a perfectly good machine over this issue.

Well, might be not soldered in, just the pads, working or not. And laptops rarely have.

That’s not necessary. A CH341 (possibly with a pogo pin adapter in correct width and maybe an 1,8V adapter) might do the trick.

Is this pic the correct model? The chip to the left of the DIMM slot very much looks like the bios chip. (Should be confirmed of course!)

Were you able to read the ME configuration with FIT without problems from the dump?

That’s a similar board, but not the same.
On my board, there’s a similar looking chip:

I haven’t tried to read the dump just to reflash it. I’ll do that soon.
I have an identical but defective board as well. Would it be a better idea to swap the bios chips between them? Assuming that’s the one I’m looking at… :slight_smile: