Installing XP SP3 on a newer laptop (circa 2012, Win8 Preinstalled), need AMD USB 3.0 drivers

Hello everyone! I had a decapitated laptop lying around whose only fault was that it didn’t have a screen (it got torn off…)
So I thought one way of bringing it back to life would be to turn it into a retro gaming station (since a mid-range 2012 laptop has equivalent power to a workstation of ye-olden times right?)

I tried Googling, thinking that I’d be able to install any OS I wanted, but I soon realised that for a laptop, it was easier said than done. The BIOS menu was severely limited, having almost no options to do much besides enable/disable Secure Boot and ‘enable legacy support for systems like Windows XP’, without giving us a IDE/AHCI controller switching option. Much to my dismay, many intellectuals from the internet adamantly held the point that Windows XP flat out could not be installed on modern systems due to a lack of USB drivers at text-mode phase of the setup (which is true, I was also of the same opinion when I used Rufus to make a Windows XP USB installer and it couldn’t boot up in the laptop)

Long story short, I was actually able to get Windows XP running, because there were clearly no physical limitations. I had to use Easy2Boot, which provided the AHCI drivers which allowed Windows XP to run on the system, and somehow added in PAE by itself so I could use 2.7GB of RAM on a 32bit system, Easy2Boot is awesome!!!

cough anyways, I was amazed that many drivers for my system existed, which I was able to source off the ‘Driver Search’ at DriverPack, (they have an amazing collection of Drivers but you shouldn’t run their automated DriverPack, it’s very janky and buggy, had to use System Restore twice and then decided to install drivers manually, which took an hour)

--------------The entire point of this wall of text above was to prove that Windows XP can be installed on modern systems, and to give you guys a backstory for this problem I’m stuck with---------------

After installing the drivers, I now have a 90% usable Windows XP installation, complete with GPU, Sound, and Network drivers (even found a driver for the fingerprint sensor XD). The rest of the 10% is unusable because I have 4 USB ports on my Laptop, 3 of which are USB 3.0 ports, and one of them a USB 2.0. Only the USB 2.0 port is currently working for data transfer and input devices. Having used Windows 7 for so long, I never thought a USB 3 port would be flat out UNUSABLE on this laptop without drivers. I thought it would at least work like a USB 2.0 port albeit with slower speeds (I don’t mind that at this point, I just want them to work). So an acquaintance suggested me this forum, which sounds amazing as you guys have a lot of experience working with XP, anyone wanna point me out to drivers that I can install to get these ports at least usable upto a USB 2.0 standard? Thanks in Advance.

Oh, and before you ask.

According to Device Manager: Other Devices > USB Controller(Yellow Question Mark)
Hardware ID: PCI\VEN_1022&DEV_7812&SUBSYS_18A6103C&REV_03\3&2411E6FE&0&81

EDIT by Fernando: To make the request more specific, I have added the word “AMD” to the thread title.
EDIT by AbdullahTrees: Thanks man, I don’t know how you figured out it was AMD, made some formatting changes to make things look easier to read.

One more thing… There’s two USB controllers, one for which I tried installing drivers by searching DriverPacks with the Device Instance ID (
The one for which I tried installing drivers reported that the installation failed cause the .inf file was made for Windows 95 or later (which doesn’t make sense cause Windows XP IS after Windows 95)

Other devices > [Yellow Question Mark] Universal Serial Bus (USB) Controller > Device Instance ID: PCI\VEN_1022&DEV_7812&SUBSYS_18A6103C&REV_03\3&2411E6FE&0&81
Universal Serial Bus Controllers > [Little Yellow Exclamation Mark] Universal Serial Bus (USB) Controller > Device Instance ID: PCI\VEN_1022&DEV_7812&SUBSYS_18A6103C&REV_03\3&2411E6FE&0&80

USB 3.0/3.1 Drivers (original and modded) (A. AMD USB 3.0/3.1 Drivers for AMD H-Series Chipsets)
Recommend that you uninstall the USB controllers that you have mentioned, and update them with the drivers from the link i gave you

Thanks a lot! I checked out the drivers and used this one…

It worked quite well initially. First I didn’t pay attention to the instructions in that page and was wondering why the drivers were failing to install. Then I realised I was running the installation off a USB drive XD so I had to copy the files to local and then pull out the USB drive, i.e. making sure the USB ports are all unused.
After I took out the USB drive though, the installation went quite nicely, and now I have this…

Other devices > [Yellow Question Mark] Unknown Device > Device Instance ID: AMDUSB30\ROOT_HUB30\4&8A736FC&0
Other devices > [Yellow Question Mark] Unknown Device > Device Instance ID: AMDUSB30\ROOT_HUB30\4&A1279A9&0

This is an excerpt from the instructions in the forum post you linked for the AMD Drivers
2. Expand the “Universal Serial Bus Controllers” section of the Device Manager and check the HardwareIDs of the listed USB Controllers (right click onto them > “Properties” > “Details” > “Property” >“HardwareIDs”) to find out, which of the Controllers is the one, where you want to update the driver software.
3. As first step you have to update the driver software of the USB 3.0/3.1 Controller.
4. After the reboot the Device Manager will show within the “USB Controllers” section devices with missing drivers. These are the USB 3.0/3.1 Hub Devices, which belong to the USB 3.0 Controller, where you just have updated the driver software.
5. Now you can easily install the missing USB Hub Device drivers by navigating to the related driverpack.

There seems to be a bit of a disconnect between the instructions and my view of Device Manager, as the USB Controllers whose drivers I installed were under ‘Other devices’. And as seen from the picture above, I have no devices with missing drivers inside the ‘USB Controllers’ Section, but 2 new devices have popped up with Device Instance ID seemingly related to the AMD USB drivers. I inferred from the instructions that a reboot was pending, and so I restarted my PC (PC crashed as ‘Windows is shutting down…’ disappeared, with BSOD: DRIVER_POWER_STATE_FAILURE)

these other devices are the usb 3.0 hub ones.

@AbdullahTrees :
As you already found out, the listed “Unknown devices” are AMD USB 3.0 Hub ones.
Why don’t you just follow the advices given within the start post where you found the download links?
This is what you should do: Run the Device Manager, do a right-click onto the first of the “Unknown devices”, choose the options “Update driver” > “Browse my computer” > “Search” > navigate to the “For Hub” folder of the “AMD USB 3.0 drivers v1.1.0.249 WHQL” and click onto “OK”.
After having finished this procedure for the first “Unknown device” repeat it for the other one.
Finally both devices will be listed within the “USB Controller” section of the Device Manager.

EDIT: I was too late. IntiMD has already answered your questions.

@Fernando @IntiMD

Hehe, I was doing a bit of work and my latest post was incomplete, I didn’t expect to get an answer this fast. My main problem is this:

I did attempt to install the AMD Hub Device Drivers! But when I selected the Hub folder for drivers, Windows reports that…

Basically, the drivers in the ‘for Hub’ folder are not being accepted as a valid driver for these devices. Even though the Device Instance ID suggests that they are related. This is what I wanted to say, hope you guys have some advice for this