Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

@lfb6 , @GlitchyHack , Thanks for your help.
Yes, I got error 433 when using the CSME file from the first page.
I have read the first post regarding updating CSME12. This procedure is too complex for me.
When using the CSME file offered from @GlitchyHack the error does not appear and firmware update is OK:

UpdateFW_vers_v120902072_step02_OK_DONE_13avril22.png



HWINFO64_Tool_13avril22.png

CSME 11.8 CON H DA v11.8.92.4222

CSME 11.8 COR LP C NPDM v11.8.92.4222

CSME 11.8 COR LP C YPDM v11.8.92.4222



I’m afraid you’re the wrong target audience for this thread, then.

My laptop didn’t restart upon wake for a long time as I can recall, since I updated to version 11.8.92.4222, after 4 days, my laptop did restart upon wake up, although it happened just once among hundreds of sleeping and waking up, but that is not a good sign :frowning: I really hope it is not the new firmware and it will not happen again

Maybe someone can explain to me, why since v12 CSME a CSME update can’t be done at the same time than a BIOS update ? My systems will shutdown, instead of restart, and then neither BIOS update nor Intel CSME update was updated?
Everytime I have to do first a BIOS update , reboot, Intel CSME update, reboot - or viceversa.
Hm

@plutomaniac
Attached find the TGP N 11.225 PHY I was missing on the list of the start page. Maybe it will help someone ?

TGP_N_11.225.256.2041_PRD.bin.zip (28.2 KB)

Not missing- Part of “G. Intel USB Type C Physical (PHY), PHY N TGP” => ‘PHY N TGP Repository r5.rar’ on Intel (CS)ME, (CS)TXE, (CS)SPS, GSC, PMC, PCHC, PHY & OROM Firmware Repositories

1 Like

CSME 16.0 COR LP A v16.0.15.1810

CSME 15.0 COR H B v15.0.35.2039

PMC ADP LP A v160.1.00.1026

PHY N ADP v14.527.505.8209

1 Like

Greetings, I have a Dell Ins 5593 with i7-1065G7
ME Info:
Intel(R) ME code versions:
BIOS Version 1.19.0
Vendor ID 8086
MEI Driver Version 2131.1.4.0
FW Version 13.0.55.1889 LP Consumer
LMS Version 2130.1.16.1
IUPs Information
PMC FW Version 130.1.30.1051
OEM FW Version 0.0.0.0000
IOM FW Version 4.12.0.0000
NPHY FW Version 9.0.1.0003
TBT FW Version 13.0.0.7103
PCHC FW Version 13.0.0.1005

When I tried to make an image to update ME (with ME img, PMC and PCHC), FIT give me issues about missing IOM. Can I get it somewhere, or take it from my current machine? Also Can I update NPHY and TBT? It is strange to see TBT on a system without Thunderbolt.

If I use the last tab on the left side ‘FW Udate Image Build’ there’s no complaint at all. If I look into the ME update file of the original Dell update package the only difference is that MEA states ‘OEM Configuration Yes’ for the Dell upgrade file. This OEM partition is different for every ME included in bios 1.17 to 1.19 and contains a signed manifest (?), so wouldn’t make sense to copy it.

Hi and Greetings Fernando,

I have an BIOS that is locked from Advanced Features which I would like unlocked.

I have installed Intel ME drivers and software, downloaded what I thought was the correct CME for this (CSME v16.0.r7).
I have greatly misunderstood all this and don’t know enough.
I have installed python 3.10.4 and downloaded the MEA.py from the link provided but could not install it as prescribed at the page for MEA.py download.

Installed are the prerequisites as prescribed there with the past command failing with “pysinstaller is not found to be an internal command or could not be found.” < close to this.

I have a few snapshots but it looks like cannot upload here? from HWINFO64 and when I tried to run the command
“pyinstaller --noupx --onefilfe MEA.py”.

What do I need to do next?
Would please help?
Thank you kindly
stumanchu

5 posts were split to a new topic: [Problem] Usage of an ASUS Hyper M.2 x16 PCIe card

CSME 16.0 CON LP A v16.0.15.1810

CSME 15.0 CON LP B v15.0.41.2142

CSME 15.0 COR LP B v15.0.41.2142

CSME 14.1 CON LP BA v14.1.65.1969

CSME 14.1 COR H A v14.1.65.1969

CSME 13.30 LIT LP B SPI v13.30.30.1766

PMC TGP LP C v150.1.20.1041

CSME System Tools v15.0 r14

CSME System Tools v14.0.20+ r19

CSME System Tools v13.30 r3

CSME System Tools v13.0 r7

1 Like

CSME 15.0 COR H B v15.0.41.2142

CSME 14.1 COR LP BA v14.1.65.1969

CSME 13.50 ATM N A v13.50.20.1657

PHY P TGP v12.14.215.2015

2 Likes

Which is this link… https://www.station-drivers.com/index.php?option=com_remository&Itemid=352&func=fileinfo&id=3435&lang=en

Doesn’t appear functional anymore. Or I can’t figure out how to get it to work. Is this just gone? I already tried a Google search and am not sure of a valid replacement. I think there was a Lenovo link I didn’t try yet, but… A couple others failed similarly (acted like it existed, but trying to download failed).

Thanks for all this information either way :slight_smile:

1 Like

OK, so finally yesterday Intel published SA-00613

Let’s hope we soon can collect all the missing firmware versions around… looking for 14.1.65.1969 Cons H.

Good to see content has been synced now, only the blue color of the links on the dark background is :expressionless:

1 Like

Agree, the blue is too strong/bright.

1 Like

I know everyone is very busy with the new forum, but maybe someone has an answer to my question posted before ?

Maybe someone can explain to me, why since v12 CSME a CSME update can’t be done at the same time than a BIOS update ? My systems will shutdown, instead of restart, and then neither BIOS update nor Intel CSME update was updated?
Everytime I have to do first a BIOS update , reboot, Intel CSME update, reboot - or viceversa?

@ EternalStudent07

I’ve fixed all the (Intel & SD) broken old driver links at the OP.

@ FM1, MeatWar

The migrated posts are a completely different experience, compared to the ones we’re natively (to this platform) creating now. New posts should work automatically with light/dark theming, but old ones are their own thing. There are various issues: format is ugly/raw html and needs manual conversion to MD or bbcode, colors need to be removed for proper visuals, some html elements are deprecated but were still allowed at the old forum software, so they may break without careful adjustments etc. Basically, all important/complicated old posts need some (probably manual) love by their creators to look good here. That is to be expected when migrating from such an old/deprecated/proprietary forum software. Anyway, still WIP. These will be fixed in time. Focusing on the more important things for now.

@ FM1

How CSME/BIOS updates are handled is vendor-specific for the most part. Some other systems may work exactly as you described, others not.

2 Likes

Here is the corresponding security bulletin from HP:

HPSBHF03793
I can see the CSME firmware is integrated into the .bin files from newer BIOS (e.g. 14.1.65.1969). But I myself can not extract it, but someone can maybe?

PMC TGP H B v150.2.10.1020

The FW versions at the OP are up-to-date based on what has been found so far (including HP). When 14.1 CON H becomes available, it will be posted here.