Intel (Converged Security) Management Engine: Drivers, Firmware and Tools

CSME 14.1 CON H A v14.1.65.1969

1 Like

CSME V14.1.65.1969 CON H compleatly broke ability to OC via BCLK. I am now not allowed for even 100.02 MHz clock
I can only remove spread now, so now I can only set it to steady 100MHz clock.
All previous CSME FW have ability to rise clock up to 102.98 via the me fw mod with second profile with aadjustable clock range.
So if anyone still doing this kind of mod stay away from it. Beside that everything rock stable.

1 Like

CSME 15.0 CON H B v15.0.41.2141

CSME 14.5 CON V A v14.5.45.1763

1 Like

15.0.41.2141_CON_H_B_PRD_EXTR
FWUpdLcl_15.0.41.2141
MEInfoWin64_14.1.65.1969

220517.rar (2.4 MB)

1 Like

CSME 15.0 CON H B v15.0.41.2142

1 Like

Something is wrong with this latest firmware, CSME 15.0 CON H B v15.0.41.2142.

I tried loading it in FIT to build a full image to flash, and I get this error :

Error 209: [Fit Actions] Chipset Init Product version does not match the configured PCH SKU type.

Selected PCH Type: TGP-LP (0x6).

Chipset Init Binary Type: TGP-H (0x7).

Error 9: Failed to decompose Image.

Error 9: Failed to decompose Image.

Unable to open file: E:\3\15.0.41.2142_CON_H_B_PRD_EXTR.bin. Reverting to default configuration.

@Ataemonus All i did is just make the fwupdate.bin and update it using fwupdate, updated my phy, pmc, and me using it instead of flashing the bios completely, and used fptw64 -greset after flashing it (fwupdate told me to restart so i used -greset on fpt instead.)

Mobo is B560M Pro.

@Koekieezz I have absolutely zero idea what you are talking about.

@plutomaniac looks like the CSME 14.1 CON H A v14.1.65.1969 image does not contain a placeholder for the PHY (USB C) firmware.
Is this because it’s an extracted CSME that doesn’t include PHY? (i’m aware not all CSME 14 have the USB-C firmware included)
Any harm in flashing a build without PHY if the current CSME version has one inside?

@Ataemonus sorry, this is what i meant:

image

Instead of building the full image, do the usual replace as the guide told you, but Build Image for FWUpdate instead Build Image. Then Flash the FWUpdate.bin using FWUpdate from the system tools you did downloaded, after you flashed it, do -greset on intel flash programing tool.

i have the same error if i built the full image, so for updating i only do fwupdate.

Works fine here:

Did I misunderstand something?

It works just fine. You probably forgot to set the SKU to H series at the top before loading the image, as the instructions say.

Placeholder? If I remember properly, that was an old ASUS thing/trick before CSME 14.1 (RKL) came out. Try a forum search with “14.1” “placeholder” “PHY” etc to see what comes up because I have forgotten the details now. One thing is certain, only RKL actually needs PHY for USB-C support, not CML.

@plutomaniac thx, very helpful, as always.
Update went smooth as butter :ok_hand:t3:

Yes, just as @plutomaniac says, I did not set the SKU at the top, I had no idea Intel changed the way FIT works and I did not read the instructions again, silly me.

15.0.41.2141_COR_H_B_PRD_EXTR-Y.rar (5.5 MB)

2 Likes

MEInfoWin64_15.0.41.2142.rar (336.1 KB)

2 Likes

04.04.04.048_WH_SVR_B_PRD_EXTR.rar (7.7 MB)

1 Like

@plutomaniac got this error, the only way i could do is only build image for fwupdate. any clues?

also it seems 15.0.41.2142 CON-H-B did restore my stable ram OC settings, compared to 15.0.41.2141 CON-H-B, i just updated it via fwupdate and retested it (previeously i must use high vccsa/io for my usual daily timings for 4133mhz ram), it could do the same, idk why.

FWUpdLcl_&_FWUpdLcl64_14.5.45.1771.rar (515.0 KB)

2 Likes