Intel firmware me problem

Hi all of you lately I had some problems updating intel me with me tool update to the latest version I would like to go back because I notice high latency slowdowns I really hope there is a way to run the previous one I would be grateful my current card is a asus z490 prime a with latest bios 2601 my current firmware version is as processor i have an i7 10700k and a 3080 ti evga ftw3 ultra with 32 gb ram

New version here: Intel (Converged Security) Management Engine: Drivers, Firmware and Tools (2-15) - Special Topics / Intel Management Engine - Win-Raid Forum (
or here on ROG forum: [FIRMWARE] Intel ME (H470/Z490) (

EDIT: Easy there… the linked files/tools are not my work and the 1rst link is to read and learn, anything else related to the 2nd link is outside this forum but the archives have their own instructions…but that you didnt know rigth. RUSH is the mother of all mistakes…Over_n_OUT.

EDIT: No, sorry but i have no guide for “regular users” to downgrade the ME, too risky on modern bios/motherboards. I doubt that your performance issues is all due to the ME firmware…

1 Like

Thanks, now what exactly should I do? :blush: Download the file you posted to me?

Thanks I tried to download the firmware that you told me the second link by doing the written procedure let’s see how it goes,
Otherwise I will downgrade following a help guide from your help

But before upgrading I didn’t have those problems or maybe it’s related to chipset drivers but I don’t think so, In case what could I do?I was reading on a post that a guy had solved here I send the link,

What he finally did was just updating to the latest bios from 0401 to 3802, as you can read the Intel FPT tool failed to flash old ME.

“The bios version 0401 had unlocked ME read and write. i used usb flashback to flash it, still had me fw 11.8, then i tried to use the tool under windows but still refused. i then tried to flash bios 3802 with usb flashback and it worked!”

I dont see any confirmation of ME downgrade. And this was with ME 11 not 14.
And yes the Intel FPT tool can read/write bios regions if the access is unlock (FDPR), how does the motherboard reacts… you may get a bad surprise…or not.

Read the whole thread and you’ll find that is not an easy task for unskilled users… sorry but i will not guide you on this, to much work, time and high chances of failing, thats it from me.

EDIT: Sorry to hear that, still did you upgraded to the latest MF FW version and still buggy?


Okay come on thank you for the tips in the meantime you’ve been very kind

Hi, I finally changed the motherboard