Intel ME problem on ASUS TUF FX505GT

Hello everyone this is my first post. Thanks to everyone around here I have un-bricked my laptop but there is a problem:
Everytime I turn on my laptop it took 5-15 second to boot and when I check device manager, Intel ME Driver is not there, even if i tries to install the driver from manufacturer’s website. When I check ME Status using MEInfo it returned with this:

I also tried searching the BIOS for ME toggle, nothing there, also tried to clean ME but to no avail.
Now I don’t know what to do next. Can anyone from here help me here? Here is my BIOS dump using Intel FPT:

Edit: Included the correct file:

[quote=“amakura0101, post:1, topic:88869”]
…I have un-bricked my laptop but there is a problem:
[/quote]That’s not too much information about the unbrick.

A starting point might be:

But this error indicates that the ME is disabled by jumper or bios setting. If you didn’t set any FDO or ME recovery jumper and did not change any bios settings regarding ME then cleaning the ME and emptying the NVRAM (alternatively using a stock bios region with a cleaned ME) are the things you could try.

@lfb6 Well, I don’t know how to empty the NVRAM on my laptop, and as far as I know, there’s no ME or FDO jumper on my board.
About the unbrick, I actually bricked my laptop by shutting down my laptop in middle of BIOS Update, and then reflashed using CH341A programmer

Now we know that you didn’t use any jumpers and didn’t find any obvious settings in the bios.

But it’s still unclear when in the process your bios dump from post 1 was made and what file you used to reprogram the firmware and if you possibly made a dump of the bricked bios before overwriting it.

@lfb6 I used this file to reprogram the bios:
TUF FX505GT.bin
And I don’t backup my bios before overwriting it.

Well, in #1 you post spi.bin which is bios region version 3.10 and has ME settings being fiddled with (for example AMT enabled but these machines don’t even have hardware support according to the specs I could find)

Now you state you used TUF FX505GT.bin, different ME settings, bios region version 3.11, identical to a file from badcaps.

This isn’t a very constructive way of giving “information”.

Since you didn’t backup your old firmware one can’t tell for sure which one would be the correct ME configuration for your laptop. Even the dumps (one of which youu used) at badcaps are different in some settings (platform protection).

As proposed in #2 clean the ME, use the settings from TUF FX505GT.bin. Good luck.

@lfb6 Whoops, seem like I included the wrong file. Edited the first post to include the correct file.
As for cleaning the ME, I used the settings from TUF FX505GT.bin but nothing changes, MEInfo still show Error 198: ME Disabled