Intel Nuc Hades Canyon HVK BIOS no POST

Hey good people this is my first post on the forum in hopes of getting some help from the experienced experts here. I have an Intel NUC8i7HVK Hades Canyon that will not POST or display anything and as soon as I connect the power adapter the device turns on. I have tested the motherboard and found no faults so my assumptions were that there is some kind of Bios problem, I went ahead and used my programmer to dump the original file and while researching this forum I found a dump file posted by a member of the forum and I went ahead and flashed the bios chip. The device now powers on normally (with power button) but the post screen only shows up after about a minute. I managed to install an OS and all the drivers (technically the device is functional) but im having problems with Intel ME and ofcourse im missing all my Bios region data, serial keys and so on which is also not allowing me to install intel ME.
Is there anyone who could rebuild me a bios file for my device and exctract all necessary information from my dump file to get this little machine running properly.
If any other information is needed that I skipped please let me know. I have attached the original bios readout file.
PS I have tried bios jumper recovery with no luck.

Thank you
NUC8 HVK ORI dump bios SPI (5.4 MB)
NUC8 HNK Winraid dump bios SPI (5.6 MB)

You lost your NVRAM completely, see pic. It might be possible to restore some of the machine data, I’ll have a look into it later or tomorrow.

1 Like

Thank you so much for having a look at it. I have also been trying to investigate the file with UEFI Tool and FIT but as I am not really experienced with these kind of repairs im not really sure what I am doing :joy:
I also noticed that something is missing just have no clue what. I bought this NUC off someone on FB Marketplace as a secondary unit as I own one for 5 years now. Im not really sure what happened to the NUC, looks like the previous owner failed a BIOS update, as the machine is really clean inside I assume they didnt really get the chance to use it much. Thought I could get this one running so i could claim my one back from my wife :rofl: she really loves these little machines.

Try, no warranty!


1 Like

I come back with good news! The file so far is working great, the POST has no delay and all Intel ME drivers installed perfectly. POST says: “System in manufacturing mode” on power up, but I read online it should go away after 20 reboots. All i can say thank you very much!

Thanks for the feedback. Good to hear it worked!

The firmware posted had the ME region reinitialized (according to this guide) and there were some parts of one NVRAM still readable. NVRAM gets rebuild automatically, but reconstructing NVRAM with the DMI information might give som unexpected results.

There’s actually a variable MfgMode which I put in again, but it might be reset since the secure boot databases and several values have to be rebuilt again.

I’d recommend

  • to make a backup after several restarts / when the message about Manufacturing Mode has disappeared. You might try to use Intels FlashProgramming Tool fpt from
    CSME System Tools v11
    For CSME v11
    (File folder on MEGA)
    from this thread.
    Syntax would be
    fptw64 -d spi.bin (for the whole SPI) or
    fptw64 -bios -d biosreg.bin (for the bios region- and that’s the only part with relevant changes now)

  • to update to the latest firmware version (it’s now on Asus’ websites) as last step

If you can get a backup of the bios region I’d be interested how the NVRAM looks when the manufacturing message disappears!

Hello apologies for the late reply I havent had time to carry on work on the NUC as I left it at my workplace over the weekend and I am still waiting for another NVME to arrive. After I flashed the bios chip with your file I already had Windows installed on the NVME so the system booted up straight into the OS. Today I noticed the manufacturing message is gone but I also noticed secure boot has been disabled in bios, I dont plan on enabling it again as I’m not sure will that require an OS reinstall. What i can tell you is I did straight away update the bios to version 0067 from version 0064 that was on the file supplied. I will be making a dump of the file and posting it here for your further research. Is it fine that i have already updated it? Otherwise everything seems good so far havent had a chance to test performance as I still want to change the paste on the CPU/GPU. So with the tool you posted above I can make a full bios dump without removing the bios chip?

1 Like

Good to hear that the manufacturing message already disappeared. Then this system should be fully recovered now.

Secure boot normally isn’t posstible without db, dbx, pk and KEK reinstalled in NVRAM, but you should be able to enable secure boot now. There shouldn’t be any need of reinstaling Windows.
Didn’t find any OEM Windows activation in the firmware, by the way.

If you have the time to make a new dump of the bios region by software I’d be happy.

Firmware 0067 doesn’t seem to be the latest:

(image clickeable)
Seems to from late 2022, new date possibly since Asus took over

The tools mentioned (fptw64.exe) often give the possibility to dump a complete image, sometimes one region doesn’t have read access. If they work this is the most safe and comfortable way.
SInce FD and GbE normally don’t change and you already have a clean ME- region bios-region is the most interesting part. Be careful with the syntax, though!

Thanks for the reply, I am aware of bios 0070 but my other NUC unit has been running 0067 for a long time and i found it very stable (including using older amd drivers for the radeon graphics) if you would prefer an update to 0070 before the dump I can do that too as this unit is open for experimentation. Also I have made a dump of the 2nd SPI chip, also the GPU spi chip, I could also post those here if you have any interest in it.

The update to 0070 isn’t relavant. I’d like to have a look into NVRAM at the ‘earliest’ possibility after it’s been rebuilt, that’s all.

The other 2 chips would be of course relevant, just have a look and to compare to what might be in the update files!

Sorry for late reply here are the dumps of bios 0067 after manufacturing message disappeared, also I will upload SYS2 SPI dump and GPU SPI dump. Thank you for your help.
SYS SPI HADES CANYON 0067 (Manufacturing mode off) (5.5 MB)

1 Like

Thanks! The smaller ones are grapics card and Thunderbolt, and both aren’t in the normal firmware update.

Regarding the dump of the bios region: The NVRAM has become too large already, but that’s not a problem. To know that this type just needs these 4 values and StdDefaults is good enough!

Enjoy your recovered NUC :slight_smile: