Latest Firmware for ASM1064/1166 SATA Controllers

Is there any method for flashing these in Linux? Or even for showing the firmware version?

No, only in windows.

I have ASM1064 and updated the firmware according to the first post. Unfortunately, the computer with the adapter does not start. What did I do wrong?

Previously, the SATA adapter worked fine, of course, except for the Z 690. I updated it on a motherboard with a G31 chip and a Q6600 CPU.

1 Like

I don’t have access to any 1064 adapters to test this one out, only 1061,1062’s and 1166’s but are you able to revert to the original firmware without the adapter hanging machine on boot with adapter installed ?!?

I once rescued a misflashed 1062 that was hanging at boot by hotplugging it into the pcie ports and flashing in windows, the dos method of flashing was inaccessible to do it since the misflashed adapter was hanging the machine at init time.

The pci express standard supports hotplugging however windows does not, but this was enough to rescue the adapter despite being a risky unknown operation if you don’t have access to a CH314A programmer to get the chip recovered back to normal. YMMV.

I think it was the case with bricked 1062 that although windows had already loaded and hotplugging the device couldn’t actually see or detect the adapter, it was enough for the asmedia windows flash software to see and access it to be able to reflash back and rescue or something to that effect.

I have access to CH314A. I’ve just never used it and have no experience with flashing this device. Do you have a web page on how to use it? try to flash the same ROM again? 221118-0000-00

-[Guide] Using CH341A-based programmer to flash SPI EEPROM
-[GUIDE] Flash BIOS with CH341A programmer

It is difficult because the firmware chip is not removable.

The firmware is compatible with 1064 as i test it personally and also i found others that have successfully flashed it.
So what is your card and what it your firmware chip?
Can you write the letters from the chip here? And can you post a pic from the adapter?

1 Like

Maybe i am blind but where is the new FW?
“20221118” ?

Every Download Link shows → 11180000.rom

At the Moment my ASM1166 is at Version 220419-0000-00

Does anyone reach out to ASMedia for a 2024 Firmware with “less” Bugs like the 32 Drives :slight_smile:

Even if you apply, they will not give you anything. This is ASMedia’s policy - users take all firmware from their devices.

If i know how i would give you the FW 220419-0000-00 Maybe it is better then all others maybe not. :slight_smile:

@The_Master the new firmware is in the second post. It is newer than yours.

@shakal84 the spi is this chip. What it writes?
Χωρίς τίτλο

This bios spi chip is some Chinese clone of a real one as i cant find it nowhere.
This chip seems to have as a result a fake id recognition so the tool of the firmware flashed it wrongly.

It seems to me that even with ch341 you will failed to flash it as it will not recognize the chip.

In every download i get the OLD Firmware. Thats the Problem.

Every ROM is 11180000.rom

Mine first post is the 1108 (11080000.ROM) ----> 211108-0000-00

Leland second post is the new one 1118 (11180000.rom) -----> 221118-0000-00
Look carefully.
Open the file in second post and flash it.

1 Like

Chip looks tight to get a clamp on as its directly flush to sata connector. The problem with a lot of these chinese flash chips is they tend to smudge the writing so you can’t tell what they are, and when you can read it they source cheap unrecognised parts from noname brands (note the lack of a logo on this 8 pin spi) and sometimes flasher doesn’t like it but attempts to flash anyway and i think this is why sometimes they end up bricked, it definately looks EON 25Q40 based so try that.

You can definately read and write these chinese adapters without it being powered or desoldered, ive done it in another forum to hoover off and hex edit the stock bios for my own backup purposes, but it is very very finicky with the clamp.

The false 32 device enumeration with asm1166 sure needs fixing as a) it doesn’t happen with the older adapters (asm1062) and b) slows things down to a crawl at least on my systems until the drivers are applied. There are patches for linux to work around this flaw but nothing windows based.

Thanks… Naming of the Firmware Files is a bit off :slight_smile: But Thank you Update with the “new” Firmware worked.

Hi Kevsamiga,

i have bought this card: SATA PCIe Card/Controller Card, 6 Ports - SATA Controller Cards | Add-on Cards & Peripherals | which is working in a Windows 10 enviroment without any problem.

Under Windows 7 I have also this 32 ports problem with a very long booting procedure. I already flashed the card to the 211108_00_00_00 firmware, but i can’t find a proper driver which fixes the slow boot issue. Could you give me a link to your driver you are using?Thank you very much!

As far as I managed to establish it’s a hardware issue, not a software fixable one but could probably be worked around with some kind of “patch” like linux. Without drivers loaded my 1062R’s also try to enumerate 12 devices from a 6 port sata card (with multipliers) however this doesn’t appear to slow the system down if you aren’t using the ASMedia drivers just windows AHCI ones.

It’s a peculiarity solely of the domain of the asm1166 as far as I’ve tested under Win7. There shouldn’t be 32 devices on a 6 port card. There aren’t many drivers to experiment with for this chip as it’s relatively new at least compared to 1062 & 1061. And as far as I tested none of them solve the issue as it only happens when they aren’t loaded. You just have to sit through the long grind (which looks like the machine has frozen) until the desktop comes up allowing you to install the ASmedia drivers which behaves itself after that but the default AHCI ones are off the table.

At least the 1166 6-port is a true sata chip without needing to use multiplexers to achieve the same number of ports on 1062/1061.

I don’t think it can be fixed in software except for a firmware update. Since that’s the whole point. The bug only shows itself when you are not using the asmedia drivers and only the windows AHCI default ones. The drivers I do use are (which are the last ones working on Win7) the latter ones are for Windows 10.

All of these chips also advertise themselves as being Windows XP compatible, however I’ve never one gotten this to work on any of them, even with making F6 boot disks with various drivers on it. Maybe as a data drive only.

There is also another bug…on some legacy systems there is not enough space to copy the option rom of the asm1166 in the shadow PCI configuration space and shows warning during post. The asm 1062 and 1061 cards don’t exhibit this kind of behaviour on the same system.

I don’t see any detrimental effects by leaving this warning in place (the card still boots in any case) because I refuse to start switching things off in the BIOS such as booting from IDE (boot from lan is already disabled) when it’s still working fine in any case.

Hi all, I was planning to buy a sata controller with asm 1064 and use it in my nas with Open Media vault (Linux debian).
If the controller is not recognised should I do a firmware update?
If the spi chip was not the ch341, but a Chinese clone, would I still do the firmware update? (I ask this question because I didn’t understand what happened to shakal84).
Thank you all.