Lenovo ThinkCentre M83 NVME support

I need help flashing a Lenovo ThinkCentre M83 bios. I added the NVMe module to the original Bios FBKTE0A with UEFITool. However, the modded BIOS cannot be flashed with the original Lenovo tool FLASH2.EXE. Even with FTPW64.EXE I get “Error 280: failed to disable write protection for the BIOS space”. Even the BIOS dump created with FTPW64.EXE cannot be restored. The same error occurs. I short-circuited the Juper DIS_ME on the motherboard. The Lenovo tool flashes the original bios update without short-circuiting the DIS_ME jumper on the mainboard. I short-circuited the pins for testing, but the modified bios cannot be flashed with any tool. Is there a way to flash the modified bios without desoldering the chip? Some time ago I also integrated NVME support into the bios of a Fujitsu Siemens Esprimo P910 0-Watt. However, this bios could be flashed without any problems using the original flashtool.
I would be very happy to receive help.

The use of the ME_DIS is not for using FLASH2.EXE
The purpose of that jumper is regarding the Intel ME and access the bios regions.
Using the Intel ME9 tools, FPT tool, a dump of the bios region can be made to mod, but it needs access to write it back:

A full SPI dump backup is advisable, for safe keeping.
fptw64 -d spi.bin

Testing read/write acess to bios region:
fptw64 -bios -d bios_region.bin
Now performing the writing of the same region will let you flash it or will report FD lock.
fptw64 -bios -f bios_region.bin

If the writing is successful, the dump bios_region after NVMe mod can then be flashed.

Thanks for the quick answer.
fptw64 -d spi.bin works. fptw64 -bios -d bios_region.bin also works, but fptw64 -bios -f bios_region.bin does not work. Error 280: failed to disable write protection for the BIOS space.

You did understand that the operations are to be done with e ME_DIS enable (Closed)… and not in normal mode.

Here’s an example of same operation in a M92

If the write operation fails due to FD lock then a CH341 spi programmer maybe the last resource, against a possible FD unlock, regarding Error 280, that you’ll find all about in the first 2 guides during the search results, that’s it, all the best and good luck.

The guide for the M92 was the first one I tried, unfortunately without success. I am afraid that the problem cannot be solved without a CH341A programmer. I am not sure if it is worth all the effort.

Yes not all are ready to use the FPT method as the M92…but this is something that we all know… we also dont know if each user has already unlocked the FD before any other requests.
So its your call only, good luck.

Hey don’t know if your still intrested in getting the Nvme working on your Lenovo. But there is a way without even modding anything on the motherboard and it doesn’t have any performance hits either. People will prob talk crap about my method but here it is. If you just use a boot loader like Clover, the bootloader that was widely used for hackintosh’s it will allow you to boot from any device even if the bios don’t allow it. And once it’s setup using clover the computer will see the drive like it’s native. Enjoy.