Lenovo y50-70 notebook, shutdown after 30 minutes

Hello all,
Hope everyone is having a good day.
I have been doing a lot of reading, searching, trying.
It appears the ME area being messed up causes this???
SPI chip =

(G AE1510)

Processor Intel Core i7-4720HQ 4 x 2.5 - 3.5 GHz (Intel Core i7)
Graphics adapter NVIDIA GeForce GTX 960M - 4 GB VRAM, Core: 1176 MHz, Memory: 1253 MHz, GDDR5, Force Ware 352.86 (, Optimus
Memory16 GB, DDR3-1600, dual-channel, two memory banks (both filled)
Display15.60 inch 16:9, 3840 x 2160 pixel, Samsung L FLLTN156FL02L01, IPS, glossy: yes
Mainboard Intel HM87 (Lynx Point).

I tried the Intel fpt tool to get a dump, no luck, I tried the CH341a in-circuit did not work.
Removed SPI chip, got read, 8MB.

Tried ME Analyzer get error, where am I going wrong…?

Thank you

I don’t know why MEA dosen’t read, neither does MCE. But image opens fine in FIT, so cleaning according to winraid.level1techs.com/t/guide-clean-dumped-intel-engine-cs-me-cs-txe-regions-with-data-initialization/ will work OK.

(Bios update from Lenovo contains complete image, one could transfer ME region from this update file, too)