Modded Intel AHCI and RAID Drivers (digitally signed)

@ all users of my modded drivers:

Due to the availability of the first mainboards with an Intel 9-Series Chipset there was the need to add the missing HardwareIDs of the brandnew “Intel(R) 9-Series Chipset Family SATA AHCI Controllers” into the INF and OEM files of my “Universally modified” 32/64bit Intel RST drivers v11.2.0.1006. Otherwise the owners of a brandnew Intel system would not be able to get Windows XP or Windows Server 2003 installed.

This situation has been the occasion for me for a complete revisement of the “universally modded” Intel AHCI/RAID drivers, which I am offering within the start post of this thread.
At least I changed the following:

  1. addition of all new or missing HardwareIDs
  2. simplification/clarification of various Intel SATA AHCI/RAID Controller names (to make it easier for the users to differentiate them)
  3. addition of the related DeviceID to all Intel SATA Controllers names (to make it easier for the users to choose the correct AHCI/RAID Controller during the textmode driver integration)


Update of the Start Post:
Changelog:
  • refreshed: “Universal 32/64bit Intel RST textmode drivers v11.2.0.1006 re-mod by Fernando”
    (now with enhanced support from ICH7R/M up to 9-Series Chipset AHCI/RAID systems)
  • refreshed: “Universal 32/64bit Intel RST Drivers & Software Set v11.2.0.1006 re-mod by Fernando”
    (now with enhanced support from ICH7R/M up to 9-Series Chipset AHCI/RAID systems)

Request:
Although I have tried to do my very best while executing all these modifications, I am not 100% sure, that the “universally modded” Intel AHCI/RAID drivers and complete packages will work for all of you.
That is why I need your feedback (mentioning the OS, the sort of your special Intel SATA AHCI/RAID Controller and the driver version you have used).
Thanks in advance!


Good luck with these freshly customized Intel AHCI/RAID drivers!
Fernando

Ahhh, you are absolutely right!! I kept trying the 64 bit because my computer is a 64 bit windows 8.1. I am trying to dual boot windows xp on a separate hard drive and should have been using the 32 bit version. Once I did that everything worked fine! Thank you!


I integrated your remodified 32bit Intel MSM driver v8.9.8.1005 dated 04/05/2010 into the Windows 2000 Professional operating system CD using nLite, and tested today on my Biostar TZ77A / i7-2700K combination. I’m pleased to say it appears that the test was a success.

The OS installation proceeded without error. Device Manager shows driver version 9.3.0.1029, and Driver Details there shows file version 8.9.8.1005 (as does iaStor.sys Properties). Subsequent software installation went smoothly. Optical disc drive function was normal, and uninstall / reboot / reinstall of the optical drives was no problem.

The next test starts with Device Manager to uninstall / reboot / reinstall the SATA AHCI Controller, but I’m holding off on that one for the moment, because if it doesn’t work it will probably wreck the OS.

Great job, Fernando. Really makes me wish I had my 8-Series chipset in hand.

@ Bluebolt:
Thanks for your report about the successful installation of Windows 2000 in AHCI mode using the freshly re-modded "Universal 32bit Intel MSM driver v8.9.8.1005".

That is the version of the Intel Chipset Device INF file, which obviously has been installed or integrated by you, and not the version of the Intel AHCI driver itself (named iaStor.sys).

Yes, you should not try to uninstall the AHCI driver or the Intel SATA AHCI Controller, because aftwerwards would not be able to boot into W2k again, because this OS doesn’t have an on-board AHCI driver.
If you want to change the Intel AHCI driver version, you have to install another (newer) Intel AHCI driver manually from within the Device Manager or by running the installer of a complete Intel RST Drivers & Software Set.


I just tried it and it worked fine, as it has for me in the past.

To be specific, I open Device Manager, expand IDE ATA/ATAPI Controllers, then right-click on the indented line (which reads “Intel(R) 7 Series C216 Chipset Family SATA AHCI Controller – 1E02”). Then I click Properties / Driver / Uninstall.

The system asks for a restart, which I allow. The rebooted system asks to install a disk drive, which I allow, and asks for a reboot, which I allow. The “Found New Hardware Wizard” opens, looking for the SATA AHCI Controller. I direct it to yours. The system asks for a restart, which I allow.

Windows 2000 Professional loads the desktop, all right and tight as before.

Hello Fernando,

Sorry for the delay here, but I finally have my Z87 motherboard and Haswell processor back in action, and this morning I was able to test your AHCI driver using the 8-Series chipset with Windows 2000 Professional. I’m pleased to report the OS installed without incident, and I have it running in true SATA mode.

Your drivers have been very helpful in allowing me to push my favorite operating system forward into the next generation of Intel hardware. Thank you, and keep up the good work.

@ Bluebolt:

Thanks for your feedback!
It is great, that you succeeded with the Windows 2000 installation in AHCI mode by using the Intel MSM driver 8.9.8.1005, which had been modded by me, and it was a pleasure for me, that I was able to help you.

Enjoy your W2k in AHCI mode with your Z87 system!

Hi and thanks for these modded drivers.

I recently upgraded to Windows 8.1 x64 and have installed:
>64bit Intel RSTe AHCI & RAID drivers v13.0.1.1000 mod by Fernando<
using Have disk method.

Now, under “IDE ATA/ATAPI Controllers” I have “Intel(R) ICH8M SATA AHCI Controller” (Intel Driver, v13.0.1.1000, iaStorA.sys) and “Intel(R) ICH8M Ultra ATA Storage Controllers - 2850” (Microsoft Driver).

Is everything correct? I’m a bit worried since iaStorF.sys doesn’t seem to be installed at all (not even in c:windows\system32\drivers). I can boot and work normally.

@ a4453096:
Welcome at Win-RAID Forum!

Yes, everything is correct with your installation.
Now to your questions:

  1. The “Intel(R) ICH8M Ultra ATA Storage Controller - 2850” has nothing to do with the “Intel(R) ICH8M SATA AHCI Controller”. It is the Intel P-ATA Controller, which manages the Intel IDE port(s) of your mainboard.
  2. The SCSI filter driver iaStorF.sys has not been installed, because Windows 8 doesn’t need it. This has to do with the UNMAP command for SCSI drives (similar to TRIM for SATA), which is natively supported by Windows 8/8.1 (contrary to Win7).

Regards
Fernando

@ all users of my modded drivers:

Update of the Start Post:
Changelog:

  • new: modded 32/64bit Intel RST(e) drivers v12.9.3.1000 dated 04/02/2014
    (with enhanced support from ICH7R/M up to 9-Series Chipset AHCI/RAID systems)
  • new: original 32/64bit "Universal Intel RST Software v12.9.3.1000"
  • new: modded 32/64bit Intel RST(e) drivers v13.0.3.1001 dated 04/04/2014
  • new: modded 32/64bit Intel RST(e) drivers v13.1.0.1058 dated 05/14/2014


Good luck with these freshly customized Intel AHCI/RAID drivers!
Fernando

I have now testet the new 12.9.3 driver on my Sabertooth x58 with crucial m4 ssd in ahci single mode - run on the Intel Sata2 ICH10 controler instead marvel sata3 because the performance is much better.

Compare to the driver v12.8.11 is not much diverence, also very stable - but compare to v13 drivers, which are very much toddle during the benchmark tests, is v12.9.3. now my first choice…

Overall seems that the read performance is simelar and the write performance is a bit better then the v12.8.11 driver.

Thanks again Fernando for your good support.

Regards,
Thomas alias wasisdn

v13.1.0.1058 WHQL (modded like your v13.1.0.1058 not WHQL driver) driver is working on the following system:

Systembericht

Systeminformationen
Betriebssystemname: Microsoft Windows 7 Enterprise
Betriebssystemversion: 6.1.7601 Service Pack 1 7601
Systemname: ------
Systemhersteller: Gigabyte Technology Co., Ltd.
Systemmodell: EX58-UD5
Prozessor: GenuineIntel Intel64 Family 6 Model 26 Stepping 5 2,66 GHz
BIOS: Award Software International, Inc., F13

Intel® Rapid Storage-Technologie für Unternehmen Information
Installiertes Kit: 13.1.0.1058
Benutzeroberflächenversion: 13.1.0.1058
Sprache: Deutsch (Deutschland)
Treiberversion: 13.1.0.1058
ISDI-Version: 13.1.0.1058

Speichersysteminformationen
Controller-Name: Intel(R) ICH10R SATA AHCI Controller
Typ: SATA
Modus: AHCI
Anzahl der SATA-Anschlüsse: 6
Anzahl der Volumes: 0
Anzahl der Ersatzlaufwerke: 0
Anzahl verfügbarer Festplatten: 3

EDIT by Fernando: It was the modded and not the WHQL driver, which worked with his Intel 4-Series chipset AHCI system.

I doubt, that the WHQL certified (unmodified) driver could be installed onto your Intel 4-series Chipset AHCI system.
What you certainly mean ist the modified version of the driver, where I have added the missing HardwareIDs into the INF fle.

I edited my posting. I didnt want to confuse somebody. Thank you for your dedicated work.

Thanks for the clarification.
Note: Any modification within the INF file (that is what I am doing by adding the missing HardwareIDs) will break the WHQL stamp of the driver. That is why the annex "WHQL" is misleading for modded drivers - they are not WHQL anymore.

Hi All,
New to the forums. Managed to pick up a ASUS P9X79 PRO. Its been a while since I’ve updated my hardware so had to take a crash course in UEFI. Got Win7 x64 installed as not too keen on Win8.1

ASUS didnt appear to have a F6 driver for the RSTe C600 Raid Driver. Nicked it from the Gigabyte X79 site! :slight_smile: Updated BIOS from original .ROM to the newer .CAP. Currently on latest BIOS from ASUS (4608) This allows me to chose either IRST - 12.7.0.1936 or RSTe - 3.5.0.1005.

Correct me if I am wrong but am I correct in thinking…RSTe is the recommended better version?

IRST = Legacy Raid
RST = Updated Raid
RSTe = Updated Raid (Enterprise Class)

I think along the way I picked up a RSTe Driver 3.6.0.1086 or 1093 from a link or reference from one of the many Forums I have visited within the last 24hrs. Cannot quite remember where I found it…but the name Fernando kept popping up! :slight_smile: Some RAID God who appears to have given INTEL a telling off for not supporting
C600 series chipsets. Bravo that man!

Which lead me to these forums. Saw reference to some updated drivers/packages 3.8.1.1006 / 4.0.0.1040. As soon as I install these… PC hangs. Does a memory dump and my 2 x SSD shows ERROR OCCURED on the boot up screen. I managed to get back in and revert back to the 3.6.0.10.93… so at least that works.

So maybe I missed something? I guess after further reading that my current SATA OROM is limited and must be updated should I wish to use newer drivers?

So if anybody is able to assist and confirm the following…

1. Is it recommended to update. Are there performance gains plus TRIM?
2. Running the UBU OROM Replace lists the below items:

1 Intel RST(e) OROM and EFI SataDriver
OROM IRST SATA - 12.7.0.1936
OROM IRSTe SATA - 3.5.0.1005
EFI IRST SATA - 12.7.0.1936
3 LAN OROM PXE and EFI UNDI - Intel, Realtek, BCM, QCA
OROM Intel PXE - 1.3.72
EFI Intel UNDI - 5.5.23
5 Marvell SATA Option ROM and EFI
OROM Marvell 88SE91xx/92xx - 1.0.0.1031
EFI Narvell SATA - 1.1.0.1001
8 Update Intel CPU MicroCode SandyBridge-E/IvyBridge-E
9 Look Version DevID.txt
0 Exit
Intel RST OROM and EFI SataDriver

1 - Update to v11.6.0.1702
2 - Update to v12.9.0.2006
3 - Update to v13.1.0.2126
9 - Goto Update IRSTe/SCU
0 - Exit to Main Menu

Intel RSTe OROM and EFI SataDriver

1 - Update to v3.7.0.1049 OROM/EFI/SCU
2 - Update to v3.8.0.1029 OROM/EFI/SCU
3 - Update to v3.8.0.1029 OROM + v12.9.0.2006 EFI
4 - Update to v3.8.0.1029 OROM + v13.1.0.2126 EFI
0 - Exit to Main Menu

3. I assume the SCU is SCSI driver? that’s needed for certain boards? If I was to pick an option then I guess it would
be either 3 or 4 only. I haven’t seen any reference to SCU for the ASUS P9X79 PRO regarding RSTe drivers.

4. Are there any recommendations. Has anybody else been down this path. Have I read too much info and missed the obvious?

Any help or advise with the above would be greatly appreciated.

Kind Regards

Kingkenny

@ kingkenny:
Welcome at Win-RAID Forum!

Questions:
1. Did you create an Intel RAID array?
2. If yes, which Intel RAID Utility version did you use (hit CTRL+I while booting)?

This is not 100% correct.
IRST and RST are the same = Intel Rapid Storage Technology (for all Intel chipsets except the C600 Chipset Series like X79)
RSTe = Intel Rapid Storage Technology Enterprise Edition (for Intel’s C600 Chipset Series like X79)
Remark: Intel RSTe drivers v3.x.x.xxxx and v4.x.x.xxxx use an additional SCSI Filter driver named iaStorF.sys, but the latest Intel RST drivers from v11.5.x.xxxx up do it as well.
So there is no big functional difference between the actual RST drivers and the RSTe drivers.
Important: You should not mix RST and RSTe. That means, that if you choose the RST RAID option, you should use Intel RST drivers (v11, v12 or v13), but when you have chosen the RSTe RAID option, you should install any of the Intel RSTe drivers (v3 or v4).

SCU means “Storage Control Unit” and is a special feature of some X79 SAS mainboards (for details you may look >here<).

Many X79 RAID0 users reported, that they got the best performnce by choosing the RST RAID option and to use any of the latest Intel RST RAID drivers (v12/v13).

Regards
Fernando

Hi Fernando.
Thanks for the info. I think I got it (ish…). Will have another read tomorrow… Its been a long day… with a lot of reading forums :slight_smile:

Questions:
1. Did you create an Intel RAID array?
2. If yes, which Intel RAID Utility version did you use (hit CTRL+I while booting)?


Yes. Changed BIOS from ACHI to RAID and then changed IRST to RSTe. On bootup hit CNTL-I and created RAID0 Set. Thanks for the correct definition of the IRST/RST (v11, v12 or v13) and RSTe (v3 or v4). I think I was getting confused with the SCSI filter and SCU. Thanks again for explaining that.

I cannot find any ref to SCU for the ASUS P9X79 Pro. I’ll do some more google’ing tomorrow. I think I was under the impression that RSTe was newer and better that IRST/RST. I’ll have to test both and see what performance I get.

So with regards to the options showing in the UBU OROM Replacer (as per my first post…)

I currently have:

1 Intel RST(e) OROM and EFI SataDriver
OROM IRST SATA - 12.7.0.1936
OROM IRSTe SATA - 3.5.0.1005

So… If I wish to use any of the newer drivers…for either IRST/RSE or RSTe then I need to work out what my motherboard supports/uses and update the BIOS to one of the following options: (which is why if I load the newer drivers as they are now… I get BSOD and SSD ERROR OCCURRED on restart of the PC because my current version OROM is a little out of date…?) Am I correct?

1 - Update to v3.7.0.1049 OROM/EFI/SCU
2 - Update to v3.8.0.1029 OROM/EFI/SCU
3 - Update to v3.8.0.1029 OROM + v12.9.0.2006 EFI
4 - Update to v3.8.0.1029 OROM + v13.1.0.2126 EFI

Thanks for the advise so far. Much appreciated.

Kind Regards,
Kingkenny

Both modules are within your mainboard BIOS, but the question is, which one of them is in use (depends on your chosen BIOS option regarding RST/RSTe RAID).

Your actual BIOS modules are not the latest and should be updated, but I doubt, that they were the reason for your BSODs and SSD errors.

If you want to use the latest Intel RST(e) drivers of the v12 or v13 series, I recommend to do the following:

  1. Prepare a mainboard BIOS with updated Intel RAID ROM and SataDriver modules by using the UBU tool.
  2. Do a backup of your important data.
  3. Enter the RSTe RAID Utility and delete the RAID array.
  4. Flash the prepared BIOS with updated Intel RAID ROM and EFI SataDriver modules.
  5. Enter the BIOS, choose the RST RAID option and do the needed BIOS settings.
  6. Run the Intel RST RAID Utility and create a new RAID0.
  7. Do a fresh install of the OS onto the freshly created RAID array.
  8. Install the Intel RST driver v11, v12 or v13 of your choice.

How can I get my windows 8.1 update 1 OS to recognise my HDDS after installing the latest v13 irst driver?, at the moment when I install any v13 driver …windows 8 thinks I have SSDS installed, but its not true, I have 2 wd blacks in raid 0, so …how can I use the v13 driver and get it to recognise my raid 0 hdds? My system is x79 g1assassin2 with v13 orom and latest irste orom, 4820k cpu. Its the same deal with any bios but currently have f12y.