Modding Asrock X470 BIOS, Secure Flash error

Hi there again,

just got my new ASRock Z370 Professional Gaming i7 today and tried to update latest BIOS v3.10 with latest UBU (as i always did with my ASRock Z270 Super Carrier w/o any problems, evan when flashing).
But when i try to flash it through “Instant flash” i allways get the message “Secure flash check fail!”. What am i missing? Or is it possible, that ASRock has changed their Capsule-Method once again and we need to patch this with a newer fix?
I read the whole thread but could not find any post mention this behaviour.

Anyone who is able to patch latest ASRock Z370 BIOS and got this flashed to their MoBos successfully?

PS: tried it with older UBU1.69.xx and with latest UBU1.70.rc8 - also tried the method mentioned here.

@MDoehler Are you sure it’s not your mod is bad? Test by doing some single simple update in UBU on a stock BIOS, such as LAN update (Not CPU microcode), then see if you get same error with that BIOS. If you don’t then you know some other problem with your current mod BIOS.

Just opened the fresh downloaded bios file (from ASRock Website here), opened it in UBU 1.70.rc8 and choosed option “0 - Exit”.
UBU opened the file with the following log:

Scanning BIOS. Please wait…
Define BIOS platform - AMI Aptio V
Manufacturer - ASRock
Model - Z370 Professional Gaming i7

[EFI Drivers - Find and Extract]
Intel GOP SubGUID 380B6B4F-1454-41F2-A6D3-61D1333E8CB4
Intel RST GUID 7B17F47D-DA3E-48F3-8EFE-ABC82CB77F2C
AMI NVMe GUID 634E8DB5-C432-43BE-A653-9CA2922CC458
Intel 1Gb GUID 48392194-D155-4567-9AAF-FA805BAEEC6C
Intel 1Gb GUID 9006872D-3A86-4BAE-A2F0-E527B9D7119E

[OROM - Find and Extract]
VBIOS in GUID A0327FE0-1FDA-4E5B-905D-B510C45A61D0
OROM in GUID A0327FE0-1FDA-4E5B-905D-B510C45A61D0
OROM in GUID A0327FE0-1FDA-4E5B-905D-B510C45A61D0
OROM in GUID A0327FE0-1FDA-4E5B-905D-B510C45A61D0
Drücken Sie eine beliebige Taste . . .

Then i immediatly choosed option “0 - EXIT”, saved file as “mod_Z37PG73.10”, renamed the file back to its original filename (Z37PG73.10), put it on usb stick and tried to flash it with “instant flash” within BIOS Setup and “F6” during Postmessage Screen while booting up.
Both methods gave me the message “Secure flash check fail!”. Also tried to flash via latest AFUWIN - but still got the same message within AFUWIN: “Secure flash check fail!”.

Used UBU for a very long time w/o any problems on my ASRock Z270 Super Carrier. Never ever had a problem like this. Always was working flawlessly for me with Z170/Z270 ASRock Boards.

I understand that method you used before was failing, I only wanted to see if a not heavily modified BIOS would give you the same (with the UBU capsule removal as you mentioned above). You are correct, something has changed, the above should work for you based on it working in the past that way.

Did you try with earlier 1.7 UBU, to rule out any possible issue with rc8? If yes, then a new fix is needed, hopefully one of the pro’s will be able to help @CodeRush @ket @SoniX @lordkag

It seems, that ASRock has changed again the specific BIOS protection method regarding its mainboards with the latest/upcoming chipsets.

@MDoehler :
Please post your find into the UBU Discussion thread.

Thanx you guys,

i just updated my last post in the UBU discussion thread here with some more detailed informations.