Msi z690 a pro 12900ks

Hey, is there a way to add newest microcode for 12900ks to this bios? It’s already modded with couple of fixes but i dont know how to do it. I encountered couple of problems already with my build and it would be very helpful.
DDR4 PRO (8.7 MB)

Yes it can be added, by your request it seems you want to keep this old version with the mods…that we dont know nothing about them, what was done, how, who…etc, and also that you’re complaining of a “couple of problems” so you have no intention of updating to the latest bios 7D25v12 or 7D25v13 ?

i took this from felipe discord " MSI z690-a pro DDR4 good bios with no fucked bclk or usb" so i think just this were change, also on newest bios i tried to grub bclk etc but still i have a lot of problems so my idea is flash to “this version” what is good for 12900k but microcodes for 12900ks
Why i want flash this bios? easy i read a lot of about overclock on this discord and people can force gear1 cr1 and better oc score on this with lows temps

Ok…since youre familiar with GRUB tool, take a look at UBU tool: [Tool Guide+News] "UEFI BIOS Updater" (UBU)
extract the mcodes from the 7D25V13 or get it from here: CPUMicrocodes/Intel at master · platomav/CPUMicrocodes (, and update your current bios mod dump.
On UBU use the USER_mCcode folder and generate the mcodes present on current bios and newer ones/merged/replaced.

EDIT: Im not english native language “smth ofc”…

when i try to use “5” microcode cpu i have " u need to have python 3.7 or higher" so i install python but still doesn’t work

okey right now im on this step and i haven’t option “C” like in this guide, what i can do now?


I also dont see no OPTION C in UBU… and why are you messing with main MCUpdate.txt file, i said USER_mCode folder and generate with GenUSRmC.bat in Files/Intel/mCode folder, the mcodes must be already inside the user folder. If you want to use MCupdate.txt it must be updated with the new mcodes replaced in the main mcode folder, useful in future use… but i just pointed you the easiest way with usr_mcode option.

EDIT: Oh i see now what you mean with “C”… your looking at the guide and its an older version of UBU

I think i got it right. Thank you very much for the help!

@repo try this (used your bios file), updated the ME to , PMC to , and PHY-N to (all latest) as well. make sure to check the ME is updated to the version i mentioned on bios info (usually on device info) since i saw that the ME override is disabled, i enabled this. prolly if it does not apply, flash he bios again.

MODE7D25IMS.rar (8.6 MB)