[Need Help] ASUS B560M Plus WiFi BIOS Modding

I need help modding my Asus b560m Plus Wifi. Here’s what I’ve tried so far:

  • AFUWINGUIx64.EXE from AMI’s website (aptio V)

I executed the program and hit save, then I got a file named “afuwin.rom” (my bios dump)
then to confirm it was not corrupted I attempted to flash it, but was left with error (“c8 - Error: Invalid ROM image file, ROM file may be corrupted.”)

So then I tried a few other methods to disable bios lock and flash protect. I made a region dump via “FPTW64.exe”. It also output a corrupted file, or missed a few parts. The dump file did match the exact size of the original bios file though.

Then I went extreme, with a CH341 programmer and used it on my bios chip MXIC (MX25L12872F). I erased the chip, went to my ASUS motherboards bios update page and successfully flashed the oldest bios image I can find version (BIOS 0403)

Then I learned about Aptio V Uefi editor.
Link: GitHub - BoringBoredom/UEFI-Editor: Aptio V UEFI Editor: an alternative to AMIBCP
I successfully found the values and disabled them both. That’s when I discovered I have at least 30+ hidden settings and would like to unlock/view them all. Most of their access level where 09, or 01. However, some values where present in stock bios with the access value at 09 as well. Then I read a post about lost_N_bios about possible access values but didn’t understand much. Then on the editor, I changed most hidden bios settings to 09 instead of 05 or 01. Then I unchecked the “suppress if” values. After finishing building the file. I follow the instructions on the GitHub page. Then I take my output modded bios .bin file and flash it via my CH341 programmer. Since there isn’t another way. Now, I boot the computer successfully and went into bios. However, when attempting to open some configs in the advanced tab (where most hidden settings would be). The bios simply freezes then I have to force reboot.

Update: Settings optimal and failsafe don’t seem to have an effect either no matter what you set them to (on aptio V uefi editor) flash protect and bios lock remains on


Edit by Fernando: Thread title specified and customized

Why did you start this separate thread within the Category “BIOS Modding Guides and Problems”, whose title doesn’t even indicate, whether you need or offer help?
If you want to modify the BIOS of your mainboard yourself and have a problem with the procedure, you should better post your question(s) into an already existing matching thread, but if you want an already modded unlocked BIOS, I recommend to start a new thread within the “BIOS Modding Requests” Category by giving it a short, but meaningful title.

I think that HMRFPO could be unlocked using intel Flash Image Tool, if it was locked by default. Also if you want to use FPT you need to unlock the desc-me-gbe region, well it could be done manually if you have ch341a for dumping your bios. Using this information from here, you could easily edit the descriptor region in hex tools to unlock the region:


“FPT Unlocked”:

But then, flashing stock bios (any version) directly to the chip without backing the bios chip and making sure the dumped bios is not corrupted, is abit extreme XD (you could lose your uuid, mac address, etc.).

It seems you do know abt bioses, so you do actually flash the bios file, not the full cap file (the capsule body has been extracted so that the actual bios is there).

1 Like

Hello, I saw the title from the list as “BIOS UEFI Modding”. Which didn’t indicate whether it’s for tutorials or asking for help. Also the post of my title states that I (need) help modding my bios. However my apologies for my misunderstanding, how can I fix it?

Hey there, thanks for your reply!

I already have a backup of all my serials in an original dump made with the CH341. However, I do not really care about the serials for now, and I mainly bought the ch341 due to most unlocking methods not working for me. If my bios modding was successful I would probably add them at the end, since they don’t serve me any purpose at the moment.

My target is to unlock most of my hidden settings to be enabled, disabled or visible in the bios menu. I also do not understand where and how to rewrite the values for fpt lock and bios lock

using your bios dump, search the similiar 3 bytes (6 hex numbers) as per what i’ve shown in the picture above before (it is boxed and color coded so that you could understand which is which), after you fill all of those with FF’s, flash that bios and re test fpt if it could work.

Hey there, thanks so much for your explanation, I managed to make a full dump of my bios using FPTw64.exe. Then I located the values shown on my side of UEFITool in HxD and rewrote them to “FF FF FF” then saved. After re opening the file, UEFITool shows read and write list labled all “Yes”. Does this mean BIOS Lock and FPT Lock are both disabled?
I will attempt to flash this file now via the CH341. Thanks very much for your help :grinning:

Hey I’m back again, the lock seems to show its removed but fptw tool shows the same error
Thanks a lot for your help though, this is a big step I’ve been trying to achieve for months

biosfulldumpl.zip (8.7 MB)

Idk if this would help, but you could try: try.rar (8.4 MB)

1 Like

you have a typo in your title, there is b650, which is confusing.

thanks so much for pointing that out. Fernando changed my post up a bit

I’ll try that, thanks :pray:

Hello everyone
I was wondering if someone could mod my motherboard’s bios to have the following properties: enabling hidden options, remove bios lock and fpt lock
I have a ch341 programmer and have been using it to flash my bios mods normally, but my problem is I don’t know how to properly make good modded files, I’ve tried Aptio V uefi editor tool off of github, but every time I change settings (eg fpt lock value from 01 to 00) doesn’t make a difference. For enabling hidden bios tools, pc boots normally to windows 11 but when going into bios settings it crashes/goes into bootloop.

Since it doesn’t make sense to start 2 threads about the same topic, I have merged them.