[Need Help] Bricked ThinkPad T480 BIOS

Thanks for reply, i got the same problem as you had, which programmer tool you used?

Take a look at my original post, I documented everything I did.

I used flashrom (flashrom.org) to read from and write to the chip. Other than that, see my reply above on how I got the BIOS working again (or rather how lfb6 and sweet kitten did :smiley: ).

I’ll try to help if you have any questions, but it’s been a long time and I forgot most of the stuff :smiley: Laptop is still working like a charm though :+1:

Right now, keyboard lights up for a second, and then nothing. The CPU fan spins couple of times and that’s it. I tried flashing couple of .bin files (also dump from Sweet Kitten) with CH341A Black programmer with a clip and NeoProgrammer and AsProgrammer (both latest versions). Charging works, i can see orange light and later it becomes white.
And yeah, laptop worked before normally, all this happened because i wanted to remove supervisor password, and because of that now the laptop is dead. I found the original BIOS dump files on the external hard drive that i saved before, and turns out it is encrypted.

1 Like

How come the original BIOS dump files are encrypted?

I don’t know, it simply doesn’t look similar to other bios dumps…


You could post a link to it and the mods, perhaps modders experienced or acquainted with this one can take a look and figure something out. Since you have a programmer you’re not as restricted as other people.

In addition make a fresh dump of the SPI and let’s see what’s actualy stored there

Turns out, motherboard are shorted somewhere, that’s the reason why it can’t boot up.

same problem