Need help, update AMD_AHCI_DEV-4391

Hi, I own the 760GAP43_FX with the onboard SB710. The controller has a weird firmware version, it shows ‘0001.0078’ , but isn’t it supposed to be something like ‘v3.x.x.x’?

Anyway, I tried to update with v3.2.1.0 I found here in the forum, but no success so far. The device manager shows ‘PCI\VEN_1002&DEV_4391&SUBSYS_76991462&REV_00’.
With mmtool it shows me id 4391, 4392 and 4394 orom module. 4391 and 4394 contains the same as I could see after extracting them (arround 14kB data). 4392 contains 61kB data.
The update orom is much bigger, I still tried replacing the 4391 orom, but the result didn’t start (blackscreen). Any idea?

Firmware and Option ROM modules are different things.

Yes, the AMD AHCI ROM modules, which are listed by the MMTool as "1002:4391" and "1002:4394" are identical. The listed "1002:4392" is the AMD RAID ROM v3.0.1540.59.

Yes, the löatest AMD AHCI ROM v3.2.1.0 has a size of 26 KB, whereas the AMD ROM modules of your original mainboard BIOS have a size of 14 KB.
Nevertheless there seems to be enough space within the BIOS to get both AMD AHCI ROM modules (shown as "1002:4391" and "1002:4394") updated by the MMTool. I just have successfully done it.
By the way: This does not automaticly mean, that the AMD AHCI Controller will work flawlessly after having updated both listed OROM modules.

Ok, thanks for the help, I will keep trying to get it working.
So far I didnt flash my modified BIOS, I just used the ‘M-Flash Boot’ Feature. With this I can try an BIOS without flashing to minimize the risk of a bricked board, by loading from stick at bootup. Unfortunately it gave me blackscreen with all my modificated versions. Would you mind to share your try, maybe it works better than mine?

When I would start offering already modded BIOSes, I wouldn’t be able to do anything else.
Exactly this was the reason why I have written my guides.