Not enough space for Intels SataDriver

Good Day Fernando…
There is no SataDriver.ffs on my P67-Sabertooth.

BIOS Version 3602

Im Trying to insert SataDriver.FFS on my ASUS P67-Sabertooth but it keeps saying "File Size Exceeds the Volume Size"…
I just want to install my OS in UEFI mode which is Windows 7… so to verify my bios … I open it with MMTool the I follow the guide you wrote here on our forum. I search for the SataDriver to be replace and I dont find one… so i try to insert a new module, based on your guide too. and the result is that file size exceeds error…

By the way I successfully replace the current option rom of my intel raid to without any problems. Raid and Trim support is working on my SSD…

Hello Chironz,

welcome at Win-RAID Forum!
I am sorry for haven’t replied earlier, but I travelled yesterday to Spain and had no internet access until now.

Now to your problem:
If the inserted SataDriver file size exceeds the BIOS volume size, I recommend to remove the Intel RAID ROM module before you retry to insert the EFI SataDriver module. This will be without any disadvantage for you as long as you are using any Windows OS, which has been installed in EFI mode.

Good luck!

Thanks for the welcome and for replying my problem… i forgot to mentioned that i try it also. i just insert it on untouched bios means i dont replace any option roms or modify any module … and still got the same error…

If there is not enough space within the BIOS for a new ca. 120 KB sized module, you have to create the needed space by removing another (unneeded) module.
Since your system will not use the Intel RAID ROM anymore, if you are running the OS in EFI mode, I suggested to remove that OROM module.

Thanks it successfully inserted and when i reopened it i already see the "satadriver" module… but i still havent flashed it on my board… im preparing my stuffs for uefi… Thank you very much

First, thank you a lot Fernando for this forum and all the bios modding guides, all latest ROMs and your time.
I am having hard time modding the GA-Z77X-UD3H (F18 and F19) BIOS with the UEFI RAID Satadriver. For some reason MMTool don’t work for that one. Stasio from TT forum seem to say that we need a special tool for that (not MMTool). If I try to add Satadriver with MMTool is says that there is not enough space to insert module. Help will be appreciated.

P.S. Is there someone by chance that fixed the USB 3 port "not able to enter in the BIOS with keyboard’ thing in the F19 BIOS?

EDIT by Fernando:
I have changed the thread title. This way other users with the same problem may find a solution much easier.

@ Teddybehr:
Welcome at Win-RAID Forum!

It surprises me, that Gigabyte obviously has not yet inserted any Intel EFI SataDriver module into their Z77 chipset mainboard GA-Z77X-UD3H. You should ask the Gigabyte Support for a new BIOS with included SataDriver.
Nevertheless here is a workaround:
If there is not enough space within the BIOS for the insertion of an additional module, you can try to create some free space by removing another module, which is not needed anymore.
Since the SataDriver module overtakes all tasks of the Intel RAID ROM module, if you will install Win7 or Win8 in EFI mode, you can remove the LEGACY Intel RAID ROM module from the BIOS.
This is what I recommend to do:

  1. Open the BIOS with the Aptio MMTool and remove the Intel RAID ROM, which is within the CSMCORE file listed with the DeviceID 2822 or 282a.
  2. Save the modified BIOS.
  3. Reopen the modified BIOS and insert the SataDriver module according to my guide.
  4. Save the BIOS and check, if everything has been done correctly (by extracting the inserted SataDriver).
  5. Flash the modified BIOS according my advices.

Good luck!


Hi Fernando,
I actually took a big leap of faith although I knew I was in good hand with you.
Using MMTool, I tried to remove the Intel Raid rom (DeviceID 2822). Still not enough space.
Then, I started with the untouched BIOS file again, I remove only the AR8161 (dev ID 1091) rom since I have a AR8151 (dev ID 1083) rom … in the CSM section. Then, I inserted the UEFI SataDriver as per your instructions. Saved the BIOS.
Flashed the BIOS (closing my eyes) and …I am still alive
MSinfo32 is telling me that I am still booting in UEFI mode.
It worked!
Thousand Thanks Sir !

P.S. The ultimate test would be to disable the CSM support but my video card don’t have a GOP vbios dammit.

Thank you very much for your feedback.


Please report here, if you already have done the prepared OS installation in EFI mode.

By the way: Since your thread had the same topic as the thread, which has been started later by Teddybehr, I have merged them both. This may make it easier for other users with a similar problem to find a solution.

Hoping, that this is ok for you

There is already a modified bios for Gigabyte F19j for a long time…html#post455435

Intel® Legacy RAID for SATA - v12.6.0.1867
Intel® UEFI RAID SataDriver - v12.6.0.1867
ME Firmware
Atheros PCIE Ethernet Controller v2.0.6.6 (05/16/12)
Atheros PCIE Ethernet Controller v2.1.1.5 (03/15/13)
Intel® PCI Accelerated SVGA BIOS 2158 PC 14.34 (11/23/2012)
Marvell 88SE91xx Adapter - BIOS Version
Ivy E1(06A9) CPU-MicroCode Rev.17

Stasio did say that there will be no Satadriver EFI module in the F18 bios as its not compatible, its not a full EFI bios and doesn’t fully support Win8 features.

PS if you remove the Raid rom module to make space, how do you set up your raid array when you reinstall os ?

After having chosen the required EFI mode settings within the "BOOT" section of the BIOS you are able to join the "Intel(R) Rapid Storage" tab from within the BIOS and to create the RAID array.

Ahhh Ok.

Slight problem with this F19j bios then… there is no "Intel(R) Rapid Storage" tab anywhere.

The only way i have been able to install Win8 (previously Win7x64) in EFi mode with my Gigabyte Z77 UD3H board is do as follows.

1)Set bios storage boot mode to "Legacy and UEFI".
2)Erase disks with Secure erase/whatever.
3)Use Legacy ROM (ctrl+i) to set up the array.
4)Set bios storage boot mode to "UEFI only"
5)Install Windows

Unless Bios F18 is any different (which i hope it is lol, as the F19 beta series are notoriously buggy) then there is no option to enter Intel Rapid Storage, once in EFI mode.

I would love to use bios F18 for that board as its more stable, but Stasio the Gigabyte guru explicity told me that for full EFI installs its not possible to insert EFI Satadriver !!!