NVMe boot support for Asrock X79 Extreme6

Hello and Happy 2023 !

I am trying to give my old pc some life. I just went from Win7 to 10 and cloned in a sata ssd OS drive and now i am motivated and i want more !!
Modifying the bios looks like a little more than i can handle right now. (I went through the guide)

If i could just boot Windows-10-pro from an NVMe-M.2-SSD on a PCIe card/adapter I would be one happy camper. I suppose ideally i would boot from one of the PCI Express 3.0 x16 slots

Asrock X79 Extreme 6 with an Intel 3930K
I am currently on the latest and greatest bios from May 5th, 2014 version 3.10

I could only find mods for the Extreme 4 and 9 and not my 6.
I did find an old blog post from Russia with a link to a file. Looks legit but I thought I would see if i could get a little more hand holding.

Thank you for your consideration,

1 Like

Here you go:
X79E6Nvme.rar (4.9 MB)

This bios also support Pcie Resizable Bar if your gpu supports it (a minimum of AMD Polaris/GCN 4.0 8GB or Nvidia 3000 series is required).

How to enable above 4g decoding (hidden in the bios, just read from step 5, csm must be disabled by default): Enabling hidden 4G decoding · xCuri0/ReBarUEFI Wiki · GitHub

How to Enable the Resizable bar: run this app as admin and type 32 for unlimited rebar size. how to use certain size? just calculate it with 2^ something, for example, 2^10 = 1024, which means 1GB rebar is set and enabled.

This is your Above 4G VarOffset (i left the setup.txt for you to find anything useful you want to enable):

1 Like

Hi Koekieezz,

thanks alot for doing this!

I cannot extract anything from that file. I usually just right click zip files and “extract here” I am getting errors when trying to do so.

…edit… i tried another extractor and got it.

I should have my PCIe adapter card and ssd in a few days and will give it a try. Will i be able to use any PCIe slot ?

I have no idea what 4G decoding is but am about to find out.

thanks again

Yes, any pcie card on and pcie slot should be fine, i would recommend to disable CSM, make sure that your installation files for win10 is set at UEFI and GPT instead of Legacy + Bios. that way you could have full uefi running.

Above 4G means that the board would be able to reallocate the memory of gpu. so yeah i include the rebar mod so that if you have any 8GB+ amd card starting from polaris arch or any nvidia 8gb+ rtx 3000 series your board could do resizable bar, that way your cpu could access the whole vram directly instead of 256mb.

i wonder if the bios mod would work, inform me if you flashed and it worked. send dxdiag and Cpuz > Mainboard tab ss and send it here.

also added more lga 2011 mcode, you could check it using mcextractor for the list of mcode compared to original ones.

I think it is working. thanks @Koekieez

gen 3


1 Like

Hi folks, excuse the noob here, i am trying to flash the bios on my X79 Extreme 6 for NVME support.I have downloaded the file " [X79E6Nvme.rar (4.9 MB)" but it wont recognize the file on my USB when i boot into the bios to flash?. Can someone point me in the direction of perhaps what i should be doing!!. Thanks in advance

Yes…seems that we got a user that likes to add its own “print” and renames the files, edits bios revisions on shared bioses, against my “judgment” seems that the admins allows it.
The forum is not responsible for any of this shared files and their use, still its your choice only, to proceed further, as the last public version is 3.10

EDIT: No offense made by your words and you’re free to roam the forum and all its resources.
Your free to follow the guide here presented by Fernando as a choice of doing yourself the NVMe mod using the official bios file 3.10 from its source.
[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

1 Like

Completely understand and apologies if i offended!

you need to extract the bios file from the .rar

1 Like

Thanks, i did extract it. Put it on my USB, but when booting into the Bios it scans the stick but does not see the modded bios file. That’s kinda where i’m stumped!

try this one, it is what i am using now

Asrock_X79_Extreme6_X79E6_4_barsmonster_NVME_boot.ZIP (4.9 MB)

1 Like

Thanks. Just tried it and the Bios still dosent see the file on the USB. I will read the Original 2.7 bios on the USB no problem. IS there another program i should use instead of bios flash?

intel fpt for me8 ones, its chould be able to flash the modded bios i provided on the fly.

also you could try to rename the modded bios to the same one as official latest bios

1 Like

I would try different USB ports on your pc. try the 2.0 ports on the back; the red or black ones. and maybe clear your cmos first.

1 Like

Thanks, going to do it now

Thanks everyone for the help and patience. Got the bios mod installed and im now booting from my new 1Tb NVMe. Happy days. I will continue to read through the group and up skill!.