NVME support for Asus Sabertooth 990FX\\GEN3 R2.0

Modified BIOS v2501 firmware file with NVME support for Asus Sabertooth 990FX\GEN3 R2.0 motherboard. Modules NvmeInt13.ffs, Nvme.ffs, NvmeSmm.fss are taken from BIOS v2901 for Asus Sabertooth 990FX R2.0. Use Asus USB FlashBack for firmware

ST99R2G3.rar (3.07 MB)

1 Like

I flashed this firmware last night but haven’t been able to get the NVMe support figured out. I have a PCIe M.2 adapter installed in the PCIe 3 slot but the mainboard doesn’t seem to see the drive at all. Is there a BIOS setting I am missing?

I m too

Try again…both.
Where did u heard about his mod…MOON? So pay respect to it…at least and read it, learn.
Oh by the way… the poster wrote it with a bunch of words and lines just to get fancy with it…nothing important…lol

[HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS

I was able to get it done after finding the steps elsewhere. I had to initialize the drive in Windows first, then clear the secure boot keys, disable the compatibility module, and set the OS option to other. Then install Windows.

I downloaded the bios but received a message that security verification failed when trying to install. Attempted installing via usb flashback but again the process would not work. Anyway you can package this again that will allow me to use EZFlash and not get the security error?


For ASUS motherboards with USB BFB feature on it, this is the recommned method…
Its normal that other than that, it fails due to security/verification issues on modified bios files.
Further guidance here:
[Guide] How to flash a modded AMI UEFI BIOS - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

EDIT: Theres reports of users with the same issue, sometimes a different model of USB drive will work, some on FAT, some FAT32… it can be picky sometimes.
Cut off AC for 5m, CLR CMOS, power AC again and try again.
I had a board that only after removing GPU and RAM sticks and removing CMOS battery, it worked… picky :crazy_face:

Last resource…do the mod yourself:
[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

Good luck.

I followed the usb flashback process to the letter. Light blinks a few times then goes solid. Never turn off. I’m using usb 2.0, formatted fat32, drive size is 512mb, file has been named appropriately, quadruple checked the flashback port.

You are the man! Changed usb drives and it worked like a charm!!! Thank you!!!

1 Like

If I wanted to open a bios file and mod it for myself what would I use?

Since you state “a bios file” and not specified your motherboard bios i believe you want general guide, the basics…

BIOS Modding: Introduction and Preparations - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

[Guide] Manual AMI UEFI BIOS Modding - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)