[OFFER] ASUS M5A99FX Pro R2.0 v2501 BIOS with NVMe Support

I wanted to thank the forum for the helpful tutorials, without them I wouldn’t of been able to add this new feature to my existing computers!

The modified bios for the Asus M5 A99FX Pro 2.0 Rev 1.01 that includes nvme support is included.

M5A99FX-PRO-R20-ASUS-2501.cap <– Original bios version 2501
m5a99fx-pro-r20-asus-2501_modified.cap <– Modified bios

I used the MMTool utility in order to generate a compressed DXE section of the bios so that it matches the structure of the rest of the bios guids. I flashed the bios by using the usb utility of the bios. You will need to rename the bios file to M5A99FX and put it a usb 1.1 drive formatted to fat32 with no other files in it. Then use the usb flashing button on the motherboard while the computer is powered down while the powersupply is connected to an outlet. Follow the instructions on the motherboard manual. See page 2-13 of the manual at:


I hope this helps someone outhere!

EDIT by Fernando: Thread moved into the correct Sub-Forum and title customized

MBASM599FXProR2Rev101.zip (3.06 MB)

MBASM599FXProR2Rev101_Mod.zip (3.07 MB)

1 Like

This is awesome and I can validate it works. I’m using this live right now and it was painless to setup, just do the button press bios update on the board and it will pickup the NVME.

It was such a rare sight I refused to install the OS while having my regular sata drives, I couldn’t believe it was that easy… but it was.

So I started wondering, if I were to setup a raid card with two nvme’s… would it work with this bios?

Hello! Salazc, I had strange problem with your BIOS. It’s funny, but… Old Phenom 1100t booted and worked flawlessly, but newer FX-8350 - NOT! BSODs, no NVMe drive and other bugs. Same config, same board, I swapped only CPU. Of course, I resetted BIOS to defaults, cleaned all contacts, changed SecureBoot and CSM settings… No effect… But with Phenom it works great.

So, I’ve taken 3 NVMe modules from Sabertooth 990FX 2.0 BIOS and embedded them into v.2501. Flashed BIOS via USB Flashback (mo-bo manual, page 2-13). Works flawlessly with my FX-8350.

1 Like

File didn’t attached to last post. Here it is.

m5a99fx.cap.zip (3.07 MB)

1 Like

MV, Thanks for including the nodded BIOS for the 8350 it worked perfectly. I’ve had my Samsung 970 Pro nVME m.2 drive for a little over a month now, installed Windows 10 on it when I got it, and was about to try to lean how to mod my BIOS myself. You saved me a lot of reading forums and aggravation. Thank You!
AMD FX-8350
970 EVO Plus NVMe M.2 SSD 1TB

Hi guy, i have a rocket sabrent NVME 2280 with pcie adapter, my speed on test is 1500 on read and 1000 on write, what are your tests? and what NVME do you have? thank you

So, this is going to work with an FX-8370 as well, because you kept the original 2501 code and just added known working NVMe modules you scalped from the Sabertooth BIOS?
(keeps fingers crossed…)

EDIT: Worked like a charm. Thank you MV.

NVMe SSD 960 EVO 250GB RIITOP adaptor

ssd spec.png

Is there any way to boot from an NVMe on the A99FX? I’ve been trying to clone an old drive over to one and I can’t seem to get it to identify it as a bootable drive at all. Show’s it as a PATA drive but otherwise won’t boot from it.

Yes there is when things r done in the correct way.
Go read again, specially the point 4 of the guide: [HowTo] Get full NVMe support for all Systems with an AMI UEFI BIOS
and ull find out wot u messed up.

EDIT: May 2023, updated the original file shared by MV1 user on post #3
Cpu mcodes updated, RTL LAN and AMD RAID Xpert modules, NVMe is present as in the original file. ONLY method to flash is ASUS USB BFB feature.
M5A99FXR2.0_2501_2023.rar (3.1 MB)

EDIT: The topic thread is NOT mine and it offers a mod bios v2501 referring to the motherboard revision PCB 1.01
This doesnt matter as the ASUS bios files available from ASUS do not take in count any PCB revision of the motherboard as it is ONLY the R2.0
So the bios files v2501 original or modded are for the ASUS M5A99FX PRO R2.0, period.

I’ve tried all the bioses in this thread but all of them have given me the same problem which is that the SSD isn’t always detected. Whenever I turn the power on I will 90% of the time get an error message saying to change my CSM settings and I have to hit the reset button a few times before it will finally start booting my OS. Here my specs:

FX 6300
16g Gskill Ripjaws DDR3 2400
32g Intel Optane Module plugged into one of these things
7x 1tb SATA III HDDs

Operating system I’m running is TrueNAS Core

Curious if anybody has had similar problems.

First of all, the guide presented on the forum, by Fernando in witch this NVMe mod is based, its for booting Windows OS on older motherboards.
The Optane disk i only used as intended, acceleration drive, not a main OS or a NAS system.
Third… maybe the post from this user experience can help you: [HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)
Good luck.