[OFFER] Asus Rampage IV Formula - NVMe BIOS mod (5001)


Probably the thread will be the only one in this forum, but I want to help the community.

- ASUS Rampage IV Formula (R4F)
- 1x ASUS Hyper M.2 x16 Card V2
- 1x Samsung 970 PRO 1TB

1. Put the R4F.CAP file into a USB drive formatted with FAT32 filesystem
2. Flash your BIOS with ASUS Flashback procedure (put the USB drive in the ROG Connect port and press the ROG Connect button for 5 seconds)
3. Your NVMe drive appear as "PATA SS:"

- Rampage-IV-Formula-ASUS-5001_MOD_V1 includes uncompressed NvmExpressDxE_2 (RECOMMENDED)
- Rampage-IV-Formula-ASUS-5001_MOD_V2 includes uncompressed NvmExpressDxE_4


Rampage-IV-Formula-ASUS-5001_MOD_V1.zip (8.51 KB)

Rampage-IV-Formula-ASUS-5001_MOD_V2.zip (4.53 MB)

*Note on reports from users: Several users reported unsuccess using the both files.
If such happens, it’s advisable to build the mod manually, following the forum guide.

Excelente Bro. Muchas gracias

Bueno, al final no funcionó. Lástima

Hi I tried to update the bios with Rampage-IV-Formula-ASUS-5001_MOD_V2 includes uncompressed NvmExpressDxE_4

However it says that the bios is not signed and does not want to install it. Is there somethign to do in the bios first?


Same problem. Help is needed.


try to use the version "Rampage-IV-Formula-ASUS-5001_MOD_V1 includes uncompressed NvmExpressDxE_2".
It is tested and correctly working on my PC.

ATTENTION!! You need to flash your bios with ASUS Flashback procedure!!


Tried to flash V1, bios flashback will not recognize the file. Tried V2, flash successful, but will not post showing code 00. So then I flashed stock 5001 successfully to get it to post and tried V1 again, will not flash-doesn’t recognize the file R4F.CAP. Tried multiple usb’s to no avail. Am I missing something?

Flashing either v1 or v2 give CPU Code 00 - Using E5-1650 v2. Anyone have a working version?

I used @Lost_N_BIOS guide and was able to create a proper NvmExpressDxE_4 R4F.CAP NVMe Supported BIOS

R4F-5001-NVMe-DxE_4-Mod.zip (4.53 MB)

*Note on reports from users: User on post#18 as reported unsuccess using this file.

Hi,does anyone else have the same problem like me,one every bootup the bios doesnt see the ssd but its enough to enter in the bios and to make some misereable changes…like turn of and on fast boot and csm compatibility.Yes i flashed the bios

Does this allow for the use of Raid with 2 NVMe’s?

I get a "Security Verification Failed" when trying to update. I was really excited to try this!


The mod is for using the USB FBF method not EZ or other method. Besides BFB its normal the security issue from Asus due to be a modified file bios.
Asus USB BFB is the most viable and easy way to flash a bios mod when available in certain motherboards.

Thank You! Struggling as that update procedure would not work for me either. I tried multiple mods, three flashes and nothing. Stumbled across a post stating that the procedure never works for the poster unless USB drive is FAT16 and under 4gig, BINGO! Nvme drive should be here tomorrow, thanks all!

any help please?
v1 seems to be corrupted. i cant flash it
and v2 is not working to. i was able to flash it but cant boot after 00 post code

i tried to open both files with UEFITool.exe and only v2 file opened
when im trying to open v1 it says


also when im just checking if the files are fine im using EZ flash in asus bios
v1 give me error saying the file is not a UEFI bios
v2 says Security Verification Failed

**i know i need to falsh it using ASUS Flashback procedure

https:// www. asus. com /en/support/FAQ/1038568/

but files seems to be corrupted?

i tried everthing when i got bios v4804 and it failed to flash
then i flashed to v5001 official version and it flashed just fine

but those modded bios files seems not to be working?

Use the file on post#7 by Xenophobian

Do please report back and i’ll edit a note on the op regarding issues using his files v1 and V2, thank you.

its not working as well
but i was able to modd official bios file using this guide

u need just 3 files
lastest bios (v5001 in my case)

modyfing bios takes less then 1 minute
and flashing bios took like 70 seconds

u need just 3 files
take here [HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS

google and download from github

lastest bios (v5001 in my case)
download from asus website