[OFFER] Gigabyte GA-Z370-Aorus Gaming 7 BIOS mod

Dunno how i did it lol but i tried before and it didnt work :confused:
worked this time now im back on F6 :smiley: update 3…

hope in future you can add Losts 1bit string to the past and future bios`s for z370 gaming 7 motherboards so that we can go forward or back using internal Qflash as its a lot easier, still im not exactly sure what i did to get it to work hahah… :slight_smile:

When I go back home after my vacation I will do that .I won’t be back untill 14 Aug

Nice one mate :wink: will look forward to that getting done, i wonder where lost is with that guide hehe :smiley:

Try adding /x switch in EFIflash the default one with F6 BIOS.

Im already back on F6 now mate, :slight_smile:
just awaiting your guide so i can add the qflash unlock 1bit change to the F6 update 3 file that way i can flash back and forth and figure out how to get F7 working lol

Sorry, I noticed that later, but planned to edit that in when I added example of this Qflash block removal.

Here is generally how to edit BIOS post-Mod to allow Qflash to accept the image. You do this by hex edit on the entire BIOS image after all your other mods are done.

Don’t do this mod with UEFITool, you can find this and extract RAW location, but when you put back it always rebuilds too many sections, and trying to mark do not rebuild causes it’s own issues.
In case anyone planned to try and do that while doing other mods while in UEFITool. Best to do this one after all other mods are done, by itself, on the final BIOS image as a whole via hex edit.

Search BIOS w/ hex editor to find string $BDR, 4-6 lines below this you’ll find section of 10-12 count (usually) 00 bytes, followed by 50 01 or 40 01 and then next byte varies usually 03 or 04 or 07, followed next by 01. This last 01 you change to 00, this is what removes the block.
I’ve always seen 40 or 50, then 01, but next digit varies, then 01 again for the default block. It’s hard to explain because the bytes leading up to the byte to change are not always the same, but the general area is easy to spot, so once you are familiar with looking there you will easily recognize.

Here’s what that looks like in F7Mod BIOS, with the block still in place (01)

Thanks buddy, i will be able to work on F7 now with easy access now and in the future to be able to revert back and forth with Qflash instead :slight_smile:
btw just a quick question, when flashing via Qflash there are 2 options you can pick from

Fast flash method or full method
seems the difference between the 2 are the intel management, fast does not update this but full method does.
is there any way to add the latest intel management to future bios`s or is it best to just wait for Gigabyte to do that work and just update from within windows with the intel managment updater instead :slight_smile:

cheers again for the help…

You’re welcome! I am not sure that’s going to remove a block due to ME or microcode etc set by Gigabyte, that only allows modified image to be flashed as far as I know, but maybe you are right it will work for backflash from F7 to F6 when official unmodified BIOS does not allow this (? Let me know)

Full updates ME too I think, yes, like you mentioned.

Intel ME can be updated according to these guides, any time you want, or you can wait on MrBeer future mod updates or Gigabyte’s etc
System tools (For correct version Intel FPT and FW update tool, if needed, and correct version Flash Image Tool to update ME, transfer stock settings etc) - Intel Management Engine: Drivers, Firmware & System Tools
How to clean and use updated ME version with proper settings transfer from your original BIOS/ME - [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization
Intel ME FW repository, for getting the update you want - Intel Engine: Firmware Repositories

Thanks mate i will give you a buzz once i test stuff out and let you know if Qflash works for going back and forward :slight_smile: with the 1bit mod
probably be next weekend though as i work night shift. sun-thurs :wink: but i will keep you updated.

u can easy flash intel me with the flasher on the first post.
playing with the intel me can cause alot of problems and gigabyte lets you flash it with the provided tools.

on the old gigabyte z77 motherbord when u use to flash qflash it would ask you if you wanted to flash full or partial flash and partial would not update intel me.

Just a update guys…
Managed to have a look into the hex editing, and can report going back and forward with modified bios files.
i have done the hex edit to the F6_U3 bios and i can now go back and forth with ease from F6 to F7 and F7 to F6 via Qflash with no dos interaction at all.
i will report if the same works for official version but i cant see why it woudlnt

so i can report this Qflash Hex fix does indeed work for going forward and back and vice versa and it only took me about 2 minutes to do the edit lol :slight_smile:
and yeah Lost your right once you see the string and know the location its very easy to spot :slight_smile:

i will do this on all bios going forward will fix the bios files when i get home.

Thanks for the report back on that test @ViRuS2k
To confirm, without that mod, you were unable to flash backwards with official F6 from F7 using Qflash (Both unedited, from Gigabyte)?

Yes mate, without the 1bit hex change i could NOT go backwards with Qflash after flashing F7 from F6.
the mod works :wink: with no ill effects.

Just a heads up guys, after further testing :slight_smile:

the routes people can take when upgrading and downgrading if needed and in future, if the files have been 1bit edited for Qflash compatibility you can flash back and forth when ever you want
but if in the future a new firmware comes out and you want to flash EXAMPLE : F7 modded to F8 official you will need to do the 1bit edit to the F8 Official bios to be able to flash from a modified bios to an official bios otherwise you will get invalid bios message when trying to update with Qflash.

those are the only limitations i have noticed with Qflash.
but with Efiflash you can flash anybios you want back and forth with the /NoId command (If for example you want to go from modified back to full on no editing official bios…

though these issues will not happen or you wont notice them if you get your bios from this forum/thread as they will have already been modifdied with the 1bit hex fix for Qflash so updating will work always…


hope this helps and explains little more :slight_smile:

F7 Bios Update #1 (OROM IRST RAID for SATA + fix to flash in QFlash)
F6 Bios Update #4 (OROM IRST RAID for SATA + fix to flash in QFlash)
Not tested i am on vacation Till the 14th.

Ok All tested.
Intel® Management(ME) (Firmware) update.

Nice one :slight_smile: is there anyway to intergrate these Intel Managment ME`s into the latest firmwares ? if to much hassle just leave as standalone lol

Intel Managment ME need to be flash with the tool.I think it can be added but the last time i try that on the asus board i brick it.

Yes, Intel ME can be put into these BIOS mods, using this guide - [Guide] Clean Dumped Intel Engine (CS)ME/(CS)TXE Regions with Data Initialization
Follow ME rules here when finding your updated ME version - Intel Management Engine: Drivers, Firmware & System Tools
ME FW Repository here - Intel Engine: Firmware Repositories

If you need me to send you working sample @MrBeer so you can see it’s OK, let me know.