[OFFER] Maximus V Gene NVMe support

Hello, I am using the Maximus V Gene NVMe Bios provided by you, but the motherboard prompts an error that the security verification failed. What is the solution?

The bios mod file presented in post#1 is for using Asus BFB feature, not EZ update or OS environment.

Does this BIOS include any updated modules?
There’s several BIOS’s on the Asus forums for this board with updated modules but this is the only one I’ve seen that includes NVMe support. A combination of the two would be perfect.

Here, M5G v1903, BFB method ONLY, all updated (except vBios) and NVMe (07-07-2023).

Thanks! Not that I don’t trust a random BIOS obtained online…but for my peice of mind and completeness, would you be able to list the module versions included in this BIOS mod?

Well you trust it or not, its a user choice here… but not very valid when its yourself asking for it humm?

A combination of the two would be perfect…

You may find the versions of the modules yourself …without even flash it before.

But here it is, just for future users consideration…


Thanks again. No disrespect meant, just I like to have the full details before I try it.
I’ve noticed my current bios has some newer and some older modules:

Intel(R) Rapid Storage Technology - OROM - v14.0.0.2198
Intel(R) Rapid Storage Technology - SATA EFI GUID 90C8D394 - v14.0.0.2198
Intel(R) SandyBridge/IvyBridge OROM SVGA BIOS Build Number: 2170
EFI GOP Driver (IvyBridge) - v3.0.1027
EFI GOP Driver (SandyBridge) - v2.0.1024

Is there a reason you chose the Intel rst and sata v13 module instead of the v14?

Yes… because its the recommend for Intel Serie 7, regarding compatibility and performance and windows driver is also v13.
Myself had using it for almost a decade on my own Asus M5F…
By default mostly of these bioses came with v12 as can inspect yourself from older versions/original bios of your motherboard model.
V14 is implemented in Intel 8 Series.

Further info here:
Which are the “best” Intel AHCI/RAID drivers? - Important Drivers / Specific: Intel AHCI/RAID Drivers - Win-Raid Forum (level1techs.com)

Hi MeatWar,This link is deleted. Can you please upload it again? Thank you very much.

Forgive my potential ignorance, but afaik the Asus Maximus Gene V doesn’t support BFB. Is there a workaround?

Your “potencial ignorance” is forgiven… just try to do better research but this time with your eyes wide open, unless you got a M5G “SE” version that we dont know nothing about, all the best, over_n_out.

Hi, I’ve just bought myself a PCIe adapter and a M.2 NVMe SSD and discovered that the Gene V bios doesn’t support booting from it.

I tried downloading the custom bios at the top of this thread, put it on the root of a FAT USB (windows install media), placed it in the specially labeled port on my mobo and pressed the adjacent button until it flashed for BFB, but when it stopped flashing and I booted it didn’t seem to have worked (just reset my settings). Is that the right one, or is it the one that’s now unavailable for download? Or have i done something wrong?

Any help appreciated, thanks.

And why do you say that?
Every new user that comes here looking for this NVMe mods also needs to read the fowling guide:
[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

EDIT: The manual confirmation of the mod flash (PATA device) and OS install section.

Mainly because the drive didn’t show as bootable in the bios still. I also think the version number at the bottom might have said xxx.1208 or something (I’m not at PC right now to check), so I thought it might have reverted to factory default or something.

I have read that post, although i might not have understood all of it. Which bit specifically are you referring to?

You will nevertheless be able to boot off the NVMe SSD, if you follow the GUIDE, which has been linked by MeatWar.

I have had another look at the guide and I see the PATA listed, so I guess it did update, and I can follow the rest of the guide. It was mainly being unsure whether first one was correct or the detailed link not working meant I needed to build my own. Thanks

I had hoped to keep my existing windows install (i copied my partitions before realising it wasn’t bootable) and had tried to update my bcd to point to the NVMe from my old SSD. Is anyone able to explain what is different about the freshly installed boot manager for the NVMe so I could manually edit it, or is it additional files installed somewhere?

Thats what i tough… users rush in flashing and doesnt bother with the details.
I do not encourage and will not help on this, regarding cloning…
I left cloning long time ago… i believe its useful in emergency situations not on achieving the best/stable performance…or lazy users.
A clean OS will show you the correct performance of an old motherboard/chipset running a modern NVMe disk, all the best and good luck.

I’m sorry that you feel I rushed.

I had spent a lot of time on this before ever discovering that this forum existed. I simply missed the vital information about the PATA hidden inside the “additional information” section. I don’t think it’s unreasonable to think that the device would show up as bootable in the bios when that was the point of updating it.

I understand that a clean install is better, and I will probably do one when I completely upgrade my pc, however at the moment I am just trying to keep it alive until then (even if it’s not optimal performance).

I just hoped I could avoid the brute force approach of a fresh install by surgically altering what I already have, which just requires more information on whether it’s possible and what to change.

UPDATE: I got it working, although I’m not sure how many steps were important:

  • copied EFI partition back to new SSD
  • tried to manually correct the bcd to point at the right volumes (didn’t work)
  • followed the initial bootrec steps here (didn’t work, got the error it mentions)
  • deleted, then recreated bcd with bcdboot c:\Windows /l en-gb /s b: /f ALL as described
  • rebooted, didn’t work
  • changed boot device from “Windows Boot Manager (<my device name>)” to another which was just “Windows Boot Manager”
  • rebooted, returned to bios (tried 2x)
  • changed back to manager with my device name and it worked!

Further update: I rebooted to re-enable my virtual memory and SATA controller, and the boot manager without the device name has now disappeared.

Final update: Benchmark

Many thanks to the creator of the bios, I just wish the subsequent support was a little more positive/productive, but I got there in the end :slight_smile:.

Sorry >< this link is dead, can you upload file again ?

1 Like

2 posts were merged into an existing topic: [Release] Resizable BAR DXE driver