[OFFER] Rampage IV Black Edition (NVMe + OpROMs with optional uCode update)

Hello all.

Since I got myself a new MB, I decided to update/mod it’s BIOS.
For now, there are two versions (both based on official 0801 beta), first one with NVMe patch (v4) and OpROM updates, and second one with added uCode updates on top that.

Version A vs. Stock :

^other than updates that can be seen above, NO other SATA or USB controllers were updated

Version B vs. Stock (showing only uCode because otherwise, it’s the same as Version A) :


BOTH were tested by me, on my RIVBE :

Version A :

Windows will use whatever uCode it has available from updates that were installed : LINK.

Version B :



Remember to use USB BIOS Flashback on switched off PC, ROG Connect (Red) button pressed for few seconds, and pendrive in proper USB port (Arrow) :

Keep in mind that some models of pendrives, are NOT compatible with USB BIOS flashback (even if formatted for FAT16/FAT32 and with proper R4BE.CAP file present).

Disclaimer : No way I’m responsible if you brick Your board when doing BIOS update, or when BIOS update itself fails.
Also, when everything fails - you can always switch to other BIOS chip by using convenient black button on bottom of the board (called “BIOS_SW”) :wink:

EDIT : I added Ver. A with bifurcation support from Lost_N_BIOS.

Version A.zip (4.81 MB)

Version B.zip (4.93 MB)

Asus RAMPAGE-IV-BLACK-EDITION-0801-Version-A-Birurcation.zip (4.83 MB)

I bought a RIVE, are you willing to mod the BIOS for that too?

@User32 I could, but I don’t have RIVE. Can’t test it before sending it to you :confused:
Do you still want it ?

If it doesn’t brick my (expensive as hell!) board I would like it.

@User32 I think your board has dual BIOS, right ?
Just switch to other one if update fails or you encounter a problem (and/or reflash original one).

Moded BIOS specs :
RST [Legacy/EFI : 13.1.0] + RSTe update [3.8.0] +
uCode update [latest available at this time] +
NVMe support [v4] +
LAN [6.6.04/1.5.62] +
ASMedia OpROM update [to v0.97]

Of course, I’m not resposible if you damage your CPU/RAM/etc. during update.
Like said earlier - I did NOT tested it, since I don’t own RIVE MB.
Good luck :slight_smile:

R4E.zip (4.7 MB)


Cool, trying it out now, will report back.

EDIT: seems to be working fine so far, can’t test the NVMe thing because I have no M.2 > PCIe adapter.

@User32 Glad to hear it booted :slight_smile:
Check ASMedia controller (does it work ?), and what uCode version is used (in HWInfo64 for example).
Any OC’ing issues ?

@Lost_N_BIOS What would be needed to do bifurcation enabled version of "Version A" BIOS ?

ASMedia controller works but it’s garbage so i’m using the Intel chipset SATA3 ports instead. Will check microcode later.

How did you choose the version of the raid controller rom?

@jjaomni I based it on this topic recommendation : LINK.
I used one with RAID0 TRIM support for (i)RST.

I’m looking for this myself, hope someone can make it work.

@Lost_N_BIOS What would be needed to do bifurcation enabled version of “Version A” BIOS ?

@agentx007 @madindian - Yes, Bifurcation mod can be done on this BIOS as well, please give me some time and I will make for you guys based on “Version A”
* Edit >> Asus RAMPAGE-IV-BLACK-EDITION-0801-Version-A-Birurcation
Mirror Asus RAMPAGE-IV-BLACK-EDITION-0801-Version-A-Birurcation

Thank you so much !

^Works as intended

Thanks for quick tes and report back, great to see now issues right out of the gate too

@Lost_N_BIOS you seem to be everywhere on this forum and the master of modded Bios :wink:

I’ve updated my RIVBE with your Version posted here. I can see the drive in the bios. When I’m in windows, I can see the drive as well. I’ve cloned my current SSD drive to the NVMe drive and have had no luck in being able to boot up from the NVMe drive after the cloning. I’ve tried this with 3 different brands; Sabrent, Samsung and WD Black. All of which the booting of windows has failed. I’ve tried the cloning with Acronis and Samsung Magician with no luck. Closest I’ve gotten was with the Samsung NVMe cloned, it will start to boot, but then blue screens with the whea_uncorrectable error.
So I’ve moved on to just trying to install fresh from USB to the 3 different drives and each one has crashed. I’ve tried using the Asus Hyper M.2 adapter with 4 slots, no good. I’ve tried a single RIITOP adapter, no good. I purchased a Super Micro 2 slot M.2 card and no luck with that setup either.

At first I was thinking maybe something wrong with my hardware. But the problem seems to be at the exact point everytime during the windows install. I can leave the computer running for hours on the initial Windows Setup Prompt, but once I get into the nitty gritty part where it starts copying the windows files, it’ll crash. Now if I stay persistent, I can just about get all the way through the setup after alot of restarts, and selecting some prompts through the process as fast a possible. But even then, once installed, it crashes with the whea_uncorrectable error message. Any suggestions would be appreciated.

I have managed to setup NVMe Win10 boot disk on 3 different Asus x79 boards (although not RIVBE) and even Dell T3610 either by cloning or fresh install. Have you changed your system to use UEFI boot mode? Legacy boot mode does not work.

Hey thanks for replying. I managed to figure it out. Turns out my issue was voltage related. I don’t know why though? I was able to reinstall using SSD on Sata ports no problem, but using a NVMe in the PCIe slots resulted in crashes. Under Lost_N_Bios suggestion, I went and upped my CPU’s voltage from stock to 1.24v, which resulted in a BOOT finally, no crashes yet. Now I’m onto another issue, which from my understanding with Bifurication enabled, I should be able to see both my NVMe drives but I can’t.

I’m using a SuperMicro AOC-SLG3-2M2 adapter with 2 Sabrent NVMe 1tb drives on it, of which I can only see 1. I’ve switched the drives around and noticed at first I could only see the one drive and changed the setting from x4x4x4x4 to x4x4x8 I believe, if I remember correctly, and I noticed both LED indicators flickered. 1 flickered a quick sec, while the other one which is the boot drive flickered and booted. I’ll keep at it and hopefully figure this out so I can have both drives available.

*So I’ve double checked. I can only get it to boot if I have it set to x4x4x8. None of the other variations seem to work? I figured maybe the x4x4x4x4 would, but no go.

Any advice is appreciated.

When I had 2 NVMe disks mounted to ports 1 & 2 of Asus Hyper x16, which should be similar setup as yours, the 8x PCIe slot bifurcated to 4x4x worked on P9X79D, RIVE and RIVG boards. However it seems that RIVBE does not have a 8x PCIe slot so you may be out of luck.

I believe this whole thing is related to the same issue as @JackSted has already reported: with 16x PCIe slots only ports a & c are available. It seems something is missing in the bios.

@Lost_N_BIOS & @biosphere

I have finally managed to get my setup to work!! I bumped the Voltage for the CPU to 1.28v.

I’ve moved my Video Card to the 3rd PCIe x16 slot.
Then Moved 1 NVMe Adapter to the 1st PCIe x16 slot.
Finally relocated the SuperMicro AOC-SLG3-2M2 adapter to the 2nd PCIe x8 Slot and then set the Bifurication to 4x4.

I can now see all 3 NVMe drives… and boot from the NVMe drive as well.

Lost_N_Bios, your mod is much appreciated man. Saved me from upgrading before I wanted to.

Now, as you can tell from the pic, I have to reorganize my case again lol, I ripped her apart so many times trying to get this setup to work, I actually somehow crossed a hose, broke an acrylic tube and just made a mess of the entire area in and around my PC lol.

Next build will be a Micro build :wink: , no particular reason other than to just do it as small as possible.

All_3_NVMeDrivesWorking.jpg