[OFFER] Various Gigabyte Z170-HD3-DDR3 BIOSes with Coffee Lake support

Hi, I am trying to mod z170 hd3p ddr4 for coffe lake (i3 B0) with coffelake, the process looks smooth, but after I have the modded file I keep getting ‘invalid file’ when trying to qflash it through built in Gigabyte qflash. Maybe someone can advise of the next steps or send me modded bios which will go through built in Gigabyte flashing software.

@majk3l Hi and welcome to Win-Raid forums.

The reason you can’t flash the modified file is because a single bit in the BIOS has been set telling Q-flash to check if the file has been modified.

You can change this bit using a hex editor.

There is a post here that describes how to disable the check.

Alternatively you can use the modified version of EFIflash in this thread to flash it from a bootable USB stick.

The BIOS updates are all showing the hosting website as being EOL and no longer available. would the Downloads be able to be hosted somewhere else and be reposted?

@FzRdd2f Hi and welcome to Win-Raid forums.

Thank you for pointing out the dead links, I have uploaded the files for the Gigabyte GA-Z170-HD3 DDR3 to a new host:



If these are not the files you need, you will need to tell me which one(s) you want.

Is there any chance to help me with this mobo ?
I have Z170-HD3-DDR and Intel i5 6500 non-k.
I managed to downgrade bios to F5a but it seems that previous owner upgraded IMEI.
Is there any chance to downgrade to make it great again ? I mean to allow me BLCK overclocking ?

@tomekmak You should be able to downgrade BIOS (including ME region) using Intel’s Flash Programming Tool (FPT):


I have written a guide on how to use FPT to downgrade the BIOS here.

Just remember that this motherboard has the Gigabyte DualBIOS feature which means that the backup BIOS chip likely has the more recent Kaby Lake BIOS (F20 or F21) with the updated ME firmware, so if your system fails to boot due to BIOS corruption for any reason - the backup may load without any warning and the system may not POST without clearing CMOS.

It is possible to flash the backup BIOS chip using EFIflash. I have posted a guide and download links for EFIFlash here.

Good luck!

1 Like

So i have to use FPT_v11.8.x.zip with orginal F5b bios file if i understood correctly ?

@tomekmak Yes, that is correct.

Unfortunatelly still not workning. Still can’t pass even 105BCLK :frowning:
In the evening i will try again from the scratch and post results.

@tomekmak You need to use BIOS F5b or F5c - you mentioned F5a earlier and it does not support base clock overclocking.

You can download F5b or F5c BIOS from this thread:

[OFFER] Skylake Non-k OC BIOS Archive

I have also included a guide in the second post for overclocking on Z170 Gigabyte boards.

What procedure do you advise ?
1st program both bioses using Efiflash then reflash with FPT or just FPT ?
(no intel ethernet on this particular board).

@tomekmak First use FPT to flash the main BIOS chip to ensure ME is downgraded and test base clock overclock is working.

Later you can use EFIflash to flash both the main and backup BIOS chips if you decide you want to have the same BIOS on both chips.

Test it only with bclk OC or in another way ?

@tomekmak Yes, you should be able to go over 105 MHz.

Wish me luck :wink:
Still @work :wink: 1h countdown :wink:

GL :smiley:

Mobo died. Bootlooping with 55 code :frowning:


Code 55 - The Memory could not be detected. Please re-install the memory. If the problem still exists, please install only one memory module or try using other memory modules.

Have you tried clearing CMOS?

What happened prior to the Code 55?

This is weird. I just swapped RAM sticks (carefully as usual) and then MB won’t boot. Just few moments after downgrade to F5b BIOS. Cleared CMOS, replaced battery and so on.

@tomekmak I recommend you test each RAM stick individually in every RAM slot to try to narrow down the issue.

It could be poor contact with the pins, a damaged RAM slot, one RAM stick may not be detecting correctly etc.