Optiplex 3010 bios

Hello i have an optiplex 3010 with motherboard MIH61R MB 10097-1 48. 3EQ01.011 REV A00 with bios chip MX25L6406EM21-12G

I tried to program the official A22 bios(downloaded from official site) through the windows method. It completed successfuly at 100% and after that computer stayed black.I tried to program every 8mb bios i found online with my CH341A but didnt worked. My service tag is 63DWG5J.

i have the bios i managed to read after the update to A22. Can you help me to fix my bios i will be grateful.

Please attach the backup of the bricked bios.

Thank a lot for the reply.
I am new user and i cant upload files. I uploaded it at my google drive:

OK, thank you.

Nothing wrong with the bios update for the bios region, code parts are identical to stock bios. So it might be something in NVRAM (unlikely) or a corrupt ME (but it got updated to the version in the Dell update- so unlikely, too) or something not firmware related (probably).

You tried a lot of found images already, those machines are old, chances are good that there are working image(s) floating around, so I don’t think it’s firmware related…

Thanks a lot. What tool is used to extract the dell bios from the exe file? I tried with command prompt but it doesn’t work.

Look here:

Take the file from post from hoaca388 in #35

That’s latest stock bios region with a cleaned ME and worked on another machine. It has another DVAR region, but that’s not relevant for starting.
If it works you might execute the third step from #4

  • Transfer the DVAR padding 0x240000 - 0x250000 into the stock bios region (HxD)

Make sure you flashed properly! Leave the soic adapter (?) in place, close the flashing program, open it again, read the actual content of the chip, save with abother name, compare it to the file used to flash. The two files should be a 100% identical!

If you used this firmware image already, it didn’t work and you are sure you flashed properly it’s not firmware.

Thank you so much for guiding me to the correct direction.
Ok i read all the tutorials and i undersrood the procedure. I followed all the steps but still the pc didnt boot up. Surely the fault is elsewhere but I cant understand why this happened immediately after the bios update. And how a bios update can cause problems at other things as the bios update completed 100%.

And yes i also tried the bios you mentioned which was confirmed working by other members but just to be sure i also did the whole procedure you mentioned. So the bios was programmed correctly from the beggining.

Sometimes this is just coincidence?

Sorry to hear that, you may try to check the hardware, reseat cpu, memory, try a minimal set of ram and only graphics card if necessary, maybe another psu…

Good luck!