Please help me with me region empty

Hi everyone, i read a lot of forums, threads, topics, guide and so on but I’m getting crazy with my bios. Just a quick recap:

  1. bios update failed on my ASUS P8P67 PRO rev 1.x motherboard
  2. ME Region N/A - 16Gb RAM detected but only 8GB used and so on…
  3. bought a CH341 programmer - flashed the original bios, a modified bios, nothing helped

Can someone help me to solve my problem?
Thanks in advance

Read a lot but cant search correctly…

Follow the guide and it will be fixed

If by ‘original bios’ the stock bios was meant and if it was flashed properly, then it’s not firmware related- supposed that asus has a correctly configured ME in it’s bioses.

Thank you @MeatWar, I’ll give a try.

@lfb6 yes, stock bios from asus site. Flashed via afudos and with the ch341 programmer too. Not solved.

I tried with FPT too but Error 26 occurs.

@MeatWar tried the guide ma nothing changed. ME version empty in BIOS screen info and half of ram used. I’m getting crazy!!!

As lfb6 stated… and his comment is also valid in your issue.
If you have used an SPI programmer and programed correctly the Asus bios file (Extracted from CAP), it contains a full image with ME8 on it, after this if still ME N/A on bios and guide linked doesn’t work, it could be an SPI chip/Mainboard hw issue, rather than an initial corrupted bios/Me.

Corrupted ME states will not be fixed with standard flash tools from Asus or AMI.
The ME FW must be initialized as the guide linked, only then it can be updated to latest 8.1
So start from the beginning and program an extracted Intel image from Asus CAP.

Intel FPT errors is due to access the bios regions on the SPI, theres plenty of info on the forum.

EDIT: The file to use in the programmer its the Intel image extracted from the CAP with UEFI tool (less 4kb), not the CAP itself.

IGNORE this… the Asus files are ROM, in this motherboard model, just rename to .bin if necessary.

Thanks @MeatWar , so focusing on the programming via SPI, a proper flash should solve the problem, right?

Below the steps performed:

  1. downloaded latest stock bios from asus site
  2. via CH341A programmer, erased the bios chip
  3. flashed and verified the bios downloaded at point 1

Is it the correct procedure? Suggestions?

Thanks in advance

Yes it should… done it a few…lol

Again…it could be an HW issue or a failing SPI chip.

EDIT: Yes in that case its a motherboard issue, like the CMOS/PCH circuit

tried two different chips. If the procedure is correct it will be a HW issue