[Problem] Locked myself out

I mistakenly set secure boot ON and legacy mode off on my DELL Wyse 5070 thin client, as of that all i get is no display/signal, i made a dump of my bios (can be found here) and i configure it using FIT and then copied smip block from old dump to the new ‘configured bios’ but when i write it to bios chip i still get no display, modded bios could be found here

What could be wrong or what am i missing? how i can verify the integrity of bios bin file?

please help me as i have no experience with.this.

The changes you made get stored in bios region, nvram. This might be a little tricky since NVRAM is redundant and it’s not always clear which tree was used for the last changes. In addition it’s unclear if one has to extract the bios region with fit, change the value(s) and build a new image with fit and if these 2 regions are possibly protected by the OEM hash, too. (Can’t imageine that this is the case, but…)

You can see nvram regions / bios region structure with UEFIToolNE when opening bios regoin.bin in the folder for the decomposed parts of the firmware created by FIT.
In the first nvram regions the last entry is indeed about secure boot. Second last changes was in setup but seems to have been done several times before?

What changes did you make in FIT? The only difference between both images I can see is an empty DevExp1 region?

You might try the attached file, reversed just the last change but that might not be enough…

20220913_172158_SVOD3_original_1.zip (6.4 MB)

Thank you for helping me, i flashed your bin file but unfortunately still no display… if secure boot can’t be turned off isn’t there any option to turn on legacy mode, sorry am totally new to all of this.

OK, thanks for the feedback!

Extract your original bios according to this guide which you obviously already used:

After step 8 (having closed FIT) exchange - in addition to the guide - the file BIOS Region.bin in the Decomp folder with the attached file.

BIOS Region_109_DVAR.zip (5.0 MB)

Contiinue the guide to the end, follow it to the letter. The resulting file is a stock bios 1.09 (same version as your original bios) with your machine specific data copied.

Please post the resulting file!

Here is the resulting file:


Looks good to me!

If this won’t solve your problem, the reason isn’t the firmware :+1: (if you followed the ME cleaning guide correctly, that part I didn’t check)