[Problem] Meegopad T02 corrupted UEFI

Hi Guys,
I tried to mod my meegopad T02 bios (APTIO V), but seems that the ME region was erased so I have no video right now.
I can access the device via remote desktop and use it for like 20 min before it auto shuts down.

I’ve tried to reflash the original bios using the fptw tool but it says that the descriptor area is invalid.
Using afuwin says that the rom is bigger than flash size, the bios image is 8MB but the chip is detected as 4MB (it’s a Gigadevices GD25LQ64C).

I have a TL866A programmer, added some resistances to a SOIC8 clip (to go from 3.3 -> 1.8V), but seems like I’m missing something (I can’t even dump the chip id). So I bought the EZP XPRO flasher today (just to be sure) but it will arrive in 30 days.

Is there a way to reflash the complete chip from windows? Or am I screwed and should wait for the programmer?

Thank you guys.

@ clio:
Welcome at Win-RAID Forum!

I hope, that you will get help from someone, who knows more than me about how to solve this problem.

Regards
Dieter (alias Fernando)

You definitely need a bi-directional voltage level shifter instead of resistances to use the hardware programmer properly.
You can try to get to chip reflash using HDA_SDO pinmod method.

@Fernando
Thanks, I’ve been a lurker of this forum for a long time, a great place to learn.

@CodeRush
Yes, I knew, I didn’t want the hassle to build one, I was just trying some tips I found on the web (I was almost sure that wouldn’t work, but was a easy and cheap hack) and it works with some chips, sadly didn’t work with this.
I’ll look the HDA_SDO method and keep this post updated.

Thank you!

UPDATE: Looking at the Audio chip is an ALC5640 so the pinout is different, even the interface is different (I2S).

Then you have to use a programmer, IMO. Desolder the chip, connect it to the programmer via level shifter, dump the current contents and upload here, we will see what’s wrong with ME there.

I think I’ll wait for the EZP XPro, I don’t want to build a level shifter.
I just wanted to reflash the original bios :’(

Thanks for the help.

Hi,
I’ve fixed the meegopad T02 (reflashing the bios using hw), and now I have a question:
Flashing a modded bios, using hardware or software, gives the following error after rebooting: EFI_NOT_FOUND (bad signature I guess?)

So I was searching info about that, and found this on the microsoft website:



My question is (maybe isn’t a question): are intel signed bios not “moddeable”?, even after correcting the checksums the system gives the error “EFI_NOT_FOUND” or just not booting at all. ALL the modules must be correctly signed?

Thanks.

Hy. My meegopad t02 brick. How to logic level converter to Test clip adapter 3.3V - 1.8 v plase image . Thank you.