[Problem] Modded BIOS for HP Elitedesk 800 G1 DM mini PC


Tried adding NvmExpressDxe_4.ffs to my bios.rom using MMTool and bricked my machine. Not sure what went wrong.


You can certainly try if you have the same hw. From Windows it’s easier. For DOS you have to use the DOS flasher. #2 is required though to be able to flash.

Hi Cube - I guess after Thursday flash your mini was fine, unfortunately I missed your message. All gen 4 i3-i7 CPUs are good to go with that bios file as long as they are not ES (eng sample) flavor.

I flashed my friend’s 800 dm a few days ago, and got the same. After the flash & reboot, the NVME didn’t show up in BIOS as well, however I was able to install and boot Win 10 from NVME drive. After that I applied the BIOS defaults and the SSD showed up fine after the next reboot.

The best test is installing Windows 10 over UEFI. If Windows 10 setup continues after the first reboot, you’re good to go, even if BIOS fails to display it. My Sony VAIO Pro that I modded in 2017 is like that and I couldn’t care less. It boots, and it’s all that matters. However, a little too late for you now.

I’m not sure how did you manage to brick the unit, however don’t despair. Been there, done that, too. Just order a CH341 kit from Amazon or whatever and follow BigMax story. I may be able to help you with that too.

Hi @Xnet

I’ve taken a look at what BigMax done, they used a ch341A.

Do I need ch341A or ch341?

Looking at Amazon there are ones with additional connections and cables, do I need all the extras ?

Are there any guides that will help me flash back my working Bois dump?


Right - CH341A with SOIC-8 cable, so you can connect to the bios chip without unsoldering it. The process is not complicated - connecting the cable clip properly is the toughest thing.

Orders placed.

Welcome. Now would be good to make some prep for it. You going to need another PC/laptop with Win 7 (ideally), and there’s a mod to be done to CH341A. It made sense to me, so I did it, however other users, not handy with soldering, went ahead and used it un-modded and some claimed it went ok.
Check this link: https://www.youtube.com/watch?v=-ln3VIZKKaE
If you have what it takes - do it. I’d recommend to do the other 3 connections first and leave the IC pin 28 at the end as it breaks really easy. If you don’t, then you can try as it is.
Check this one to familiarize yourself with it: https://www.youtube.com/watch?v=OttN8wQ1HhE

It’s alive!

Thanks to @xnet my mini has been resurrected and is now booting form the NVMe.

I should have stopped at My first attempt using UEFITool, although my drive wasn’t showing in the BIOS, Windows 10 is still able to install and boot.

The damaged happened when I used MMTool to add the mod.

Thanks again to @xnet for your assistance and pointing me in the direction of the external USB programmer (CH341A).


Hello everyone, I’ve been mulling over these instructions for the past day and want to do this right as to not brick my computer. I have an EliteDesk 800 g1 DM and am interested in getting NVMe boot support.
I’ve tried to install the HP HQ flash utility on my main computer but it doesn’t have dependencies.
Next I’ve made a bootable drive with rufas and got DOS Flash to run and started DosFlash.

My question is how do I install the rom file provided by xnet? It looks like Dos Flash targets a .bin file not the .rom.
Do I need to do anything to get this to the rom file to get it to run?

Thanks in advance, I’m totally open to sending donations for the help too.

Hey llamafur - you certainly haven’t mulled long enough - lol. I mentioned you can rename the extension as you like. You should use HP flash utility only to upgrade the whole 16MB BIOS with the factory file. Not with my file. Intel ME flasher is recommended here. As I noticed lately, there’re at least 2 hw revs for the mini, so make sure your ME version is 9.1.xx If you have 9.0.xx don’t flash that file. Read it again.

Xnet, you are correct. Modifying the bios feels a little too daunting for me mainly due to the risk of bricking the system. The HP refuses to boot from sata but works fine booting from usb. I went the route of clover on a tiny usb memory nub and have that pointed at ubuntu on the nvme.

I got the computer for $20 from work. And use it for sftp and for our rtmp movie night. In the future when they upgrade again I might snag a few more and try flashing the bios using the Intel flasher.

The risk is near zero if you don’t wander away from the path … and all you risk is $20. Your choice.


Thank you for your effort and help!

Are you able to provide and attach your "modbios.rom" with injected NVME__.ffs or it is unique to the specific BIOS/Motherboard?


It’s not unique, however there’re always multiple hw revisions within the lifetime of a product, so they’ll be specific to a version. It’s best to upload your 10M bios file and I’ll repost it with the driver.


I think that’s the best idea :wink: 'coz I have no clue where to insert .FFS :frowning:
Although it looked like a very simple tool…

Tnx in advance!

BiosDump.zip (3.95 MB)


Don’t worry about it, I managed, sorted out!
Mini is showing NVME as a boot device, so should be fine!

Tnx again for a very detailed guide and step by step instructions!


Good job Dee. Glad you managed on your own - gives greater satisfaction. Enjoy your Win 10 mini!

Hi, @BigMax

I have a G1 800 SFF and when I flashed with moded bios I have experienced your situation. I have fixed the issue of don’t booting of my system by flashing the BIOS with an external programmer by a repair store with original bios file of HP site. I have fixed the issue of Ethernet card and I can help you to solve it. I also need your BIOS moded file to flash my pc to be able to boot from my NVME PCI adaptor. Tnx

@Xnet , could you please help me to find out why moded bios was corrupted? or how can I check the moded bios that be fine and equal to original bios from HP?

@kamran2000 : If you want, that anyone will be notified about your request, you should set an "@" in front of his/her nickname.