[Problems with] ASUS ROG Strix Z490-E Gaming BIOS

Yes, that would be the correct version.

But as written:

Asus has a placeholder PHY partition, which only can be configured in FIT if you choose CML with Rocketlake, but these configs do have slightly different options.

@plutomaniac How would one clean a ME with Asus placeholder?

Is it possible to find a working BIOS?

Me for the moment I can’t already have a bios without error.

why am i still getting errors?

I try as best I can to understand but I surely don’t understand all of them otherwise I will arrive at the same result as you.

Difficult when you’re not from the profession

I’m trying to revive this motherboard but I even realize that it’s not that obvious even with tutorials.

thank you very much for your explanation

If in doubt attach the resulting file, I might then find where the error might be?

yes I would like to thank you, not for lack of will but for incomprehension of the system. And as I like to know how to do with myself even that frustrates me and embarrasses me.
it’s always more complicated to understand a new thing by trying to look for information right and left than to see a person who explains and where you can see the do’s and don’ts visually.
I attach the results which are not good
bins outpout.rar (7.8 MB)

You’re still using old ME Analyzer:

Latest is:

I don’t see any error for your file, it has a different order of the ME partitions, that might be related to an older FIT version you used. MEA says ‘configured’, it unpacks without errors, I think it’s fine according to the guide :+1:

There’s of course still the difference with the placeholder SAMF and PHY which Asus inserts. Afaik they’re not functional in this setup, so your file might work as well. In addition i tried to manually rebuild the original structure, I assume this might be useful regarding possible Asus ME updates in the future.

Maybe there’s really an error in the ME that keeps your PC from booting. Looks like a firmwareupdate went wrong, there’s a 4k block in a module that’s missing and after that block there’s unexpected code (might be from an older ME version?)

The 16 MB file is identical to the one you sent, so no need to flash this chip.
I’d appreciate if you could flash the 8 MB chip with your file and the one I created- I’d like to know if a ‘simple’ rebuild according to the guide without paying attention to Asus’ dummy placeholders might work in case of brick and I’d like to know if my reconstructed file with Asus placeholder PHY would work, too.

(And there’s still the possibility that this is not firmware related)

Thank you for everything you do but why am I still getting errors with the latest version of MEA?

it’s because it needs all 2 files, right? 24mb

MEA reads the flash descriptor for detecting start and size of ME region if there is one. Since it seems you just gave it the 8 MB part to read it complains that the complete image is supposed to have size 0x1800000 and not just 0x800000

Try the complete firmware image and the errors will disappear.

Or cut the first 0x1000 of the 8MB file and MEA will just complain that there’s unneccessary padding

Or cut the first 0x1000 of the 8MB file and then all the FFs after 0x321000 (the size mentioned in the main block of the MEA output) and MEA again will give you no warnings since this will be a correct sized me region,

ok thank you I will install my version and then your modified version to see what it gives and I will keep you informed.

I just tried to put your 8mb file in the chip, this time it starts, but I have a cpu light on and nothing happens. I tried with my 8b file too and it’s the same.
what could that be from?

My cpu is I9 10850k

I have not changed the data of the 16mb chip for the moment just that of 8mb

I had the same remark that there was some difference between the bios 0607 data on the asus site and those currently on the 16mb chip.
is this normal?

Those differences in bios region should be normal. I wondered why NVRAM was emptied- good to know that the flashback solution seems to do that.

Difference to stock bios region is board specific data like serial/UUID, 2 short sequences in padding and one in smdata

I think this error is before bios routines would start. Lets try the original flash descriptor, cpu straps are stored there, maybe Asus has corresponding to its placeholder PHY a RKL flash descriptor, too. (FD is rebuilt when building firmware with FIT)

Did you clear CMOS by removing that small battery for some minutes?

yes I did a clear cmos by removing the battery. As soon as I turn on the computer, I have this cpu light.
I’ll try again with this new file and let you know.

I just tried with the new file and I still have this cpu led.

The graphics card fans shut off after 10 seconds after booting.

The brick didn’t happen when updating the bios but ME (if it was just one brick). As written there’s a missing block at A9000, I compared the stuff after this missing block and it belongs to older CSME- versions- CSME to do have this code. So this brick happened when updating the ME firmware to the older of the two updates offered by Asus.

If there was an update for the bios region, too, is unclear, the bios region got properly restored (at least in the files I have) and the NVRam was cleaned / emptied.

Question would be why the ME fwupdate process stopped. This process is normally very reliable, the fw gets uploaded into the ME fw itself, the program for flashing the new firmware is part of the ME itself. So if the ME firmware flashing stopped there should’ve been an error message of the program and since the new ME only get’s loaded when booting the PC should’ve worked at least to next reboot. Or the PC crashed while doing this- then the question is: Why?

In addition there are Firmware updates (bios/ME) via Windows update. This would fit with you mentioning reboots since they’re done in an EFI service environment which requires two restarts. If you could get access to your storage device keeping the os you could check the Windows directory for a ‘Firmware’ folder and write down the GUIDs of the subfolders.

Anyway, I don’t think there’s anything firmware / bios related again, I’ll attach another file for the 8 MB chip where I replaced the old ME code parts with the updated code and left data partition as it was. But that’s more like a desperate try…

  • Please try the file from attached 8MB_reco.zip for the 8 MB chip

  • If it doesn’t work flash back the 8 MB chip with the file from 8MB_FD.zip

  • Dump the 16 MB file once again and compare it to the 16MB file we’re working with.

  • Does the Q-Code 2 digit display ever show anything else than “00”?

  • Reseat the CPU, check the socket.

  • Try another CPU?

if it can help, after updating the bios, it shows me the update was successful.
it restarted twice then the 3rd time it displayed a message like no boot aura and it was extinguished.
my cpu is functional and well installed. there it is installed on a z590 card from msi and works.