Qualcomm Atheros AR5B125 Wireless Network Adapter driver for W2K

I was wondering if anyone has gotten drivers for the Qualcomm Atheros AR5B125 to work with Windows 2000. It came with such computers as the Acer Aspire E1-531. These only support Windows XP and later and don’t include a 5.0 (2000) section, BUT, it does give a passing mention to 2000, like here: “Installs athwx.sys (NDIS 5/5.1 driver) on NT platforms (2000, XP and greater)”. In addition, passing mentions to Windows 9x (95, 98, etc) are mentioned as well, like these: “Installs athwx.sys (NDIS 5 driver) on 9x platforms” and “;ExcludeFromSelect = \ ;for win95 and legacy support” (with the latter quote mentioning generic legacy support).

This means the device should be workable with Windows 2000, but I am not really sure how to do so. Here’s what I’ve attempted so far (using a 2007 Acer TravelMate 2480 to temporarily host the network adapter while I await my E1-531 delivery):

  1. Added in NT.5.0 and my device ID (obtained from XP) %ATHER.DeviceDesc.661711AD% = ATHER_DEV_661711AD.ndi, PCI\VEN_168C&DEV_0032&SUBSYS_661711AD and blanked the 5.1 section so it is commented out (E.G. [Atheros.NT.5.1] ; Empty section, so this INF does not support NT 5.1 and later). I also edited both .sys files within CFF Explorer to swap 5.1 mentions to 5.0 mentions. This did not work.

  2. Put back in the original AR5BXB63 adapter, install its drivers under XP, copy its driver ID to the Generic section of this driver, but changed it to read as: %ATHER.DeviceDesc.001C% = ATHER_DEV_001C.ndi, PCI\VEN_168C&DEV_0032&SUBSYS_661711AD (This caused an Code 10) and then %ATHER.DeviceDesc.001C% = ATHER_DEV_661711AD.ndi, PCI\VEN_168C&DEV_0032&SUBSYS_661711AD (The name is already in use as either a service name or service display name).

Number 2 was done to trick the driver into thinking the original AR5BXB63 adapter was inserted, which failed. If anyone has any solutions to getting the AR5B125, please do share. Thanks in advanced for your guys’ help!