Query for MOD add bios CSM mode (LEGACY support)

It’s similar to OndrejCZE’s board, Asrock J4105B,
https://www.asrock.com/mb/Intel/J4105B-ITX/index.us.asp
No legacy boot seems to be a common issue to gemini lake boards,
and it’s intel’s decision to ditch legacy,

Here is first test (only enabled main menu entry) @cemara - if contents inside missing let me know (didn’t want to double enable if already enabled when root submenu is enabled)
Should be new submenu located at Boot >> Boot >> CMS at bottom of page, directly under Boot Beep, then Full Screen logo or Addon Rom Display (If not, show me image of this page)
If settings are visible you should see these 4 options inside submenu, if not let me know and show image

CSM.png


http://s000.tinyupload.com/index.php?fil…186358573443295

Its late here so can take pic like 12 hours from now…
But i’m sure theres no CSM or anything to flip uefi to legacy on boot submenu… its similar to the ones posted by OP in previous page…
Is it intentionally hidden by asrock ?

@cemara - You are talking about after you flashed the BIOS above I sent correct? You don’t see submenu named >> CSM(Compatibility Support Module) at bottom of boot page, under Full Screen Logo Option?

Yes, they intentionally hide, but we can unhide, sometimes take a few tries using different methods. And, even if we can never unhide, I can either change the default settings for you, or show you how to do it without BIOS flash, but I bet we can unhide

Ah so that link is bios file, i thought its screenshot file,
I will flash it tomorrow, thanks. The current bios is the same as the ones posted by OP on previous page.

Ohh, sorry for any confusion! Yes, that is a modified BIOS I linked above, then showed image of the settings you should see or not inside " CSM(Compatibility Support Module)" submenu
I’m not sure if same BIOS as previous ones, I downloaded the latest 1.30 it was I think

Hmm strange i cant seem to download it, can you use other file sharing? google drive maybe?
Edit : had to use vpn…
I just flashed it using instruction on asrock website, but now i cant even turn on the board… is it dead?

Very sorry to hear this @cemara !! What is the MD5 checksum value for the file you used to flash with? Concerned maybe VPN and issues downloading corrupted a byte or something possibly? I get this for file I sent >> MD5 9d3303cf4a9d0b6d04f126e41c40249d
It could be a faulty mod, but I doubt that since I didn’t edit much at all (only moved 4 bytes) and removed Asrock’s Protection via UBU. Or could have just been a bad flash?

If you can’t get it running, you’ll have to order a CH341A flash programmer, or other similar. And a SOIC8 test clip cable, or SPI Cables, BIOS is right above the CMOS battery
These are only about $2.50 each on ebay but 3-5 weeks for delivery, same $ for the SOIC8 test clip cable, let me know if you need links.
Or a kit like EZP2010 or EZP2013 would work as well, or any other hardware flash programming kit that has cables and flashes 25xx type BIOS. You can get all these on ebay, or places like Newegg Amazon too for higher price/faster shipping.

*Edit - @cemara I noticed this on 1.30 BIOS - the update ME/TXE notice - if you were not already on that 1.30 BIOS, you may need to do this now, see if that let’s it startup, if so then you will need to follow the rest and update the ME/TXE using the stock BIOS files.
https://www.asrock.com/support/BIOSIG.asp?cat=Windows10

Then you may need to reflash the MOD BIOS again using built in BIOS flashing app



Ok Already ordered a CH341A, a local seller in my country has it,

I uploaded the GLKBITX1M.30 from your link to http://onlinemd5.com/ and i get 4F293EA86B07D5C072610055375CA495

https://www.asrock.com/support/BIOSIG.asp?cat=Windows10
Thats exactly how i did it,
My bios was still 1.00 though before flashing
but the flash was successful
It says “FPT operation succesful” so i wasnt worried at first…

@cemara - Great you could find a programmer locally. Did you get cables? you need either SOIC8 Test clip with cables, or SPI Cables for your BIOS since it’s not socketed.

That is not same MD5 checksum as file I uploaded, so something must have happened to it during the VPN download possibly?
I re-downloaded from the link I gave you again just now to confirm the MD5 from file I had in storage that I gave you previously, it’s a match

GLKB-ITX-P1.30-CMSTest1-BIOS-MD5.png



MD5 = 9d3303cf4a9d0b6d04f126e41c40249d

Even though MD5 does not match, you did remove the jumper after flashing now correct? I assume this wont help, since MD5 does not match who knows how bad the file is you flashed in? Very sorry this happened, but looks like it’s due to how you had to download.
Upload that file you have and I will check it, maybe I can find what the issue is, but you wont be able to fix it without a programmer, unless you can boot to DOS?

If you have not tried yet, put jumper back on and see if you can boot to DOS or BIOS like that, this will disable the ME region if ME region is what got messed up during the flash you may be able to reflash again.
If you do get lucky and that gets it started again, redownload the file and make sure you get that MD5 above before you flash it. And if needed, please give me a free file host other than google you want the file uploaded to and I can re-upload for you.



I tested the checksum again with the same program in your pic, neo hexsum


And i think i got the same value, so i guess it was the online md5 that was incorrect.
Just tried plugging the jumper again but still wont turn on… i guess i have to use the programmer,
it should arrive in 2-3 days

Yes, interesting! So now I go to the site you linked, and get same MD5 from there too, definitely something to do with uploading a file to their site?

Very sorry this happened, it could either be a bad flash generally, or something wrong with the method I modified the BIOS (It can be done a few ways).
Once you have your programmer, do not write anything until you have reached goal #1 >> first and only goal until you get a valid verified backup is that, do not try to recover the board until you have a verified backup (read, verify then save) and then open that BIOS in hex editor and make sure it’s not all zero’s or FF’s
Once you have a good backup, then you can try to recover (erase, blank check, then open file and write/verify) The BIOS downloads are .bin/rom file, so you can use that, but you’ll later have to correct BIOS using your backup from above, to put back LAN MAC ID, serial, UUID etc.




https://www.tokopedia.com/rajacell/ch341…software-driver

I bought that one, but i can’t find a detailed guide on how to use it for SOC motherboard like J4105, would this guide work ?

[Guide] Using CH341A-based programmer to flash SPI EEPROM

What is “SOC motherboard”? Yes, that guide you linked applies, and here is one with lots of images to show you how to correctly use everything
https://www.bios-mods.com/forum/Thread-G…341A-programmer

That is correct programmer, but you also need SOIC8 test clip cable, or SPI Cables




Ah ok i guess i’ll be getting the cables first,
SOC = system on chip, the processor is soldered into motherboard,
https://www.asrock.com/mb/Intel/J4105B-ITX/index.us.asp
Judging on the pics, i guess i need to remove the heatsink first then?

@cemara - Yes, cables are needed unless you have a drop-in/spring loaded SOIC8 adapter or PCB based DIP8 adapter to desolder the chip from the board and then put into the programmer. Which I assume not, that’s why I mentioned you will need cable too when said to pickup a CH341A
Thanks, I gotcha now, SOC does not matter, processor is not used for this process, so additionally no heatsink removal is required either. BIOS chip is right above the CMOS battery, that is all you will be connecting to in order to reprogram the BIOS.

I’ve setup everything but i got 1 issue, during PART2 of that post, the “Detect” button remains greyed out, am i supposed to pick other than W25Q64BV?

Edit : its finally detected with W25Q128FW :slight_smile:

Do you have jumper in correct position on the programmer itself, should be on 1-2 (End of block, nearest middle of programmer, on lever side)
Are you sure you have all cables connected correctly? To programmer side and to the BIOS chip itself? If yes, then you may need to leave power supply connected if you have it disconnected now, or you may need to disconnect it.

If you still cannot get it, show me images of your BIOS chip on the board with nothing connected to it (So can see it’s orientation), and then show me image of cable connected to the BIOS chip, and then cable connected to the programmer.

It could also be software bug, maybe detect button doesn’t work on some versions, not sure? What version software are you using? If not already, try 1.30, I know that one works correctly for W25Q64BV/FV when clicking detect it will show both and choose W25Q64FV if BV is not working
Does it show “Device Connected” in bottom right corner? If not, use a different USB Slot.

You can’t use 128 if chip size if 64, please try W25Q64FV instead, or just W25Q64 without any letters

I looked directly into the chip in the motherboard and it has "128" in it, so i chose W25Q128FW, and its finally detected…
then i tried read, verify, but during verify i got " chip main memory with the contents are in disagreements"
what should i do then?

OK, well then that makes more sense! Yes, then you would use W25Q128xxx The error you mentioned is normal, that means it failed try again.

What is the actual chip ID? Try choosing that, if not, try another similar. “Detect” button should work at first, without selecting any ID.
What software version are you using? You just have to keep trying until you find the right software that works with that chip, and then right ID that works too.