Questions about failed RAID array after lightning

While I was using my computer a few days ago, a lightning strike caused a power outage for a few seconds. When I tried to power my computer back on the on board controller reported that one of the drives in my 5-drive RAID5 array was not detected. As such the array failed which concerned by as I figured it should just be degraded. I could hear a slight buzz and tick that kept repeating and was able to identify the suspect drive. Didn’t sound like a head crash, but like the arm was stuck. Windows 10 tried to load, but then reported back about a non-bootable drive. I shut the machine down and ordered a replacement drive. Of note, MB is an ASUS P6T Deluxe V2, with an Intel Core i7-920 and 12 gigs of RAM. RAID5 was set up on the ICH10R with 5 WD caviar blue 500GB drives. The RAID array is partitioned into 3 parts: OS (Win10) 100GB, Programs 500GB, and Storage 1263GB.

The new drive came today, but on a whim, I tapped the effected drive with a screw driver when trying to start up the machine and it started working again. BIOS showed all 5 drives, but a failed array. Windows tried to start, but reported an error and suggested a reboot. After the reboot, all 5 drives again showed up and now the RAID controller showed a status of REBUILD. Windows managed to load without major issues and my HD activity has been pegged at mostly 99 or 100% for close to 7 hours. Logically, the machine appears to be trying to recover the RAID array, but I don’t know what program or service it is using to do so. Is this being done at the driver level?
Also of note, Windows is now telling me it needs to be Activated?? Again??

Going through the device manager shows: Device Manager–>Storage controllers–>Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller
Driver Version by Intel
Storage spaces is empty on my machine…never been used.
Disk Management only shows Disk 0 with the 3 usable partitions, All 3 ‘logical’ drives are listed as Simple, Basic, and Healthy
RST does not appear to be installed on my machine. I don’t recall ever installing it for one and its not in the location it should be if it was.

So, the question is…what’s performing the ‘recovery’ procedure? Is there any way I can monitor this? I’d like to install RST, but it appears to require a reboot and doing so would start the rebuild process over from scratch wouldn’t it? Also, I’d rather not mess with the underlying driver. Its working and I don’t want to bork the machine. In other words, I’d like to install just the GUI. After the RAID rebuilds I want to check on the status of all 5 drives. If I need to replace one, then I will. I do have a spare now after all. Thanks.

@TKESlinky :
Welcome at Win-RAID Forum!

You can check it by using the “Add/remove Programs” option of the Control Panel. If there is no Software named “Intel Rapid Storage Technology” listed, it is not installed.

Usually the monitoring and the reparation of a faulty or degraded RAID array is done by the Intel RST Console, but this Software has obviously not been installed onto your computer. So I am rather unsure myself, which utility is able to repair your current RAID issue. Maybe it is the Intel RAID Utility, which is within your mainboard BIOS.

Yes, the installation of a complete Intel RST/RST(e) Drivers & Software Set will require a reboot. Furthermore the currently running Win10 in-box Intel RST(e) RAID driver v13.2.0.1022 will be replaced by the one, which is within the related Intel RST Set.

It is not possible to install just the Intel RST Console Software.
This is what I recommend to do:
1. Don’t shut down your computer and don’t reboot unless the recovery of your RAID array has been completed.
2. As long as you have access to your RAID data, do a backup of the most important ones and store it outside the RAID array.
3. If not already done, install additionally the Windows feature “.NET Framework 3.5” from within the Control Panel (this feature is required for the Intel RST Console and Services).
4. If the RAID array cannot be repaired by your currently available resources, I recommend to run the installer of an appropriate Intel RST(e) Drivers & Software Set v11.7.4.1001 WHQL or v13.2.8.1002 WHQL. The download links can be found >here<.
5. The best way to get a proper working slim system and to prevent future problems like your current one is to do a clean installation of Win10 v1703, to additionally install .NET Framework 3.5 and your favorite Intel RST Drivers & Software Set.

Good luck!
Dieter (alias Fernando)

OK, I picked up a 3TB Mybook and backed up the data I was sure I didn’t want to loose. Even doing a backup of WoW (Its nice that you can copy it from one drive to another and it will just work) so I wouldn’t have to wait for a few days while it downloaded and reinstalled. The question is which RST would be the best to use. Does it matter which version of the RAID ROM is installed in the BIOS? You mentioned two versions of RST in your post. Is one going to be better than the other? I’m not sure that the rebuild is completely finished, however, disk usage is down. Generally spiking in the 30’s and more often just in the teens.

Also, I’m not sure if I can do a fresh install of Win10. My machine originally started with Win7 and I took advantage of the free Win10 upgrade before it expired. Is there a process I’m not aware of?

On a side note. Not sure there’s any relevance, but I checked the driver folder to see what was already there. I located iaStorAV.sys described as “Intel(R) Rapid Storage Technology driver (inbox) - x64” and iaStorV.sys described as “Intel Matrix Storage Manager driver - x64”.

I gave you already an answer, but the choice depends on the Intel RAID ROM version as well. At least you will have to find it out yourself.

Yes. The RAID user can expect the best results, if the platform (MSM resp. RST) and the version of the Intel RAID Option ROM and the in-use Intel RAID driver are matching (same platform and rather similar development branch).

I don’t know, which one of them is better for your special system, your sort of PC working and your preferences (performance/stability).
If you tell me the current version of the Intel RAID ROM and let me know, whether you are willing to replace it by another platform/version, I will give you an advice.

The OS will be automaticly activated, if you had successfully upgraded from Win/8 to Win10 on the same machine before. A replacement of the system drive doesn’t matter.

Both are Win10 in-box Intel RAID drivers. The Intel RST RAID driver named iaStorAV.sys will automaticly be used for all Intel systems, whose Intel SATA RAID Controller has the externally visible DeviceID DEV_2822 (= all Chipsets/Southbridges from ICH8R up), whereas the Intel MSM RAID driver named iaStorV.sys will be taken for Intel RAID systems, which are even older (up to ICH7R) and have a DeviceID DEV_2652, DEV_2682, DEV_27C3 or DEV_27C6.

Forgot I had taken a picture of the failed array after hitting crtl-I before the rebuild. The machine has Matrix Storage Manager option ROM v8.0.0.1038 on it now. Definitely prefer stability. Would prefer to NOT dump the raid and have to redo it from scratch. I can reflash the BIOS if required, but would prefer not to. If I can reflash and not run into issues with current RAID, then I suppose its not that big of an issue.

In this case I recommend to update the Intel RAID ROM to v11.2.0.1527. This should be no problem with your mainboard (look >here<).
The best matching Intel RST driver would be v11.2.0.1006 WHQL, but it is not easy to get this absolutely best, but old Intel RAID driver properly working with Windows 10. A “downgrade” from the in-box Intel RAID driver v13.2.01022 will give you an unbootable system.
Solution: Look >here<.

I apologize for it being so long since I got back. I was not looking to reflash the BIOS and have instead implemented a less than elegant solution. This computer will most likely be replaced in the coming year. I only needed to keep it working in the interim. I downloaded and installed the latest Intel RST program v14.8.0.1042, but before rebooting, I rolled back the driver to the boxed v13.2.01022 in an effort to make sure the computer would continue to boot. It worked. I am now running RST v14.8.0.1042 with driver v13.2.01022 and option ROM v8.0.0.1038. I know this isn’t ideal, but it is accomplishing what I set out to do. Interesting enough, the drive that originally was giving issues has not acted up once. It has been performing as it should and as such the RAID array is functioning as if nothing ever happened. Also, on the first reboot several days ago, windows did perform a few ‘disk repairs’ after which the machine rebooted. It came back online with Win10 in activated status once again. I will report back if I run into any glaring issues with how it is currently set up. Realistically, if it can last another 12 months, I’ll be happy.