[Release] Resizable BAR BIOS EFI Module

What about the BIOS setting @Koekieezz did suggest? setup_var_cv and the other var. store, which I don’t know cos the screenshot was cut.

Give me a hand please.

In bios, I can’t locate more than 3.5gb

Tolud is configured good. The memory remap function does everything else later on.

What’s really matter, Above 4G is still disabled. Changing the 0x387 variable is worth giving it a try, but not in PCI_COMMON storage. I’m limited in my abilities to tell what to do next, so lets wait for someone will take over.

1 Like

I understand. I also thank you very much for the intention and the help :slight_smile:

there was 2, 1 PciDynamic and 1 the ol regular Setup, so i was confused which is the real setup, since on Setup 0x387 have the toggle for it.

Does anyone have any ideas so that I can enable the 4g decode?
On the other hand, I tried to make the dsdt patch, but I’m having problems

AmiBoardInfo.zip (2.2 KB)
If I use “AMIBCP”, can I enable 4g decode?

I modified the bios, but when I want to update, it says “secure failed” How can I remove the restriction or sign my bios?

UPDATE: In the end I managed to make the modification with AMIBCP, use the following guide to achieve it. [Guide] How to flash a modded AMI UEFI BIOS

When I flash the bios, I see that the options were saved as expected, but when I load windows everything freezes. :confused:

@kingdzv What you say sound like a DSDT issue but AmiBoardInfoTool doesn’t support your mobo so idk how to fix it. Maybe try to boot Linux with 4G on and dump DSDT from there to see if there’s an issue ?

1 Like

In the end I was able to make the bios modification, I saved the changes correctly. I could verify that when entering the bios, but then I could not enter windows.

I’m trying another method, but I’m also stuck. Honestly, I don’t know what else to try :frowning:

Yes, I understand. There are two setting for configuring Above 4G. The checkbox and the one with toggle.
But why offset is 0x387 after all? I asked a friend of mine to extract Setup IFR tables from the BIOS uploaded.

And the variable offset there is 0x38A. It might be BIOS version dependant, I guess.

I suggest trying “setup_var_cv Setup 0x38A 0x1 0x1”. Let me know if it worked, @kingdzv.
Provided that it didn’t work, and the genuine BIOS is installed in order to exclude any doubts. You may search for DSDT in some other module, even in freeform section.


Thank you very much for continuing to help me.

I tried, but it doesn’t work, I have some conflicts.
Now GPU-Z does not show anything, windows starts normally… but I notice the pc a little slow :confused:

1 Like

could you try this (enable above 4g decoding manually like what you did, or if you did flash my bios, try the grub method again like what i suggest before):
ModZ17MOCF7.rar (7.7 MB)

1 Like

Unfortunately, when flashing the sent bios, the system does not turn on. The board is dual bios, so I already restored everything.

Is it possible that it is because the bios sent does not have the coffelake microcodes?

@kingdzv This is DSDT issue, it can be fixed. See DSDT Patching · xCuri0/ReBarUEFI Wiki · GitHub “DSDT broken 4G Decoding fix (Haswell and up)”

It’s a common issue on ASRock boards


I tried but it gives me an error
I did the steps, but I think something is wrong

@kingdzv Yeah AmiBoardInfoTool doesn’t seem to work on these newer boards.

It seems to be that the DsdtAsl module contains the DSDT on these boards

Using iasl to decompile it shows it does contain a valid DSDT. The QWordMemory does seem a bit weird, usually QWordMemory is under _SB/PCI0/BUF0 but on this board it’s under _SB/EPC/RBUF. It seems to be related to Intel SGX rather than PCI device allocation

I’ve updated to wiki to add a DsdtAsl method which seems to have worked for other uses, you can try it.

You can verify if the issue is related to QWordMemory by checking if you have Large Memory in Device Manager


it does have, check it on coffeetime

1 Like

I’m trying to keep up, but I don’t understand how to run this step

Could you help me a little? Should I execute this for CMD?

I got the bar working on old dell 7810

16gb bar was really easy to do tried to turn csm off but system won’t boot after that but rebar works like a charm

Save the raw section body to DSDT.aml using UEFITool and run that command in cmd yes


I managed to use the shared bios. It wasn’t a microcode problem.
The problem was the ME version
The modified bios with only that detail is the following.

Then do what is indicated, use the grub method, but nothing worked.
“setup_var 0x3 0x1” = no change, 4g decode off
“setup_var 0x387 0x1” = does not start windows
“setup_var_cv pci_common 0x3 0x1 0x1” = no change, 4g decode off
Z17MOCF7.60MOD2.zip (8.0 MB)

Just one detail, without applying any of this, I can activate the resizable bar at 1gb (with the bios shared by you). Likewise, when I try to go up to any higher value, it doesn’t start the pc. :confused: