[Release] Resizable BAR DXE driver

Few other settings you need to change mmmio size (someone correct the name if not right)

Yer boot time for me is loooong with the arc a770 bitfircation set to x16 if you can
Mine runs at pci 3.0 x16 but power is a problem I have a 825w and either bad gpu rail or not enough juice

1 Like

I did it on dell precision t7810 it’s a few bios edits but it’s not hard

1 Like

I’ll take that in mind, I am also working on unlocking hidden options in BIOS

so are a few of us working on the dell bios what options you looking for as we have a few figured out

I have a P9X79-PRO board with i7-3930K, the CPU is “Sandy Bridge-E”. the board does support “Above 4G”. I wanted to know if it is possible to user ReBar with this CPU please (cause this is the architecture before “Ivy Bridge”).
Thanks in advance for all helpers!

Edit: Here is some proof that my motherboard is capable

For AMI IV core bios AMIBCP, mostly still works, for AMI V core bios use:
[TOOL] UEFI Editor - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)
Enabling hidden 4G decoding · xCuri0/ReBarUEFI Wiki (github.com)

There are no limitations by CPU architecture. The only thing you need is UEFI and optionally 4G decode to use full BAR size.

Right, sorry. Got confused for a second there and ran to post.

hi sorry for the late but i did some more test. about the intel a770 on the poweredge r730 looks like resizable bar is active, but in the info i see only 16gb, while i tried an rtx 3080 and i got 3 line on gpu.-z; 1st is 32mb, 2nd is 16gb and 3rd is 16mb :expressionless:
really strange thing is that in benchmark i got not good results… im still testing, but after setup fan speed to 15% and setup max performance in bios , got almost good score in unigine 2 with gpu utilization to max 60/70% and cpu freq to 1.99ghz, while before those 2 change i got cpu at 1.3ghz and gpu at 50%… maybe my psu arent good enought and are throttling power

Hello @Scruffy,

Only having one BAR value of 16GB is normal for Intel ARC A770 16GB card.

Performance is variable with these cards. It depends on the graphics API being used and any driver optimisations Intel have made.

Best regards,


tnx for the tips. so having only one bar is perfect and it means rebar is working perfectly.
can u do a unigine 2 superposition “1080p high” benchmark? im scoring around 11k.

ReBarState.exe doesn’t work for me.

ReBarState variable doesn’t exist / Disabled. Enter a value to create it.

Failed to write ReBarState UEFI variable
GetLastError: 5

Flashed via AFUWIN. 4G enables, CSM disabled. Patchs was applied.

Any suggestions? Board Asus X99 Deluxe. Bios 4101.

Tried also on linux, get Segmentation fault error.

Hello @sf1 ,

How did you put ReBarDxe.ffs into the bios file?

Can you read the file from the board to chesk that it is there?

Best regards


You haven’t applied the patches correctly then. There specifically is patch to fix this

@68k-dude yes, I put it and I also tried the bioses modified by somebody else on this forum. Same result.

@Kuri0 Version - UEFIPatch_0.28.0_win32. I put the original bios, patches.txt and execute:
.\UEFIPatch.exe .\BIOS.CAP

parseImageFile: Aptio capsule signature may become invalid after image modifications
parseSection: section with unknown type 52h
parseSection: section with unknown type 52h
patch: replaced 22 bytes at offset 46CFh C70605000000833E067506C70604000000BE01000000 → 909090909090833E067506909090909090BE01000000
patch: replaced 8 bytes at offset FC6h 0F84B300000041F6 → 90E9B300000041F6
Image patched

patches.txt has the lines related to NVram:

# AMI APTIO V NvramSmiDxe (Socket 2011-v3 MB: C612, X99) NVRAM whitelist unlock
54B070F3-9EB8-47CC-ADAF-39029C853CBB 10 P:0F84B300000041F6:90E9B300000041F6

# NvramSmi NVRAM whitelist unlock (by @vit9696)
842A454A-75E5-408B-8B1C-36420E4E3F21 10 P:9801000072:0000000072


Hello @sf1,

Maybe I am not understanding what procedure you have followed.

Where did you get the cap file?

If you are using UEFI Tool,
Extract the bios section
Add the ffs file at the end of the dxe section
Save this file.
Apply the patches.

Best regards,


This is what I did. I took the CAP file from Asus: https://dlcdnets.asus.com/pub/ASUS/mb/LGA2011/X99-DELUXE/X99-DELUXE-ASUS-4101.zip?model=x99deluxe

maybe bc I flashed it as .rom via AFUWin?

Hello @sf1,

I have performed the mod myself and I can confirm that there are two patches that apply.

"# AMI APTIO V NvramSmiDxe (Socket 2011-v3 MB: C612, X99) NVRAM whitelist unlock
"# PciBus | Don’t downgrade 64-bit BARs to 32-bit (by @Mak3rde)

Are you able to read the BIOS file from the mainboard to check that it has been flashed correctly?

Best regards,


Hi all,

Was able to modify my UEFI on my Gigabyte GAZ170X-Gaming 3 and flash it all successfully as well as set an 8GB ReBAR via rebarstate.exe

Only issues:

Black screen on boot until Windows :
(this only applies when value is set in rebarstate if 0 is set BIOs splash screen shows as normal)

GPUz shows Rebar 0 - 8192 and Rebar 1 - 256 (unsure if this is actually an issue)

GPUZ and AMD Adrenalin report ReBAR as working

RX 6800 CT

CSM disabled & 4G Decoding enabled
msinfo32 reports BIOS mode is UEFI
GPU has factory unmodified VBios so I don’t think this is GOP issue

Hello @SS_Seppuku ,

Is that an 8GB card? I thought 6800XT were 16GB.

Did you try to apply the patches?

Best regards,