[Release] Resizable BAR DXE driver

uefi patch is already correct, the bios i made have all the patches, oh also for unstable OC, you could just downgrade the MCode using coffeetime, since the latest have mitigation for spectre

1 Like

that, perfect.
but then why even with uefi patch, can’t I upload above 1gb rebar?

Now if I’m totally stuck, it looks like I’ll have to stick with the current achievement.

If there is any idea, I stay tuned to do the test. Thank you!

1 Like

@kingdzv Did you try 4GB or unlimited (32) BAR size ?

2GB often doesn’t work

Also try this patch

# PciBus | Don't downgrade 64-bit BARs to 32-bit (Skylake)
3C1DE39F-D207-408A-AACC-731CFB7F1DD7 10 P:A80274334038AF95:A802EB334038AF95
1 Like

Yes, try 2gb, 4gb, 8, 16, 32 and unlimited. None worked, only 1gb or less works.

unfortunately it didn’t work :smiling_face_with_tear:
Use everything from scratch, after uefi patch add dsdt and rebar. Still 1gb limit (anything above fails)

hi i have put dxe where u asked for, but i still have rebar disabled .
first time i added it after 7E374E25-8E01-4FEE-87F2-390C23C606CD and didnt work.
then i added after 7F7292E8-B594-45FA-92CD-78534D8B7EEC and still it didnt work.

maybe my board have some kind of big rebar size ? c610 chipset.
is it also possible to add intel arc a770 gpu support in bios ?
i noticed that if i make bslot bifurcation to 8x 8x i got bsod.
also on hwinfo pcie slot it say vga is in 1x mode, while gpuz report gpu is at 16x.
hwinfo and gpu-z always report rebar not enabled in bios.


ok looks like if i enable or disable csm in bios doesnt change as it looks like always disabled.
the other day i noticed that enabling igpu in bios showed a rebar status enabled even if it tell not enabled in bios. my guess is that for some reason enabling integrated bpu trigger something and make rebar status work different ways. with igpu disabled, pc wont boot past 1gb rebar.
now i tried with 512mb and it told me rebar enabled on hwinfo and gpu-z, but in the secion “bios enabled” it was always off till i changed to 16gb. after that even intel arc control show enabled in bios.

now only problem is fan very loud and loading app time very slow. also framerate are low like gpu drain max 120 watt instead of 200. that could possibly be my dual 750watt that are not designed for discrete gpu and i should get dual 1100 watt for better performance.
for now however im very satisfied to found the problem relaying in rebar status.

edit2: looks like disable cms in bios (alweays seen as disabled) give more fps in benchmark.

@kingdzv what happens when you connect monitor using to motherboard igpu when using 16GB BAR ? do you get any video output or still boot failure ?

1 Like

I had tried and it does not give an image. Likewise, as I understand it, on the z170m boards formula asrock… with the hardware mod and the mod on the processor joining two pins, all this blocked the use of the igpu. Also, I will try again

So in the end, when you did enter it under the GUID i told you (or maybe you did use my bios?), it works with charm with csm disabled right? For performance i couldnt know a clue about that, but if you do have big rebar size, just set it at 32 on rebarstate.exe.

So you could now confirm that your board, with either my or your bios (thing is rebar dxe is inserted under the guid i told you), CSM is disabled for sure, and Above 4G Decoding enabled, you could do rebar fully?

i think placing dxe would have worked both with my and your placement. the thing that make it work was to enable onboard vga. it work even with legacy boot rom enabled or disabled (cms). it say rebar enabled in intel arc control onjly if i set it to 14 (16gb). if i remember set it to unlimited gived bios error (not sure 100% as i did many try with different values).
for gpu performance, i think problem could be related to different things.
gpu usage never exceed 74% or 163 watt.
so or psu are not enought power, or pcie doesnt support 100% intel vga (dell only support natively some king of compute nvidia gpu), or it can be some bad optimization at all in the whole system. after i added nvme boot support by replacing dell driver with custom driver i have now pcie ssd boot, but it come back to give whea uncorrectable error when installing drivers.
before rebar and nvme driver , when setting mmio to lower memory support to 512gb i didnt had crash annymore .

so my question is: is there a way to update bios to make vga more compatible ? like gop or some pcie specification; now when i run unigine 2 benchmark, it doesnt show gpu temperature and gpu usage, like unknown gpu. in dell lifetime controller when i go to pcie4(gpu slot) i see all undefinied, wile if i go to nvme slot i have speed, manufacturer and other values.
woulòd be cool to change bios support for some nvidia card i dont need and replace it with intel and rtx vga support. always if that make sense at all. on bios ive seen some pciedevice dxe… maybe replacing it with one of a good newer board would give full support for intel vga.
if i install old 9800gt from nvidia, fan speed stay low and pc never crash.

tnx for the help :slight_smile: more then use this pc as gaming pc, im happy to have solved that problem where i am now.
for gaming i use my clevo notebook with z270 chipset and 9700k @4.7ghz and rtx 3080 150 watt gpu on my qhd philips lcd 27 170hrz gaming monitor :smiley:

You were right, validating from the igpu and then going from windows to the nvidia gpu. It worked!!! :raised_hands:

But there are several problems
1_CSM when I deactivate it in bios, it automatically activates.
2_I can only activate the nvidia gpu with dual screen.
3_Using dual screen I lose the HDR (I use a sony a80j tv)

Would it be possible to solve this? From what I see, several are having this problem.
And if I modify the bios so that by default it always remains “CSM=OFF”??? I remain open to suggestions.

UPDATE: i have 20% less performance with 16gb rbar :smiling_face_with_tear: 1gb resizable bar works best

EDIT2: Disable the IGPU, now if it works fine.

Doing a quick comparison 1gb rbar vs 16gb rbar, the difference is 1%/2% higher in 16gb rbar.

Now I just need to be able to keep this, without having to start with the igpu when I start windows. Is what I say possible?

@kingdzv both @Adiel235 and @dsanke had this same problem and fixed it this way. iirc @Adiel235 connected both iGPU and GPU to same monitor and disabled the iGPU in windows.

this probably can be fixed with patching btw but reverse engineering this isn’t going to be easy.

You could probably use a dummy HDMI/dp cable on the iGPU and see if that works

1 Like

if you’re not sure CSM is disabled, try to disable CSM, but also enroll/install platform keys/secure boot keys. with secure boot keys installed and the mode is on user/custom, your board will run full uefi.

Also you need to use nvidia profile inspector to force some game to actually use it, and when it came to rebar size, just put it to your vram ammount, for example my 3060Ti is 8GiB, so i put 0x0000000200000000 for rebar size (use Decimal to Hex to find the ammount, use Byte to Gibibyte Converter to get the results), so if you’re on 10GB, set rebar size on 0x0000000280000000.

1 Like

Thanks for all the suggestions. @Kuri0 @Koekieezz :raised_hands:
Use the bios with the dsdt + uefi patch + start with igpu to have the 16gb rbar… (I change the screen to use the rtx 3080)
Validate with each of the following values

0x0000000040000000 = 1gb

0x0000000060000000 = 1.5gb

0x0000000080000000 = 2gb

0x0000000100000000 = 4gb

0x0000000200000000 = 8gb

0x000000000C800000 = 200mb

0x0000000012C00000 = 300mb

0x0000000280000000 = 10gb

The one with the best performance is “0x0000000040000000 = 1gb” (generally speaking, in some games other values gave slightly better results)

Also, I was testing the “CSM” theme. Modify the bios with (AMIBCP + UBU), apply it to default and always be disabled CSM=disabled.

When I start, I see that the changes were saved successfully. I configure to start from the IGPU and it no longer starts. I configure it to start from the GPU, it starts normally with “CSM=disabled”, but I have the limit of 1gb rbar.

At this time, it is already an achievement at the current point, so if in the future there is a patch to solve the bug to start from the igpu + CSM disabled, everything would be perfect. Also, now I just have to enjoy :sunglasses:

Again, very grateful to everyone for all the help given. I would not have been able to get to this point without your help. :raised_hands: :slight_smile:

1 Like

@kingdzv would be helpful if you could create an issue on GitHub about the problem of requiring iGPU. Make sure to describe it and the workaround well

1 Like

Hi Kuri0,

I have connected with a Display Port and at 1GB ReBar it boots to motherboard. Me and 68k-dude attempted to reconfigure the reBar by reconfiguring to 11. Upon posting to BIOS the computer made the the usual sounds upon starting and the signal to the screen was an assortment of green and purple shaded lines.

Thanks to removing the CMOS battery the all settings were cleared and I restarted the computer just fine.

Kindly advise.

11 / 2GB often doesn’t work on Skylake. Try 12 (equal to 4GB) and make sure 4G decoding on and CSM off. Also boot with monitor connected to iGPU

Hi, buddy.I have the same problem as you. My mainboard is ASRock z-170 k4/d3,I can not enable the “above 4g” option, and when I enable “above 4g mmio bios assignment” option it dose not start windows system.So I can only set resize-bar to < = 1024m.
@Koekieezz helped me a lot.He suggested that I enable the IGPU,and connect the monitor to the IGPU.But it’s not convenient for some reason.
you said “The one with the best performance is “0x0000000040000000 = 1gb” (generally speaking, in some games other values gave slightly better results)”
Is it better for me to keep it as it is

That is NVIDIA driver BAR size which is different from GPU BAR size

Not sure about others but my RX 580 performs measurably better with 8GB BAR than 1GB