[Request] AsRock X79 Extreme9 BIOS with NVMe Support


Could someone please help me with a modded BIOS?UEFI for AsRock X79 Extreme9. There seems to be no available one to download from other topics. I’ve been struggling for hours to find one. And I am quite a noob in this area and I don’t know how to mod it myself. Thanks in advance


Take a look here


I downloaded that one as it was the only one available, I flashed it, but it would not show the NVMe drive even if it was the only drive connected. I tried converting it to MBR and GPT and nothing. So I simply assumed it doesn’t work.

Once I put the Windows 10 USB stick in, the windows config starts up but it will not install Windows on the NVMe under any circumstance. It just says that windows cannot install on this drive.

I’ve been trying everything I could think of for the past 12 hours and I have not been able to either make it appear in UEFI/BIOS, with a Windows 10 installed on it separately on another PC with an M2 slot. I installed both as MBR and as GPT and tried but to no avail. As I thought that if it had a boot partition, it would see it, but no.

It is driving me mad and I’m 100% fuming after all this time.

Also, CSM or legacy mode option does not show in BIOS whatsoever. I have genuinely exhausted every little bit of my limited imagination.

[quote=“hotspotter, post:4, topic:92799, full:true”]
(post deleted by author)
[/quote]The adapter I’m using is a Glotrends dual M.2 NVME & Sata, but only the NVMe drive is installed.

The drive is a Samsung 512GB Dell proprietary version of a Samsung 980 Pro, which is basically a Samsung 980 Pro, only not labelled as such.

Mobo is AsRock X79 Extreme9 with BIOS v4.00

BTW, the link that you sent me to your uploaded modded BIOS file is flagged up and instantly quarantined by Windows Defender as a Trojan:Win32/Bearfoos.A!ml

false positive? i never upload a virus (why would i)

I imagine it’s a false positive. I went by your statement and installed it anyways. I didn’t really have an alternative so cannot be picky. But it installed fine, no problems there. Just that nothing works and I’m out of troubleshooting clues

So you’ve flashed my bios? tried to use windows install and try to install it on nvme? or did your nvme drive didnt get detected on windows at all?

I have flashed your bios. I tried the NVME drive with windows installed separately (on a SEPARATE computer that can install the windows on it) and I ALSO tried to install windows on it while it was connected to the PCIe adapter.

@hotspotter, try this. Add only
X79E9_4.00_mod.zip (4.9 MB)

ON Windows, sure it gets detected, but it did get detected even before any bios mods. Like any other storage drive. I came on here to use your mods to boot windows 10 from it. Or to make it boot windows as a bootable drive.

Hi Michael

Thank you very much. Give me ten minutes to flash that on the system and see what happens.

BTW, could you give me some instructions on how to install Windows 10 on it? Like what’s the most appropriate way to tackle this? MBR/GPT? Fresh install onto it? Already installed Windows? Anything I should do in particular?

I’ve got multiple PC’s and parts and can play around. Plenty of other drives too, to aid in this situation.

Edit by Fernando: Unneeded Annex removed

Prolly fresh installation is better than installing it on another pc.

I was wondering how did my bios couldnt detect it, as it have nvme dxe 5 and samsung ahci m.2, with the addition of resizable bar support.

the other guy on the post said it works, nvme get detected after windows installation. so it might that my bios didnt have any issues.

So yeah the option here is to clean install windows after a bios flash. also make it gpt first, before installation, make sure windows installation drive is GPT/UEFI, then set csm disabled on bios, and then save and exit, then during windows install choose custom, and format the drive to gpt (if its mbr, then use diskpart to convert it to gpt, use Shift+F10 during before installing the windows in windows installation)

@hotspotter, I think, only clean install and only in UEFI mode (BIOS setup). Unplug electrically all other disks, otherwise Windows Boot Manager will writing anywhere.
May be, you will not see your SSD in BIOS setup. It`s normally.

@hotspotter, why in CAPs? :smile:
I edited and UpLoaded new bios mod, opened with AMIBCP any Boot items for choise CSM/EFI modes.

@hotspotter, reload and reflash my mod, I correct it for you - CSM/EFI opened. I think, you in CSM mode. Try it.

@ hotspotter
Since there was no reason to start a new thread about the same topic, I have deleted the other thread, put this thread into the correct Sub-Forum and customized its title.
If you want to boot off an NVMe SSD, you should follow the “Step 4 - Installation of the OS onto the NVMe SSD” chapter of my guide, which is within the first post of >this< thread.