[Request] ASRock X99 Taichi - Adding IntelRCSetup to UEFI (BIOS) GUI

No visibility changing to USER in Access/Use, with AMIBCP?
If not you may try this tool:
[TOOL] UEFI Editor - BIOS/UEFI Modding / BIOS Modding Guides and Problems - Win-Raid Forum (level1techs.com)

Further questions/info on your progress with this tool, post on the related thread, not here.
Good luck

How can this tool help me here ? I don’t think I need it. Whatever this tool does I can do the same manually with ifr extractor and hex editor.

UEFI Editor can help. There’s 3 different methods to add IntelRCSetup. Mind the top bar with menus. It must be possible to put IntelRCSetup there.

The problem is that IntelRCSetup is in “Platform” UEFI module and not in “Setup” module. I just tried this online UEFI Editor tool, I was able to open up “Setup” as documented, but when I try to feed it with “Platform”, it refuses to take it.

When I open up just “Setup” module with UEFI Editor, I can’t see anything related to IntelRCSetup there.

I understand that I need to replace Form Id of a form that is visible and not need with Form Id of IntelRCSetup. But what if that new form is in different file ?

Can you give me some tips on how to proceed ?

Section_PE32_image_Setup_Setup.sct.0.0.en-US.ifr.zip (865.7 KB)
Here are 4 files you need to open up “Setup” in UEFI Editor

pdf.zip (202.4 KB)

How did you open “Platform” (IntelRCSetup) in the Editor ? It takes only “Setup” for me.
How do you know the offset where to put GUID ID in Section_PE32_image_AMITSE.sct ?
What is the last screenshot ? The motherboard has bios with graphics GUI, and not that plain text one.

I renamed the file.

OverPowered TONGFANG CyberPower Machrevo MACHENIKE - Unlocked BIOS Guide W/ Files
Thanks to this topic.

I know. I’ve found the screenshot on the web. :smile:

This is amazing! I was kind of skeptical, didn’t believe that it would work, but it works!!!
Menu item doesn’t fit the screen. You can see it in upper right corner and it continues to the next line, upper left. Do you know how to shrink that upper menu to fit this new additional item ? :crazy_face:
I tried it on a different ASRock X99, not Taichi one, but they are all the same.

To return the top bar to normal, you can only replace another menu with IntelRCSetup, for instance, security. Or try another way of accessing IntelRCSetup.

On Taichi you might need to insert the GUIDs twice.

Yes, I can try to add it instead of Security and move Security somewhere else, as it is in Setup module and should be relatively easy.

Hi man
Overclockers.ru banned me again LOL
Very interesting topic you have. Did you try undervolt by bios already or preconfigured raw-driver still needed to change voltages?
Could you explain what have you done step-by-step for my mobo?

It doesn’t work on ASRock with locked CPUs. But works on Asus. The reason is still unknown.
Pm me your bios region (fptw -bios -d mybios.bin) and I will add this mod for you.
Don’t contaminate this thread with unrelated stuff please.

I mean that unlocked Intel settings. Maybe that one will accepting instead of asrock one.
Core and cache voltages needed. System agent voltage is correctable by default.

I tried to find asrock’s voltage data offset with no luck. If someone direct me how to calculate the address I can recompile raw driver to get that settings from that points

If I compare bioses via changes on amibcp (intel settings) there is too many changes instead of simple points.

No, it doesn’t work on ASRock with CPUs with locked multiplier. Works with CPUs with unlocked multiplier though, like E5-1660v3.
It works on Asus though, core voltage offset, cache voltage offset and core/cache multiplier as well up to the highest available one.
The reason why it works on Asus and doesn’t work on ASRock is unknown. The only person who can figure that out is Nalex, as he was able to fix similar problem for Huananzhi X99, but we don’t have a contact with him.
He says on his site that he installs some kind of driver for that. I wonder, why CPU with locked multiplier needs a driver and CPU with unlocked multiplier doesn’t need it. I doubt that Asus installs a special driver for that either.

It’s reasonable. Check this out: ‘GitHub - freecableguy/v3x4: Intel(R) Xeon(R) Processor Max Effort Turbo Boost UEFI DXE driver’. I think the tool installs driver like this.

The question is how can we adjust cpu/cache voltage offset from the original bios. And why it works on Asus from its original bios and doesn’t work on ASRock.
We are aware of those third-party dxe drivers that hard codes those values for core/cache voltage offsent and cpu multiplier, that are gone btw after resuming from S3 sleep mode, but the question is how to make it adjustable from ASRock bios, the same way as we do it on ASUS boards.

What’s the other way to access IntelRCSetup ?
I was able to replace “Security” with “IntelRCSetup” but I was not able to move Security to a different place (maybe didn’t try hard enough). I don’t want to lose access to Security. What if I need it some day ? :wink:

Because ASUS allow it. Intel’s limitations to OCing is just a reccomendation.

I think it’s all about memory registers. You know, like a multiplier limit on some H77 boards.
I don’t know how exactly make the voltages adjustable, we need to study things better.

UniversalAMDFormBrowser app.
Or the way genius239 unlock external forms.

It doesn’t work after sleep. That why people (me too) using PAI or RAW driver. As my mobo accept only raw I decompiled its topology for investigating, its assembly code is quite simple and almost the same as dxe. I already tried to modify it by hex it works just fine so all I need is correct address where settings(cmos) holds required data saved by user at bios settings