[Request] ASUS P9X79-WS BIOS with NVMe Support

@SoOzAciD :
Have you tried to simply replace the currently used NVMe SSD by the new Crucial NVMe SSD and to get Win10 freshly installed onto it according to my guide?
If this procedure should not work, I recommend to RMA the Crucial SSD.

CSM can be activated, but the BIOS settings must allow booting in UEFI mode.

Crucial works fine in my lenovo P51 no issue at install and boot, brand new disk, no rma at this time :wink: ( i have 2 crucial p5 and same results :wink: )
Only freeze in my p9x79 mobo
see in bios windows boot manager see attached :wink:
I perform a fresh install in my p51 and put this one in asus mobo = BOSD machine system check
second pic, when i put usb pen drive do to fresh install, stop when need check hdd presence


Kind regards


@SoOzAciD :
To exclude, that the NVMe module hasn’t been correctly inserted by you into the mainboard BIOS, please attach your modded BIOS as compressed *.ZIP file.

i used this one : P9X79-WS-4901-NVME-Advanced-SA-Mod-Redo4
maybe i juste need a stock bios with simply nvme module
Thank you Fernando

P9X79-WS-4901-NVME-Advanced-SA-Mod-Redo4.zip (4.95 MB)

@SoOzAciD - That looks like a BIOS I made, which would already have NVME mod done. BUT, it “may” not be the final proper mod BIOS from that thread, check to be sure
I thought it was this thread, but I don’t see the BIOS you mentioned there, so check whatever thread that is from to be sure it’s latest one I posted

If you do not need bifurcation, I can just make you stock mod BIOS, but it would be same as any bifurcation BIOS too, in regards to NVME - the Bifrucation mod BIOS just have more settings visible to you in the menu

Hello Lost_N_Bios,

nice to meet you :slight_smile:
Thanks for this bios file but it works with an WS too ?
my current bios is 4901 this is 4701

@SoOzAciD :
Attached is the BIOS 4901, which has been modded by me this evening. The only thing I have done was the insertion of the NvmExpressDxe_4.ffs file.
Good luck!

P9X79-WS-ASUS-4901modbyfern.rar (4.36 MB)

Yeah many thanks ! I try it now, i’ll be back soon :slight_smile:

==> Flash Ok :wink:
==> Light north bridge menu :slight_smile:
==> start a fresh install => crucial P5 won’t start, i try with my other P5 (working in lenovo P51) same result = BSOD machine check exeption and automaticly shutdown :frowning:

Thanks for my new light bios
Just really want to know why some nvme won’t boot in some machine ( i m not alone ;p )

keep in touch :slight_smile:


@SoOzAciD - The BIOS I made, which you referenced, is ONLY for the model it says in the folder/link, if it’s not WS BIOS then it’s not for WS Board.
I looked back up, and YES, you mentioned/linked WS BIOS, which is tested by many members and it works properly.

I’ve seen some compatibility issues with Crucial P5 drives on modern boards with native NVME compatibility, so you may have problems to get that working on an old X79 board.
Best to use the P5 on some other system and pick a more mainstream / general / seasoned NVME for this older board

Lost_N_BIOS, Fernando,

thank you so much, new tech is not for the best :slight_smile: in an old time, an hdd is an hdd :stuck_out_tongue:
I put my samsung p961, working well
Maybe i flash with your full option bios again :slight_smile: ( a tutorial of this one is very appreciate :stuck_out_tongue: )
I keep in mind, what is the incompatibility reason of this NVME or the other. Maybe OpRom udapte or SMBIOS
SMBIOS 2.7 to 3.0 possible ?
ami dot com/en/news/press-releases/american-megatrends-announces-support-for-smbios-320-specification/
One day i perform a clone of my samsung to my crucial and it work…i want to do a fresh install…and stop working…perform a new clone…don’t work. It’s maaaaaaagic
If i find a solution or a reason i tell you
X79 is not dead !

Warm regards

@SoOzAciD - Yes, sometime stuff is just too new / not compatible with old stuff, or even some new stuff until manufacturers fix compatibility issues in BIOS.
Good to hear you got older NVME working in there now

About the BIOS I made, you only need to use that if you need bifurcation options (if using Hyper card, or other card that allows more than one NVME on same PCIE Slot)
But, you can use it if you want, there is a lot more BIOS options, but I’m not sure if any of those will be useful to you in a single NVME use scenario
No tutorial is needed, flash it the same way you flash any other BIOS via USB Flashback.

Hmm, if cloned OS works for you on P5, but clean install does not, then sounds like you are doing something wrong (wrong BIOS setting, or NVME is not RAW or GPT before starting windows installer?)

Here’s how I suggest cloning personally, you can do it with a system you’re already using, or make a clean install on that same drive you cloned from before, then clone the clean install
Installing Clean Win7x64 on M2.2280 PCIe Gen3x4 SSD A-DATA SX8200 Pro (post #5)

And here’s how to make NVME RAW before trying a clean install (nothing to do about Clone, but I would also do this first, to be sure NVME is ready for clone and setup proper)

You can use diskpart in windows from OS (Direct from any CMD Prompt), or from installer ISO (press Shift + F10 on the first setup screen where you pick language)
Or from repair/troubleshoot options in the installer/setup. Remove all other drives, so you have only USB and target win10 drive. Then from CMD prompt do the following

1. Diskpart
2. List Disk << Here, identify what your target disk is by size/name etc, and make note of it’s #, you will use it’s # next - (If in windows, these #'s will match what you see the drives shown as in Disk Management) - Be sure you do not select your USB or main OS drive if in OS
3. select disk # << Here, instead of #, put target disk #, example >> select disk 0
4. clean
5. Exit

Reboot and run the installer again, then point it at the raw/blank drive, do not load any drivers or create any partitions etc, just select drive and click next

Clone OS work one time only :frowning:
Diskpart or other are ok for me
Any state of this disk hang my system (raw at this time and won’t initalise)
Witch setting can i tune in bios to do this one run as well ? if you know :slight_smile:
I’ll try your method and do my feedback

See you :slight_smile:

feedback :
Lost_N_BIOS cloning method not working for me because system hang before it start :stuck_out_tongue:
made a modded bios with @Fernando 's great method :slight_smile: (mmtool) on MSI B75IA-E33 (my bench) ==> P5 crucial working great
What is the problem with my Asus P9x79-WS mobo and this nvme model ?..i try do made my onwn modded bios, same result, after check usb keyboard and mouse(off) and hang :slight_smile: all features disabled :slight_smile:




@SoOzAciD : @Lost_N_BIOS :
a) SoOzAciD started his help request within this thread,
b) other ASUS P9X79 mainboard users may be interested in the results and
c) the related discussion got meanwhile very voluminous,
I have moved it completely into this already existing thread.
I hope, that this is ok for you.

@SoOzAciD : @Lost_N_BIOS :
After having written my last post I have realized, that the original thread was about an ASUS P9X79 (without any suffix) and this discussion about an ASUS P9X79-WS, I have split the source thread.
I am sorry about the confusion.

P5 not compatible with this board it seems, nothing we can do. Use other NVME here instead
Not all things are compatible always

thanks for your time, you and @Fernando are great teachers :slight_smile:
We fight for the future, nothing impossible, we need to know why :slight_smile:
One day my friend…one day we know…

Merry X-Mas All, wish you the best, take care

@SoOzAciD - You’re welcome, sorry we could not find solution for P5 on this board
Hope you have a good time during all the holidays, and have a great New Year too!

Hi mate!

I’ve found your discussion today because I’m having the same problem with a Samsung 980 nvme. Ive updated the bios with the NvmExpress.ffs by my own modded bios and also tried the bios files from this discussion and i as able to find the Nvme from the windows installation menu but after restart my computer / bios won’t detect it.

Maybe it’s the same problem as with your P5 disk? Did you try with other M.2 drives which worked? Thanks.

only read OP, not thread, sorry.
maybe this is what you want?:

didn’t realize the post was from 2020, it was just on page 1…

Welcome to the Win-Raid Forum!
I recommend to follow the Guide about “How to get full NVMe Support for all Systems with an AMI UEFI BIOS”, which can be found >here<.
Good luck!
Dieter (alias Fernando)

Why did you link to an Overclock.net thread, which is neither up-to-date nor supported since 2015?