[Request] ASUS X570-I BIOS update or ROM ID change


I’m using a prebuild PC from Corsair which has an ASUS X570-I gaming build in and considering to upgrade my CPU to a 5800x3D.
My problem now is, that the current BIOs is to old that it supports the new CPU and Corsair uses a custom BIOS with a different BIOS Rom ID.
Although the Mainboard is the same as the ASUS X570-I I can’t make an BIOS update to any BIOS from ASUS, because EZ Flash won’t do the update because the ASUS BIOS “ROM ID is incompatible with existing BIOS!”. My guess is, that COrsair uses their own ID an that it’s different than the ASUS ID.

I’ve tried to use AFUWINGUIx64, AFUWinx64 and AFUEFIx64 but they all freeze my system as soon as I started them.
Sadly the board doesn’t have a Flashback option.

I’m not sure how difficult it is to change the ROM ID so EZ Flash believes it is a proper BIOS and if this would help.
Maybe there is a way to update the Corsair BIOS .cap so I can use EZ Flash. Sadly EZ Flash doesn’t recognize bin/rom files.

Here are links to both BIOSes from:

Thanx for any help!

Hello @FairXeon,

Have you tried the AFUwin and the /GAN option?

There is a link to a version of AFUWin that supports the /GAN optoion on the following guide page.

If you get stuck, I’m sure someone can help.

Good luck



thank you for your response.
I somehow can’t use the AFU tools. As soon as I start one of them, e.g. when I hit enter using the command “AFUwinx64.exe /U”, my PC just freezes. This happens even in an EFI Shell. I haven’t found out why this happens yet.

Maybe there is a solution to get AFUwin running, but at this point I see EZ Flash as my only option.
If I missed another tool I could use I will definitly give it a try.

The previous GAN version mentioned is for AMI Aptio IV, there were no “leaks” of a similar version with GAN cmd for Aptio V that should be your bios core.
There were some cross flashing of bios with success from a few Asus and MSI mb models, made by some users (took their chances…).
A full backup of the current bios is advisable and a CH341 programmer for further recovery, if this is a path you choose to take.
Others went strait with programming the OEM bios with the programmer.

I wasn’t clear which AFU version I’ve used. I’ve tried the latest (https://www.ami.com/bios-uefi-utilities/) and some older versions of the Aptio V Ami Firmware Update Utility. But as mentioned my PC freezes as soon as I start them, no matter which command I use.

Is a full backup different than the provided bios file? Since I’m currently unable to use AFUwin etc.

I thought using a programmer. I had hoped there is an easier solution, e.g. changeing the ROM ID within the cap file or getting AFUwin running somehow.