[Request] Bios for Z370 Fatal1ty ITX for XOC

I’m looking to get/make a bios for the board above for extreme overclocking. The board is (physically) nearly identical with the Z390 Phantom ITX, which has support in bios for coldbug removal as well as nearly unlimited voltages. The most important voltage for me is VMEM, as I intend to do memory overclocking on this board.
Does anybody have advice on who or where I could get such a bios from, or how to make one myself?
I believe physically modifying the motherboard is a possibility for vcore and vmem control, but I don’t know about the “coldbug killer.”

@AutisticChris - Is this your board? https://www.asrock.com/mb/Intel/Fatal1ty…20Gaming-ITXac/
And, this the other board you mentioned, correct? https://www.asrock.com/MB/Intel/Z390%20P…ITXac/index.asp

Do you have flash programmer? Flashing over to the other BIOS may be best/easiest option, or may be only way this is possible.
And as you considered I’m sure, the two boards may not be as identical as you think, internal power delivery may be different, traces, VRM’s used etc, so your board may not be able to utilize the others features/functions even with it’s BIOS on your board.
I checked your BIOS, the settings you are asking about are not there (ie not hidden from you, simply not there, entire OC Tweaker section is removed).

Please check BIOS main page and see if ME FW version is shown, if not then download HWINFO64 and on the large window on left side, expand motherboard and find ME area, inside that get the ME Firmware version.
Once you have that, go to this thread and in the section “C” download the matching ME System Tools Package (ie if ME FW version = 10.x get V10 package, if 9.0-9.1 get V9.1 package, if 9.5 or above get V9.5 package etc)
Intel Management Engine: Drivers, Firmware & System Tools

Once downloaded, inside you will find Flash Programming Tool folder, and inside that a Windows or Win/Win32 folder. Select that Win folder, hold shift and press right click, choose open command window here (Not power shell).
At the command prompt type the following command and send me the created file to modify >> FPTw.exe -bios -d biosreg.bin

Immediately after you successfully create the above dumped BIOS region, please run this command and if any error stop, do not try to do again, show me image of the command entered and the error given on same image
FPTw.exe -bios -f biosreg.bin

If you are stuck on Win10 and cannot easily get command prompt, and method I mentioned above does not work for you, here is some links that should help
Or, copy all contents from the Flash Programming Tool \ DOS folder to the root of a USB Bootable disk and do the dump from DOS (FPT.exe -bios -d biosreg.bin)

As a general note to you on extreme OC with this board, I found this in your BIOS about the CPU PLL (From it’s help string, in case you didn’t notice or know already)
Default is 0.900V, each step is 0.015V. Adding 9 ~ 15 steps will helps CPU PLL to lock internal clock during High frequency under Ln2 cooling. For Example: 1.020V ~ 1.125V will be proper value.
But the voltage level will be different on each processor. User has to find the best value for your own processor.
CPU Vcore Voltage must higher than CPU Internal PLL Voltage, or your processor will hang.

I think your first move should be to purchase a CH341A flash programmer + SOIC8 test clip w/ cable.
This way you can backup your entire current BIOS, then crossflash the other boards BIOS in there as quick test to see if it runs OK or not, then if it does we can create BIOS from that boards BIOS with your board specific details.

@Lost_N_BIOS I do have a CH341A flash programmer on hand, and I believe it came with a cable but I’m not 100%. I’m interested in testing the Fatal1ty board for mem OC capability before I do any LN2 overclocking first, so that is the priority.
Once my board arrives I will get a bios dump. It’ll be ~ next Wednesday.

If you have a programmer, then we can try anything you want safely, and I can rebuild a BIOS in numerous ways, Frankenstein of this or that from either, if the other BIOS doesn’t work straight up on that board for you.

@Lost_N_BIOS I believe I have seen someone attempt to use the full-on Z390 bios and I believe it had issues with ME, so a Frankenstein is likely needed.

The ME issues, could be due to ME version with whatever CPU they used, or maybe they didn’t transfer ME FW settings from OG board into the other BIOS before using it.
Some people don’t know how ME FW works, and often just blindly insert/update to a stock ME FW rom without even putting board specific setting in it, so it’s hard to know what happened in that instance, especially without knowing their exact complaints/issues noted during those tests.
I read the thread, none of that is discussed there at the end, but it sounds like he knows these things need done, however unsure if he tried doing or not, or tried changing ME FW SKU etc.
A change at FD region may be needed too, which is not mentioned at all on that page. However, yes, it’s not a problem for me to simply pull the complete BIOS settings from one to the other

@_haru @svarmod @revlaay @PCGH_Torsten one of these guys may be able to tell us exact specific changes required to run Z390 BIOS on Z370 board, or if it’s not possible etc.

I’m aware that you can change the SKU and do that sort of thing on 100/200/22nm 300 chipsets, but I have no idea how that would work with a 14nm chipset bios on a 22nm board.

@Lost_N_BIOS I have my board now, will post back as soon as I can get it running. I don’t believe it is capable of modifying XOC voltages, but I believe it may still control vttddr. I could be wildly incorrect though.


This is exactly why I think I could not get it to work, but I’m far from a pro when it comes to software side of things.
The bios from the Z390 board *should fully work with the voltage controls since that hardware is all the same.
I was also trying to gain access to the XOC voltages and and bypass the the bios limits for vCore, VCCIO, VCCSA and vDDR/DDR VTT
If it’s possible to port the voltage section from Z390 to Z370 that should also work, but that is not easy as I’m sure most of you know

This was a dead end for me. The PCIE slot was already dead on my board so I returned it