[Request] bios mod for supermicro X10slm+-ln4f

Do we already have a modded bios for supermicro x10slm±ln4f?

Im eager to get it booting from the NVME drives, but somehow im stuck in modding the bios

[HowTo] Get full NVMe Support for all Systems with an AMI UEFI BIOS - Special Topics / NVMe Support for old Systems - Win-Raid Forum (level1techs.com)

Whats your issue performing the mod by the guide?

EDIT: Gonna be straight with you… this guide is very well elaborated, users need to pay attention to what is written and follow its directions.
Whats the issue on Step 2 - BIOS modification (2 alternative Methods)?

One more thing…in mod world, NO ONE can assure you of 100% success or a risk free operation, so its your choice only, no responsibility from the guide author or the forum, take it or leave it.

EDIT: Supermicro wants login for bios update access. Share the bios file or the dump.
MMtool 4.x or 5.x?
UEFI tool method as alternative.

Im somehow not able to get paste the search DXE thing, and where to inject the driver :frowning_face:

i don’t want to risk my board :smiley:

Getting this error during injecting the driver

Link to the bios file

x10slmp1_310.zip (4.1 MB)

Im using 4.x

I will also try with V5, alternatively you can post me the modded file, will try right away

Strange on V5 i get


Be careful, MMTool 4 will insert the module itself properly, but the µcodes get moved and FIT won’t be adapted. Tried EUFITool 025, 028, MMTool_4

So I assume one would have to adjust FIT manually. There’s a thread somwhere, but I’d have to search, too.

Thanks all,

Got it working…


Since your first question was if there was an already modded bios available you surely want to leave at least some information which method you did you use and maybe attach the modded bios to your latest post for the next one searching?

Thanks in advance!

1 Like

This is the working firmware.

My friend did the MMtool thingie, it seems from version 5.x there is a 2nd edition or something, which worked perfectly.

x10slmp1-modded.zip (4.0 MB)


Thanks a lot! So seems that the µcodes no longer referenced correctly in _FIT _ aren’t used to boot, fortunately!

1 Like

Hi Guys,

So i’ve got an issue now, i tried installing windows 10… with the modded bios, and every LEGACY setting in the bios changed to EFI or UEFI

it took me a while to even get the efi bootloader for iwndows going, but that’s solved now… so im getting into the setup, and it sees the NVME drive, but it won’t allow me to install on it whatever setting i tried.

Gives me the error:

Windows can’t be installed on this disk:

Windows cannot be installed to this disk. The computer’s hardware may not support booting to this disk. Ensure that the disk’s controller is enabled in the computer’s bios menu.

It added the PATA : SS drive after the bios mod, which is I guess the nvme drives… as the windows installer sees the NVME i think we are good. But have no clue how to get passed above error message.

Any suggestions? maybe someone has the same board and can give it a shot?

ps: the sata controller (onboard) is enabled, the uefi setting for the controller is enabled and sata controller frozen is disabled (although there is nothing connected to the sata cables ofcourse as im using a pci-e card with the 2 nvme’s on it.

Well i found the issue i think.

Usb created with windows media creator makes a uefi and legacy bootable usb

With all settings in bios to efi/uefi and boot the usb as uefi device, its just keeps rebooting.

Do i boot the usb as legacy the windows installer shows up but ofcourse wont let me install windows

If i use the efi shell to manualy start bootx64.efi, the screen stays there for like 20’secs and then just reboots :confused:

Isn’t this a pic from your machine? Windows Boot Manager is the proper choice, but this get’s shown first after OS install.

I assume there’s an error with the disk ‘preparation’. Try a completely empty disk, no partitions, completely blank! EFI bootloader will get installed in the process.

yes that’s correct… well here is the story… Bios 3.4 is just fucked… you have to use 3.2 to install windows under uefi mode… under 3.4 just not possible, so i’ll try to mod the 3.2 firmware now to make it uefi boot

why i had "success"last time was that i install under 3.2, and then upgraded firmware to modded 3.4 which showed me the windows boot manager, but didn’t realize that was the correct one…

then after i tried to reinstall it with win 10, but no way to boot the win 10 usb uefi

Yes confirmed.

Please dont use the modded 3.4 firmware or 3.4 at all :slight_smile:
Ill mod the 3.3 to make it nvme boot.

I downgraded to 3.3, win 10 uefi usb boots now, and no windows installer errors anymore